Bug 588686 - [abrt] crash in hdparm-9.16-3.2.el6: Process /sbin/hdparm was killed by signal 8 (SIGFPE)
Summary: [abrt] crash in hdparm-9.16-3.2.el6: Process /sbin/hdparm was killed by signa...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: hdparm   
(Show other bugs)
Version: 6.0
Hardware: x86_64 Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Karsten Hopp
QA Contact: David Kutálek
URL:
Whiteboard: abrt_hash:7562b52b72a09bfdbecda71eb46...
Keywords:
: 589258 590649 590674 590678 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-04 09:45 UTC by David Kutálek
Modified: 2018-10-27 12:06 UTC (History)
6 users (show)

Fixed In Version: hdparm-9.16-3.3.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 19:10:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (11.69 KB, text/plain)
2010-05-04 09:45 UTC, David Kutálek
no flags Details
File: comment (2.13 KB, text/plain)
2010-05-04 09:45 UTC, David Kutálek
no flags Details

Description David Kutálek 2010-05-04 09:45:32 UTC
abrt 1.0.9 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: hdparm -g /dev/dm-0
Attached file: comment
component: hdparm
executable: /sbin/hdparm
global_uuid: 7562b52b72a09bfdbecda71eb46c122fb4a9f517
kernel: 2.6.32-22.el6.x86_64
package: hdparm-9.16-3.2.el6
rating: 4
reason: Process /sbin/hdparm was killed by signal 8 (SIGFPE)
release: Red Hat Enterprise Linux release 6.0 Beta (Santiago)

How to reproduce
-----
1. Happens always on my workstation
2. Just run hdparm -g /dev/dm-0
3. (/dev/dm-{1,2,3} does the same

Comment 1 David Kutálek 2010-05-04 09:45:34 UTC
Created attachment 411236 [details]
File: backtrace

Comment 2 David Kutálek 2010-05-04 09:45:36 UTC
Created attachment 411237 [details]
File: comment

Comment 3 RHEL Product and Program Management 2010-05-04 10:59:25 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 4 Bill Nottingham 2010-05-05 20:41:15 UTC
*** Bug 589258 has been marked as a duplicate of this bug. ***

Comment 5 Ben Woodard 2010-05-10 13:24:26 UTC
*** Bug 590678 has been marked as a duplicate of this bug. ***

Comment 6 Ben Woodard 2010-05-10 13:26:11 UTC
This happens several times per day on my Lenovo X301 with 64GB Toshiba (?) SSD

Comment 7 Evan McNabb 2010-05-10 13:41:23 UTC
Same here on my Thinkpad W500.

Comment 8 Karsten Hopp 2010-05-10 14:47:55 UTC
ioctl HDIO_GETGEO returns zeros for cylinders, sectors and heads on
devicemapper devices. There's an erroneous check for that in the hdparm sources
which causes a divide by zero error.

Comment 10 Karsten Hopp 2010-05-10 14:52:12 UTC
*** Bug 590674 has been marked as a duplicate of this bug. ***

Comment 11 Karsten Hopp 2010-05-10 14:53:01 UTC
*** Bug 590649 has been marked as a duplicate of this bug. ***

Comment 13 Ben Woodard 2010-05-10 15:10:26 UTC
I'll let it run from whatever background script that it has been running from but when I run it from the shell it doesn't seem to die anymore.

Comment 15 Karsten Hopp 2010-05-11 11:39:44 UTC
fixed package built: hdparm-9.16-3.3.el6

Comment 18 releng-rhel@redhat.com 2010-07-02 19:10:34 UTC
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.