Bug 591080 - Traceback on rhn_check "no attribute 'cfg'"
Traceback on rhn_check "no attribute 'cfg'"
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: yum-rhn-plugin (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Jan Pazdziora
Petr Sklenar
:
Depends On: 589120
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-11 07:49 EDT by Jan Pazdziora
Modified: 2010-11-10 17:01 EST (History)
3 users (show)

See Also:
Fixed In Version: yum-rhn-plugin-0.9.1-5.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 589120
Environment:
Last Closed: 2010-11-10 17:01:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2010-05-11 07:49:50 EDT
+++ This bug was initially created as a clone of Bug #589120 +++

/var/log/up2date says:
[Wed May  5 13:43:17 2010] up2date 
Traceback (most recent call last):
  File "/usr/sbin/rhn_check", line 283, in __run_action
    (status, message, data) = CheckCli.__do_call(method, params)
  File "/usr/sbin/rhn_check", line 275, in __do_call
    method = getMethod.getMethod(method, "/usr/share/rhn/", "actions")
  File "/usr/share/rhn/up2date_client/getMethod.py", line 78, in getMethod
    actions = __import__(modulename)
  File "/usr/share/rhn/actions/packages.py", line 266, in <module>
    yum_base = YumAction()
  File "/usr/share/rhn/actions/packages.py", line 62, in __init__
    self.doConfigSetup(debuglevel=rhncli.cfg["debug"])
<type 'exceptions.AttributeError'>: 'module' object has no attribute 'cfg'

I *think* this results in:
Client execution returned "Fatal error in Python code occured [[6]]" (code -1)
in the WebUI for all events (i.e. anything that runs through rhn_check) even if the task is successful (i.e. rhn_check -vvv does). The traceback might be unrelated to this tho.

Version:
rhn-check-1.0.0-1.fc12.noarch

Additional Information:
<roysjosh> red_alert, jsherrill, seems like this commit is responsible for your traceback: 2fa678d4153e2a072d8c1953c3c5a16b7a1d080c
<roysjosh> it removes cfg from up2date_client/rhncli.py

--- Additional comment from jpazdziora@redhat.com on 2010-05-05 08:51:55 EDT ---

Actually, it's 8d915a17b46d5e83a1b06d60b51c0e7ed36bf714 which seems to be out of line.

--- Additional comment from sm@sandro-mathys.ch on 2010-05-05 08:56:27 EDT ---

Additional tests show that this definitely happens in different cases:
- applying updates
- deploying config files

Also, if rhn_check is called with -vvv the following is always logged just after the traceback:
[Wed May  5 14:57:59 2010] up2date D: local action status:  ((6,), 'Fatal error in Python code occured', {})

So I guess those two things are really only one problem.

--- Additional comment from jsherril@redhat.com on 2010-05-05 09:08:47 EDT ---

went ahead and added the cfg back into rhncli.py

master:
a437034484fb40034f59c209bb95f0c912776519

spacewalk 1.0 backport:
bfa90ae335a79f88390d20894eed52bb0900c4b4

--- Additional comment from jpazdziora@redhat.com on 2010-05-05 09:54:49 EDT ---

*** Bug 587888 has been marked as a duplicate of this bug. ***

--- Additional comment from jsherril@redhat.com on 2010-05-05 11:11:09 EDT ---

Packages built:

yum-rhn-plugin-1.0.2-1
rhn-client-tools-1.0.6-1

--- Additional comment from jsherril@redhat.com on 2010-05-05 16:34:23 EDT ---

Changed the fix a little:

da27aded48e9710465a55a72d845d23779005a8d
Comment 1 Jan Pazdziora 2010-05-11 07:50:07 EDT
Clonning for RHEL 6.
Comment 2 Jan Pazdziora 2010-05-11 07:51:57 EDT
Reproduced on RHEL6.0-20100506.3 with

# rpm -qa | grep rhn | sort
rhn-check-1.0.0-4.el6.noarch
rhn-client-tools-1.0.0-4.el6.noarch
rhnlib-2.5.22-4.el6.noarch
rhnsd-4.9.3-2.el6.x86_64
rhn-setup-1.0.0-4.el6.noarch
yum-rhn-plugin-0.9.1-4.el6.noarch
Comment 3 Jan Pazdziora 2010-05-11 08:46:02 EDT
Cherry picked da27aded48e9710465a55a72d845d23779005a8d to CLIENT-RHEL-6, commit 088b44cdf069598dc4f0a97e0bc67848f061eb38.
Comment 9 releng-rhel@redhat.com 2010-11-10 17:01:09 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.