Bug 589956 - (intel-artifacts) occasionally parts of screen are garbled
occasionally parts of screen are garbled
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-intel (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
: Triaged
: 593970 595632 598326 598328 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-07 07:48 EDT by Stefan Assmann
Modified: 2010-06-16 16:35 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-03 14:09:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhel6-garbled.png (12.38 KB, image/png)
2010-05-07 07:48 EDT, Stefan Assmann
no flags Details
Xorg.0.log (77.82 KB, text/plain)
2010-05-07 07:49 EDT, Stefan Assmann
no flags Details

  None (edit)
Description Stefan Assmann 2010-05-07 07:48:10 EDT
Created attachment 412311 [details]
rhel6-garbled.png

Description of problem:
Every now and then I see part of a window being "garbled" (see screenshot). This usually goes away after a while. Happens regardless of compiz being on or off.

Version-Release number of selected component (if applicable):
xorg-x11-drv-intel-2.10.902-1.el6.x86_64
xorg-x11-server-utils-7.4-15.el6.x86_64
xorg-x11-server-common-1.7.6-3.el6.x86_64
xorg-x11-server-Xorg-1.7.6-3.el6.x86_64

How reproducible:
happens sometimes

Actual results:
sometimes garbled screen parts

Expected results:
no garbled screen parts

Additional info:
lspci -nn
00:00.0 Host bridge [0600]: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub [8086:2a40] (rev 07)
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07)
00:02.1 Display controller [0380]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a43] (rev 07)
00:03.0 Communication controller [0780]: Intel Corporation Mobile 4 Series Chipset MEI Controller [8086:2a44] (rev 07)
00:19.0 Ethernet controller [0200]: Intel Corporation 82567LM Gigabit Network Connection [8086:10f5] (rev 03)
00:1a.0 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 [8086:2937] (rev 03)
00:1a.1 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 [8086:2938] (rev 03)
00:1a.2 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 [8086:2939] (rev 03)
00:1a.7 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 [8086:293c] (rev 03)
00:1b.0 Audio device [0403]: Intel Corporation 82801I (ICH9 Family) HD Audio Controller [8086:293e] (rev 03)
00:1c.0 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 [8086:2940] (rev 03)
00:1c.1 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 [8086:2942] (rev 03)
00:1c.3 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 [8086:2946] (rev 03)
00:1c.4 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 [8086:2948] (rev 03)
00:1d.0 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 [8086:2934] (rev 03)
00:1d.1 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 [8086:2935] (rev 03)
00:1d.2 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 [8086:2936] (rev 03)
00:1d.7 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 [8086:293a] (rev 03)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev 93)
00:1f.0 ISA bridge [0601]: Intel Corporation ICH9M-E LPC Interface Controller [8086:2917] (rev 03)
00:1f.2 SATA controller [0106]: Intel Corporation ICH9M/M-E SATA AHCI Controller [8086:2929] (rev 03)
00:1f.3 SMBus [0c05]: Intel Corporation 82801I (ICH9 Family) SMBus Controller [8086:2930] (rev 03)
03:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Network Connection [8086:4237]
15:00.0 CardBus bridge [0607]: Ricoh Co Ltd RL5c476 II [1180:0476] (rev ba)
15:00.1 FireWire (IEEE 1394) [0c00]: Ricoh Co Ltd R5C832 IEEE 1394 Controller [1180:0832] (rev 04)
15:00.2 SD Host controller [0805]: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter [1180:0822] (rev 21)
15:00.3 System peripheral [0880]: Ricoh Co Ltd R5C843 MMC Host Controller [1180:0843] (rev ff)
15:00.4 System peripheral [0880]: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter [1180:0592] (rev 11)
15:00.5 System peripheral [0880]: Ricoh Co Ltd xD-Picture Card Controller [1180:0852] (rev 11)
Comment 1 Stefan Assmann 2010-05-07 07:49:38 EDT
Created attachment 412312 [details]
Xorg.0.log

forgot to mention, this is on a Lenovo T500
Comment 3 RHEL Product and Program Management 2010-05-07 10:07:53 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 6 Matěj Cepl 2010-05-20 14:23:16 EDT
*** Bug 593970 has been marked as a duplicate of this bug. ***
Comment 9 Matěj Cepl 2010-05-26 10:16:20 EDT
*** Bug 595632 has been marked as a duplicate of this bug. ***
Comment 16 Ray Strode [halfline] 2010-06-01 10:32:51 EDT
*** Bug 598328 has been marked as a duplicate of this bug. ***
Comment 17 Ray Strode [halfline] 2010-06-01 10:33:21 EDT
*** Bug 598326 has been marked as a duplicate of this bug. ***
Comment 18 Adam Jackson 2010-06-03 14:09:31 EDT
2.6.32-30 included several i915 drm fixes, so I'm calling this resolved based on comment #15.  Please reopen if anyone is still seeing this with -30 or later.

Note You need to log in before you can comment on or make changes to this bug.