Bug 590951 - Using custom repo during system install
Using custom repo during system install
Status: CLOSED DUPLICATE of bug 633369
Product: Beaker
Classification: Community
Component: lab controller (Show other bugs)
0.5
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: Bill Peck
: Reopened
: 622433 (view as bug list)
Depends On:
Blocks: 545868
  Show dependency treegraph
 
Reported: 2010-05-11 00:03 EDT by Hushan Jia
Modified: 2014-08-12 00:32 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-03 01:29:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hushan Jia 2010-05-11 00:03:38 EDT
Description of problem:
RFE:
use custom repo during system install. the custom repos added in xml files like:
      <repos>
           <repo name="myrepo_2" url="http://lacrosse.corp.redhat.com/~hjia/"/>
      </repos>

The Requires directive will add 
                        <packages>
                                <package name="make"/>
                                <package name="gcc"/>
                                <package name="wget"/>
                                <package name="procmail"/>
                                <package name="networking"/>
                                <package name="tunctl"/>
                                <package name="lzo"/>
                                <package name="lzo-devel"/>
                        </packages>
in job xml, some of the packages are not in distro repo, rather in specified repo, so this bug want to add repo support during install.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bill Peck 2010-05-11 07:35:13 EDT
Have you tried this?   Because if you had I think you would have seen it works already.
Comment 2 Bill Peck 2010-05-11 08:29:07 EDT
Oops!  Sorry, I should have tried it myself.  I was thinking of the optional repos we add automatically to the distro.  

I'll see if I can get the repos from the job added during install time.

The only downside to this is if you give a bad repo it will prevent the install from happening at all.
Comment 3 Hushan Jia 2010-05-11 21:07:29 EDT
Since the <package name="xxx"/> in job xml is generated automatically according to test rpm dependencies, so it make sense to enable this feature.
Thus, we dont need to add  <test role='STANDALONE' name='/distribution/pkginstall'>......</test> for each packages the test need.
Comment 4 Marian Csontos 2010-08-09 08:20:31 EDT
*** Bug 622433 has been marked as a duplicate of this bug. ***
Comment 6 Bill Peck 2010-12-01 16:20:03 EST
Had to revert this change since it causes some problems with anaconda.
Comment 7 Dan Callaghan 2012-10-03 01:29:29 EDT

*** This bug has been marked as a duplicate of bug 633369 ***

Note You need to log in before you can comment on or make changes to this bug.