Bug 592209 - BerkeleyDB needs compatible versions of libdb & db.h - binary mismatch
Summary: BerkeleyDB needs compatible versions of libdb & db.h - binary mismatch
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-BerkeleyDB   
(Show other bugs)
Version: 13
Hardware: All
OS: Linux
low
urgent
Target Milestone: ---
Assignee: Steven Pritchard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 595831 595834 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-14 09:07 UTC by lejeczek
Modified: 2010-06-01 18:27 UTC (History)
5 users (show)

Fixed In Version: perl-BerkeleyDB-0.41-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-01 18:27:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description lejeczek 2010-05-14 09:07:37 UTC
Description of problem:
quick fix for user - manual perl-BerkeleyDB recomplication

Version-Release number of selected component (if applicable):
perl-BerkeleyDB-0.41-1.fc13.src.rpm

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Paul Howarth 2010-05-14 20:07:22 UTC
I'd suggest hard-coding the BDB version as a dependency in perl-BerkeleyDB so that this shows up more quickly if db4 is rebuilt in future. The following works for me:

# Need to know the exact DB version we're built against
%global db_ver %(sed '/DB_VERSION_STRING/!d;s/.*Berkeley DB[[:space:]]*\\([^:]*\\):.*/\\1/' /usr/include/db4/db.h 2>/dev/null || echo 4.0.0)

# Hard-code Berkeley DB requirement to avoid problems like #592209
Requires: db4 = %{db_ver}


I can add this and push an update if you're busy at the moment Steve; let me know.

Comment 2 Nick Urbanik 2010-05-25 01:29:39 UTC
A rebuild of perl_BerkelyDB under mock fixed this.
It stopped amavisd-new from working.

Comment 3 Paul Howarth 2010-05-25 08:34:26 UTC
Which versions of the db4-devel and perl-BerkeleyDB packages do you have?

I can reproduce this on Rawhide but not F-13 at the moment.

Comment 4 Paul Howarth 2010-05-26 07:01:16 UTC
OK, I've reproduced it on F-13 now; will build an update shortly.

Comment 5 Fedora Update System 2010-05-26 07:13:37 UTC
perl-BerkeleyDB-0.41-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/perl-BerkeleyDB-0.41-2.fc13

Comment 6 Paul Howarth 2010-05-26 07:14:19 UTC
*** Bug 595831 has been marked as a duplicate of this bug. ***

Comment 7 Paul Howarth 2010-05-26 07:14:33 UTC
*** Bug 595834 has been marked as a duplicate of this bug. ***

Comment 8 Fedora Update System 2010-05-26 21:40:05 UTC
perl-BerkeleyDB-0.41-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update perl-BerkeleyDB'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/perl-BerkeleyDB-0.41-2.fc13

Comment 9 Fedora Update System 2010-06-01 18:27:02 UTC
perl-BerkeleyDB-0.41-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.