Bug 592510 - [abrt] crash in liferea-1:1.6.2-2.fc12: raise: Process /usr/bin/liferea was killed by signal 6 (SIGABRT)
[abrt] crash in liferea-1:1.6.2-2.fc12: raise: Process /usr/bin/liferea was k...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: liferea (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Steven M. Parrish
Fedora Extras Quality Assurance
abrt_hash:344a05611b4438bbe32b9c02e01...
:
: 592572 592713 592812 595326 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-14 23:02 EDT by Scott Schmit
Modified: 2010-10-13 12:42 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-13 12:42:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (26.22 KB, text/plain)
2010-05-14 23:02 EDT, Scott Schmit
no flags Details

  None (edit)
Description Scott Schmit 2010-05-14 23:02:45 EDT
abrt 1.0.9 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: liferea
component: liferea
crash_function: raise
executable: /usr/bin/liferea
global_uuid: 344a05611b4438bbe32b9c02e01d63e51f9f0081
kernel: 2.6.32.11-99.fc12.x86_64
package: liferea-1:1.6.2-2.fc12
rating: 4
reason: Process /usr/bin/liferea was killed by signal 6 (SIGABRT)
release: Fedora release 12 (Constantine)

How to reproduce
-----
I have no idea. I was just trying to browse through my feeds and it just hung.
I then looked at the process list and strangely saw two copies of liferea running.
I did a kill -9 of one of them and noticed that abrt noticed the crash in liferea.
Afterwards, both copies were gone.
Comment 1 Scott Schmit 2010-05-14 23:02:46 EDT
Created attachment 414202 [details]
File: backtrace
Comment 2 Karel Klíč 2010-05-25 06:08:04 EDT
*** Bug 592572 has been marked as a duplicate of this bug. ***
Comment 3 Karel Klíč 2010-05-25 06:08:08 EDT
*** Bug 592713 has been marked as a duplicate of this bug. ***
Comment 4 Karel Klíč 2010-05-25 06:08:13 EDT
*** Bug 592812 has been marked as a duplicate of this bug. ***
Comment 5 Karel Klíč 2010-05-25 06:08:17 EDT
*** Bug 595326 has been marked as a duplicate of this bug. ***
Comment 6 Scott Schmit 2010-05-25 07:29:53 EDT
This reliably crashes any time I look at a feed that has something embedded in the payload (generally a flash applet).

I've tried disabling javascript, but this has no effect. I have flash-plugin-10.0.32.18-0.alpha.fc12.x86_64 installed (personally created rpm based on the 64-bit flash library from adobe), but when I go to the referenced page in my browser, it displays fine.

Since with some feeds, it's completely unpredictable whether there will be flash applets in it or not on a given article, this is extremely frustrating.

I'm clearly not the only one running into this bug, as the duplicates will attest.
Comment 7 Scott Schmit 2010-05-25 07:52:01 EDT
I've also tried uninstalling flash-plugin and upgrading to the latest available 64-bit version (10.0.45.2). Neither prevent liferea from crashing.

A better test case, now that I know what's going on:
1) Add http://www.smbc-comics.com/rss.php
2) Go to May 24 (there are others that do this, but let's keep it simple)
3) See a crash
Comment 8 Steven M. Parrish 2010-07-13 18:27:04 EDT
Liferea 1.6.4 has been pushed to stable.  Please upgrade to this latest version and see if it corrects this issue.  If there is no update to this bug within 30 days will close as WORKSFORME.

Thanks
Comment 9 Scott Schmit 2010-07-13 23:22:53 EDT
The version of Liferea in F13 does not have this problem. As I'm no longer running F12, I am unable to test this update.
Comment 10 Steven M. Parrish 2010-10-13 12:42:21 EDT
Liferea 1.6.5 has been submitted for testing on F12/F13/F14.  Closing this bug for now.  Please install the new update and if the problem returns feel free to reopen this report with additional information

Note You need to log in before you can comment on or make changes to this bug.