Bug 59433 - lpr -# (2 or more) gives "Fatal error - Maximum of 1 copies allowed"
lpr -# (2 or more) gives "Fatal error - Maximum of 1 copies allowed"
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: LPRng (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Brock Organ
:
: 63124 63649 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-07 15:38 EST by Need Real Name
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-13 17:56:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-02-07 15:38:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20011221

Description of problem:
Using the copy feature of xsane, I discovered that calls using <lpr -#> fail.
Xsane 0.82 crashed completely when set to >1 copy. I upgraded to 0.84 -- it
still returns "Fatal error..." but handles it better--no crash, just dialog box.
Invoking lpr from command line returns the same message. This does not result in
any nasty residual system behavior as far as I can tell (hung processes,
instability, crashed lpd, etc.).

Version-Release number of selected component (if applicable):
LPRng-3.7.4-28

How reproducible:
Always

Steps to Reproduce:
1. do something that invokes <lpr -# or -K> where #/K > 1
2.
3.
	

Actual Results:  returns "Fatal error - Maximum of 1 copies allowed"

Expected Results:  I should have got 2 or more copies printed.

Additional info:
Comment 1 Tim Waugh 2002-02-08 06:07:56 EST
Yep.  I'd like to see if I can find what's causing this and fix it for the next
release.
Comment 2 Tim Waugh 2002-02-13 09:28:19 EST
This is caused by LPRng's default for 'mc', which can be adjusted in
/etc/lpd.conf.  Put 'mc#128' in there, for example.  I'll adjust this default
for the next LPRng build.
Comment 3 Need Real Name 2002-02-13 17:56:44 EST
Yes, thanks!  I'm embarrassed that I overlooked it in man, but I was fixated on
-# and -K. Maybe it should have, but checking for printcap options never
occurred to me. I wonder, since changing mc# is so easy, perhaps simply changing
the diemsg to point the user to lpd.conf or printcap.local would be easier than
trying to pick a default that pleases everyone, and could save users from
scouring man pages for the right reference?  For example: "Maximum <n> copies
allowed, set default in lpd.conf"
Comment 4 Tim Waugh 2002-02-15 03:49:26 EST
I'll mention it to the maintainer.  For now I've just set the default to
something sane.

3.8.5-3.
Comment 5 Tim Waugh 2002-04-10 06:40:32 EDT
*** Bug 63124 has been marked as a duplicate of this bug. ***
Comment 6 Tim Waugh 2002-04-17 02:33:01 EDT
*** Bug 63649 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.