Bug 594830 - kdump remains enabled
Summary: kdump remains enabled
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kexec-tools (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: All Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Neil Horman
QA Contact: Chao Ye
URL:
Whiteboard:
Keywords:
: 596337 601054 620514 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-21 17:47 UTC by Bill Nottingham
Modified: 2014-03-17 03:23 UTC (History)
10 users (show)

Fixed In Version: kexec-tools-2.0.0-131
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 21:00:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to have kdumpEnabled shadow checkbox status (555 bytes, patch)
2010-05-21 18:35 UTC, Neil Horman
no flags Details | Diff
updated patch (1.60 KB, patch)
2010-07-09 15:41 UTC, Neil Horman
no flags Details | Diff

Description Bill Nottingham 2010-05-21 17:47:24 UTC
Description of problem:

I did not check the 'enable kdump' checkbox in firstboot. However, the kdump server is still set up to start.

Version-Release number of selected component (if applicable):

kexec-tools-2.0.0-70.el6.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 2 Neil Horman 2010-05-21 18:35:07 UTC
Created attachment 415745 [details]
patch to have kdumpEnabled shadow checkbox status

Bill, do me a favor and confirm that this fixes the issue for you.  Thanks!

Comment 3 Bill Nottingham 2010-05-21 18:48:36 UTC
This did not fix it for me.

Comment 4 Neil Horman 2010-05-26 16:37:37 UTC
*** Bug 596337 has been marked as a duplicate of this bug. ***

Comment 5 RHEL Product and Program Management 2010-06-07 08:32:59 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 6 Qian Cai 2010-06-07 08:45:43 UTC
*** Bug 601054 has been marked as a duplicate of this bug. ***

Comment 7 jmccann 2010-07-08 22:38:12 UTC
It is pretty awful to have a big warning icon appear in GDM for many users because of this.

Comment 8 Owen Taylor 2010-07-08 22:42:39 UTC
It makes a really bad impression if on boot after a fresh install you get a service failing and a alert icon shows up on the GDM screen. We definitely need to fix this one.

Comment 9 Neil Horman 2010-07-09 15:41:06 UTC
Created attachment 430704 [details]
updated patch

sorry I missed an early exit case.  This patch should ensure that we chkconfig kdump off as soon as we apply changes in firstboot.  I also fixed a few nagging warnings in the module at the same time.  This is working in my testing here.  Please confirm, and I'll get this comitted.

Comment 10 Bill Nottingham 2010-07-29 15:31:00 UTC
Testing method:

- upgrade box to latest tree
- remove firstboot, kexec-tools, system-config-kdump
- reinstall those packages
- patch with the included patch
- reboot

I get 'insufficient memory to configure kdump', and have to continue. (This is new, the last time I suspect these memory limits weren't there.)

In that session's GDM, I have a warning that says kdump startup failed.

On subsequent reboots, there are no errors.

So, the question is - is the error on the first boot enough to worry about?

Comment 11 Neil Horman 2010-07-29 15:47:42 UTC
yeah, that error is ok, thats a fix for a different bug.  You'll get the kdump start failed error on the firstboot boot if you don't have memory reserved, since you'll always start kdump then, and since you didn't get subsequent errors, it sounds like firstboot correctly turned of the kdump service for you.  I'll commit this.  Thanks!

Comment 12 Hans de Goede 2010-08-02 20:46:14 UTC
*** Bug 620514 has been marked as a duplicate of this bug. ***

Comment 14 Chao Ye 2010-08-17 06:44:56 UTC
Verified with -139.el6:

[root@ibm-x3655-05 ~]# yum list kernel kexec-tools firstboot system-config-kdump
Loaded plugins: rhnplugin
This system is not registered with RHN.
RHN support will be disabled.
Installed Packages
firstboot.x86_64                        1.110.8-1.el6              @beaker-os
kernel.x86_64                           2.6.32-64.el6              installed 
kexec-tools.x86_64                      2.0.0-139.el6              installed 
system-config-kdump.noarch              2.0.2.2-2.el6              @beaker-os

Change status to VERIFIED.

Comment 15 releng-rhel@redhat.com 2010-11-10 21:00:09 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.