Bug 595060 - vte loses cursor in Terminal XFCE
Summary: vte loses cursor in Terminal XFCE
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: vte
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Behdad Esfahbod
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 621956 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-23 07:24 UTC by Frank Murphy
Modified: 2011-11-20 17:26 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-08-23 06:48:53 UTC


Attachments (Terms of Use)
Screenshot Cropped (5.92 KB, image/png)
2010-05-27 12:28 UTC, Frank Murphy
no flags Details


Links
System ID Priority Status Summary Last Updated
Xfce 6423 None None None Never

Description Frank Murphy 2010-05-23 07:24:26 UTC
Description of problem: Loses cursor in Terminal


Version-Release number of selected component (if applicable):
vte-0.25.1-1.fc14.x86_64


How reproducible:
Always

Steps to Reproduce:
1. install vte-0.25.1-1.fc14.x86_64
2. Use with Terminal-0.4.4-1 or above
3.
  
Actual results: Cursor dissapears


Expected results: Green block cursor


Additional info:

Comment 1 Christoph Wickert 2010-05-25 17:03:49 UTC
Why do you still have Terminal 0.4.4 (built 2010-02-02) but vte 0.25 (built 2010-05-04)? Can you try upgrading Terminal to 0.4.5 (of 2010-05-22, so it was compiled against vte 0.25).

Comment 2 Frank Murphy 2010-05-25 17:30:08 UTC
http://lists.fedoraproject.org/pipermail/xfce/2010-May/000125.html(In reply to comment #1)
> Why do you still have Terminal 0.4.4 (built 2010-02-02) but vte 0.25 (built
> 2010-05-04)? Can you try upgrading Terminal to 0.4.5 (of 2010-05-22, so it was
> compiled against vte 0.25).    

http://lists.fedoraproject.org/pipermail/xfce/2010-May/000125.html

Comment 3 Christoph Wickert 2010-05-25 18:09:41 UTC
I did read that thread but your initial mail there stated that you were using Terminal 0.4.4 with vte 0.25. Kevin asked you if it works with 0.4.5, but you did not reply to that question explicitly, instead you just mentioned that you downgraded your vte.

So just to make this clear to Matthias who is likely not to follow the Xfce list: Terminal 0.4.5 does not work with vte 0.25 and the cursor is still missing?

Comment 4 Frank Murphy 2010-05-25 21:10:06 UTC
(In reply to comment #3)
> I did read that thread but your initial mail there stated that you were using
> Terminal 0.4.4 with vte 0.25. Kevin asked you if it works with 0.4.5, but you
> did not reply to that question explicitly, instead you just mentioned that you
> downgraded your vte.

Figured the rpm -q would have covered it, but should have explicitly stated it.

> 
> So just to make this clear to Matthias who is likely not to follow the Xfce
> list: Terminal 0.4.5 does not work with vte 0.25 and the cursor is still
> missing?    

Yes latest Terminal 0.4.5 does not work with latest vte 0.25 in Rawhide.

Comment 5 Frank Murphy 2010-05-27 12:28:44 UTC
Created attachment 417222 [details]
Screenshot Cropped

Comment 6 Bug Zapper 2010-07-30 11:41:08 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 7 Kevin Fenzi 2010-07-30 21:19:16 UTC
Does this seem to affect any of the other pile of terminal apps that use vte backend? 
Or is it just Terminal?

Comment 8 Frank Murphy 2010-07-30 21:38:25 UTC
I honestly don't know, as it's just Terminal within XFCE, that caught me eye.

Comment 9 Kevin Fenzi 2010-07-31 03:30:41 UTC
If you could try with several others and add info from them that would be great... 

any of: gnome-terminal, roxterm, xterm, lxterminal, gtkterm, etc.

Comment 10 Frank Murphy 2010-07-31 08:48:01 UTC

lxterminal-0.1.8-1.fc14.i686  has a  cursor

roxterm-1.18.5-1.fc14.i686 No visible cursor, on gtk colours or tango , if colors are changed to default white block cursor shows up


gnome-terminal-2.31.3-1.fc14.i686 has a cursor

It may be a Terminal rather than a VTE problem?

As if I go into:
edit > Preferences > Appearances > Background > Change to transparent
I get a cursor, but its' color doesn't  match what is set in colors (Green)
it is black the same as the solid background, if I then change bg solid color to something else, eg red, A red cursor shows up.

Unfortunately, I had downgraded to the previous vte, and hadn't kept testing this.  Can others test?

Comment 11 Mathieu Bridon 2010-07-31 08:59:20 UTC
With gnome-terminal, I have a similar issue, but I don't know if it's related, and I don't have a way to reproduce it reliably.

I'm using Gnome-Shell, and when the shell is restarted (for example because it crashed), all open gnome-terminal windows have lost their cursors.

This doesn't happen every time.

Comment 12 Frank Murphy 2010-08-01 08:25:34 UTC
Example Screenshot:

http://www.zimagez.com/zimage/screenshot-010810-092239.php

Comment 13 Behdad Esfahbod 2010-08-01 23:20:45 UTC
gnome-terminal doesn't let the user set the cursor color AFAIK.  someone using xfce terminal needs to debug this.

Comment 15 Frank Murphy 2010-08-02 07:46:38 UTC
I'm guessing with Branched we may get some more cc's to this.

Kevin, Should I bump this upstream Gnome? 
https://bugzilla.gnome.org/show_bug.cgi?id=621298
referencing this bug.

I can play man in the middle, as currently I can reproduce it?

Comment 16 Kevin Fenzi 2010-08-02 17:08:52 UTC
That would be excellent. Please do provide info there and see if we can get a solution. 

Thanks Frank!

Comment 17 Frank Murphy 2010-08-02 18:32:03 UTC
(In reply to comment #16)
> That would be excellent. Please do provide info there and see if we can get a
> solution. 
> 
> Thanks Frank!    

Done, 
temp workaround is to play with transparency in Terminal to get some form of cursor.

Comment 18 Tomasz Torcz 2010-08-02 19:03:07 UTC
For the record, my gnome-terminal shows cursor again after initiating window resize (no need to actually resize window, just Alt+middle click).

Comment 19 Kevin Fenzi 2010-08-06 16:15:43 UTC
*** Bug 621956 has been marked as a duplicate of this bug. ***

Comment 20 Frank Murphy 2010-08-11 18:46:03 UTC
https://bugzilla.gnome.org/show_bug.cgi?id=621298
" 

   Bug 621298 - Cursor invisible (plain black) in (xfce) Terminal & terminator

    Fix the case where cursor color is set.

    Towards making determine_colors make sense.  Still not done.  More
    commits coming, but this one is enough to fix the main regression.

"

Comment 21 Frank Murphy 2010-08-22 10:01:10 UTC
This seems to be now fixed in Fedora 14\15.

After latst update.
F14
http://koji.fedoraproject.org/koji/buildinfo?buildID=190889
F15\Rawhide
http://koji.fedoraproject.org/koji/buildinfo?buildID=190788

Can anyone else confirm?

Comment 22 Kevin Fenzi 2010-08-22 23:26:20 UTC
Yep. Works fine here now. 
I'd be ok closing this now...

Comment 23 Ken Dreyer 2011-07-16 20:30:38 UTC
This is present in RHEL6's vte-0.25.1-6.el6 (and EPEL's Terminal-0.4.7-1.el6.)

To work around this issue in RHEL 6's vte, set the following line in .config/Terminal/terminalrc (yes, leave the value blank)

ColorCursor=

Comment 24 Niels de Vos 2011-11-20 17:26:12 UTC
Thanks for the workaround, Ken. I now found that the issue on RHEL-6 has also been fixed with bug 658774 (update is available in the fastrack channel).


Note You need to log in before you can comment on or make changes to this bug.