Bug 658774 - No cursor in some vte based terminals
Summary: No cursor in some vte based terminals
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vte
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Tomáš Bžatek
QA Contact: Desktop QE
URL:
Whiteboard:
: 628486 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-01 08:58 UTC by Tomas Smetana
Modified: 2015-03-03 22:56 UTC (History)
7 users (show)

Fixed In Version: vte-0.25.1-7.el6
Doc Type: Bug Fix
Doc Text:
Previously, setting a cursor color was not working properly in that a terminal (text) cursor was invisible in some applications which used vte. With this update, the bug has been fixed so that the cursor is now rendered properly and is visible as expected.
Clone Of:
Environment:
Last Closed: 2011-08-24 10:55:48 UTC
Target Upstream Version:


Attachments (Terms of Use)
Proposed patch (1.73 KB, patch)
2010-12-01 08:59 UTC, Tomas Smetana
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1204 normal SHIPPED_LIVE vte bug fix update 2011-08-24 10:55:43 UTC

Description Tomas Smetana 2010-12-01 08:58:20 UTC
Description of problem:
The terminal (text) cursor is invisible in some applications which use vte.

Version-Release number of selected component (if applicable):
vte-0.25.1-5.el6

How reproducible:
Always

Steps to Reproduce:
1. Install something else than gnome-terminal (in my case Xfce Terminal from EPEL)
2. Start it
3. Try to find the cursor...
  
Actual results:
FAIL

Expected results:
No FAIL

Additional info:
This is a known bug in vte fixed by the following commit in the upstream tree:
http://git.gnome.org/browse/vte/commit/?id=956a836ab4f7000a7cf409c05a194e194573c358

Comment 1 Tomas Smetana 2010-12-01 08:59:00 UTC
Created attachment 463922 [details]
Proposed patch

Backport of the upstream patch.

Comment 2 Michal Babej 2010-12-15 16:05:18 UTC
There's also Fedora bug 595060 on this issue with some comments & patches.

Comment 3 RHEL Program Management 2011-01-07 16:02:06 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 4 Tomáš Bžatek 2011-02-21 15:28:25 UTC
*** Bug 628486 has been marked as a duplicate of this bug. ***

Comment 6 RHEL Program Management 2011-02-25 20:35:21 UTC
Quality Engineering Management has reviewed and declined this request.  You may
appeal this decision by reopening this request.

Comment 8 Tomas Pelka 2011-03-09 16:13:44 UTC
Another terminal emulator which is missing cursor on RHEL6 is terminator.

Comment 9 Josh 2011-04-18 21:11:50 UTC
This bug can be worked around by not setting a custom color for the cursor, that's what I'm doing in terminator for RHEL6

Comment 12 Orion Poplawski 2011-06-27 16:17:50 UTC
I'm seeing this with XFCE Terminal 0.47.  Any ideas how to tell it not to set a custom color?  I don't think I'm doing so.

Comment 13 Orion Poplawski 2011-06-27 16:34:07 UTC
The proposed patch fixes it for me.

Comment 16 Tomáš Bžatek 2011-07-29 15:29:07 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: there was a bug in the code setting cursor color

Consequence: the terminal (text) cursor was invisible in some applications which used vte

Fix: color setting logic has been reversed

Result: the cursor is rendered properly and is visible

Comment 18 Petr Kovar 2011-08-03 13:08:46 UTC
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,7 +1 @@
-Cause: there was a bug in the code setting cursor color
+Previously, setting a cursor color was not working properly in that a terminal (text) cursor was invisible in some applications which used vte. With this update, the bug has been fixed so that the cursor is now rendered properly and is visible as expected.-
-Consequence: the terminal (text) cursor was invisible in some applications which used vte
-
-Fix: color setting logic has been reversed
-
-Result: the cursor is rendered properly and is visible

Comment 20 Tomáš Bžatek 2011-08-22 09:36:54 UTC
(In reply to comment #19)
> There is another bug in vte also:
> https://bugzilla.redhat.com/show_bug.cgi?id=667539
> https://bugs.launchpad.net/ubuntu/+source/vte/+bug/663364
> 
> patch:
> http://git.gnome.org/browse/vte/commit/?h=vte-0-26&id=c5ff71e924d7b3598e332392c4cc4c19e89a7d6f
> 
> It can be reproduced on RHEL 6.1
OK, please open a separate bugreport for this.

Comment 21 errata-xmlrpc 2011-08-24 10:55:48 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1204.html

Comment 22 Taunus 2011-08-26 12:21:58 UTC
Here is the new bug:
https://bugzilla.redhat.com/show_bug.cgi?id=732391


Note You need to log in before you can comment on or make changes to this bug.