Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 595774 - Settle on a solution for transient object deletes
Settle on a solution for transient object deletes
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: cumin (Show other bugs)
Development
All Linux
high Severity medium
: 1.3
: ---
Assigned To: Justin Ross
Jan Sarenik
:
: 495596 511893 (view as bug list)
Depends On:
Blocks: 595746
  Show dependency treegraph
 
Reported: 2010-05-25 11:16 EDT by Justin Ross
Modified: 2010-10-20 07:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Ross 2010-05-25 11:16:51 EDT
We've had trouble in the past with stale data sticking in the console.  Our plan for handling this is to aggressively delete data from transient objects when agents fall out of contact, with the expectation that they will not come back.

This would be a safe assumption were it not for some constraints on the agent side, where sometimes an object that would normally be durable (is conceptually durable) is made transient instead because the agent cannot guarantee that the object will return with the same identity after an agent restart.

In the past we've handled this by having a relatively long timeout for transient object deletes.

We're now instead looking into rapid deletes, but with exceptions for certain classes of transient object.
Comment 1 Justin Ross 2010-05-25 14:57:17 EDT
*** Bug 511893 has been marked as a duplicate of this bug. ***
Comment 2 Justin Ross 2010-05-25 14:58:25 EDT
*** Bug 495596 has been marked as a duplicate of this bug. ***
Comment 3 Justin Ross 2010-07-12 11:24:08 EDT
The rapid deletion policy is in as of (actually some time before) revision 4102.
Comment 4 Jan Sarenik 2010-09-03 08:24:58 EDT
How can I verify this?
Comment 5 Justin Ross 2010-09-07 15:43:31 EDT
This bug was a development placeholder.  For purposes of verification, let's redefine it to "Eliminate stale data".

To verify:

1. Start cumin and nav to the system listing under the inventory tab
2. Start sesame
3. Wait for the sesame system to appear under the inventory tab
4. Stop sessame
5. Wait for the sesame system to vanish
6. Start sesame
7. Wait for the sesame system to reappear

The "aggressive deletion" referred to in this ticket should happen between steps 4 and 5.

A regression test for this would be a little tricky.  You'd need to use the python db api or psql to monitor the systems inside the cumin database.
Comment 6 Jan Sarenik 2010-09-08 03:05:31 EDT
Verified on cumin-0.1.4219-1.el5 using the steps
described in Comment #5.

Note You need to log in before you can comment on or make changes to this bug.