Bug 59599 - Bad/Missing fonts.dir when starting xfs
Bad/Missing fonts.dir when starting xfs
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
: 59972 60232 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-10 21:17 EST by Mike Chambers
Modified: 2007-04-18 12:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-14 12:13:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xfs script, lines causing the problem are around 201 and 206 (2.69 KB, text/plain)
2002-02-10 21:21 EST, Mike Chambers
no flags Details
xfs start log, search for "attributes" [runlevel 3, X installed but no configured] (7.67 KB, text/plain)
2002-02-20 17:20 EST, giulioo
no flags Details

  None (edit)
Description Mike Chambers 2002-02-10 21:17:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)

Description of problem:
When starting xfs via services xfs start, get error message that fonts.dir is 
bad/missing.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Upgrade system from 7.2 with updates to 7.2.90
2.service xfs start
3.
	

Actual Results:  Get error message that fonts.dir bad/missing

Expected Results:  xfs should start error free

Additional info:

This is from a 7.2 install w/updates, no extra XFree86 packages.  Then updated 
to 7.2.90.

I commented out the two chmod lines for the fonts.dir and that stops it from 
looking.  I've attached my xfs script file.
Comment 1 Mike Chambers 2002-02-10 21:21:43 EST
Created attachment 45182 [details]
xfs script, lines causing the problem are around 201 and 206
Comment 2 Mike A. Harris 2002-02-11 07:50:33 EST
Hmm. Odd.  Could you stop xfs, then uncomment those lines, and add a
line to the top of the xfs initscript right underr the umask line
that says:

set -vx

then start xfs back up with:

service xfs start &> xfsinit.log

Then attach the resultant log file for me to ponder.

Thanks Mike.
Comment 3 giulioo 2002-02-20 17:20:47 EST
Created attachment 46160 [details]
xfs start log, search for "attributes"  [runlevel 3, X installed but no configured]
Comment 4 giulioo 2002-02-21 15:54:12 EST
*** Bug 59972 has been marked as a duplicate of this bug. ***
Comment 5 giulioo 2002-02-24 06:22:12 EST
*** Bug 60232 has been marked as a duplicate of this bug. ***
Comment 6 Mike A. Harris 2002-02-28 14:51:57 EST
Please try the XFree86-4.2.0-6.39 package from rawhide and let
me know if the problem goes away or not.
Comment 7 Yil-Kyu Kang 2002-03-11 15:06:35 EST
Tested with beta2 and recieved expected behavior. Please test again with beta2.
Comment 8 John A. Hull 2002-03-14 12:13:02 EST
Agree. Appears to be fixed in beta 2. Will let mike@netlyncs.com close bug if 
he agrees.
Comment 9 Mike Chambers 2002-03-14 18:58:07 EST
Don't know about the XFree packages in beta 2, as I had problems with that 
version for voodoo3.  But the ones in rawhide fixed that and don't see any 
problems with the fonts.dir so I'll close it as rawhide.

Note You need to log in before you can comment on or make changes to this bug.