Bug 596235 - PXE boot images are unable to use LAN drivers
PXE boot images are unable to use LAN drivers
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
13
All Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-26 08:36 EDT by Rainer Koenig
Modified: 2010-11-04 03:03 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-04 03:03:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
PXE boot log (20.63 KB, text/plain)
2010-06-22 03:41 EDT, Rainer Koenig
no flags Details
Hard disk boot log (25.62 KB, text/plain)
2010-06-22 03:42 EDT, Rainer Koenig
no flags Details
dmesg output after harddisk boot (30.80 KB, text/plain)
2010-06-22 03:43 EDT, Rainer Koenig
no flags Details

  None (edit)
Description Rainer Koenig 2010-05-26 08:36:41 EDT
Description of problem:
Downloaded the Fedora 13 DVDs (32&64 bit) and mounted them loopback on my lab server. PXEboot directory on the TFTP server got the vmlinuz and initrd.img from the /images/pxeboot directory. 

Then trying out the PXE installation on several machines. Success: NONE. All machines complained about a missing network driver. One machine was equipped with a simple Broadcom LAN card (tg3 driver). A laptop which was able to use the e1000e driver on a Fedora 12 PXE-Installation was now trying to configure wlan0 as described in bug 580563.
https://bugzilla.redhat.com/show_bug.cgi?id=580563

Disabling WLAN in the laptop BIOS then ended up with a not working LAN driver. e1000e should work in this case since it worked with the old Fedora 12 netinstall and it also works when I install from DVD instead of installing from PXE.

Version-Release number of selected component (if applicable):
kernel 2.6.33.3-85-fc13-x86_64 (also i686 won't work)

How reproducible:
Always

Steps to Reproduce:
1. Setup PXE installation environment
2. Boot from PXE and try to install Fedora 13 
3. Fail when it comes to switch to the network driver from Fedora 13.
  
Actual results:
No success on different machines. Successful installation on one machine from the DVD.

Expected results:
Installation from PXE is able to use the drivers.

Additional info:
Strange thing noticed when unpacking the initrd.img to a local directory. 
All the modules under /lib/modules/2.6.33.3-85.fc13.x86_64 are named <driver>.ko.gz while the working installed Fedora 13 has the drivers as expected with the name <driver>.ko. Unfortunately net install doesn't show a console to see if the modules are really loaded, from the behaviour of the system I assume that it tries something like "modprobe e1000e" which fails because the file is named e1000e.ko.gz. But the bug reported of 580563 said also that he succeeded with older hardware. So I'm really confused becaucse if my therory would prove as correct he shouldn't succeed with some hardware. :-)

Anyway, the current pxeboot-images are definitely not working as they should.
Comment 1 Rainer Koenig 2010-05-26 09:20:47 EDT
Ok, forget about the ko.gz thing. Just replaced the initrd.img with one that had all ko.gz unpacked, but then i get a bunch of complaints about missing ko.gz files.

Then I copied back the original image and tried again. Once in several attempts I saw a message from anaconda that was complaining about "too many open files", but that one I also couldn't reproduce. 

So the question still is why the network is not detected as it should be.
Comment 2 John Ruemker 2010-06-15 12:51:28 EDT
Same problem here.  Have a Lenovo Ideapad U150 with a Broadcom NetLink BCM57780 PCIe card (tg3) and when installing it immediately tries to use wlan0.  I disabled wlan0 in the BIOS, and it goes to the screen saying it couldn't detect my network hardware, allowing me to select a driver.  I've chosen every Broadcom option available and none worked.  Booting back into F12 my link/connection works just fine.  Please fix this!  I can't upgrade to F13 without it, since I have no optical drive and live cd doesn't give me an upgrade option.
Comment 3 Andy Gospodarek 2010-06-21 11:58:24 EDT
Rainer,

The e1000e issue will be fixed with the solution to bug 580563.  The proper workaround (downloading a new initrd and kernel image that contain a patched e1000e driver) can be found here:

https://bugzilla.redhat.com/show_bug.cgi?id=580563#c7

Rainer and John,

This is the first I have heard of the tg3 issue.  John has indicated he is using a Lenovo Ideapad U150. Rainer, can you tell me what system you are using?

It would be helpful if either of you could capture the console messages that cause tg3 to fail on your system.  You can either do this by using PXE boot to load the installer and then pressing CTRL-F2 (or F3) to see the console during boot and look for messages from the tg3 driver OR download a livecd/usb image (64-bit only), run livecd-iso-to-pxeboot (part of livecd-tools package) to convert the iso to something that can be loaded via tftp/PXE boot and diagnose the problem a bit once the system is running.
Comment 4 John Ruemker 2010-06-21 13:45:33 EDT
Unfortunately there's not much printed on the consoles when this happens.  When the wireless interface is enabled in the BIOS, I get this on vt 3 and 4:

INFO loader: 53 keymaps are available
INFO loader: need to set up networking
INFO loader: going to pick interface
INFO loader: only have one network device: wlan0
INFO loader: going to do getNetConfig

INFO NetworkManager: <info> NetworkManager (version 0.8.0.997) is starting...
INFO NetworkManager: <info> trying to start the modem manager...
WARN NetworkManager:    ifcfg-rh: Could not get hostname: failed to read /etc/sysconfig/network
NOTICE NetworkManager:    ifcfg-rh: Acquired D-Bus service com.redhat.ifcfgrh1
INFO NetworkManager: <info> Loaded plugin ifcfg-rh: (c) 2007 - 2008 Red Hat, Inc.  To report bugs please use the NetworkManager mailing list
NOTICE NetworkManager:    ifcfg-rh: parsing </etc/sysconfig/network-scripts/ifcfg-wlan0 ...
<snip more wlan0-specific stuff/>

When I disable wlan0 in the BIOS, its much less than this.  There are no messages specific to Broadcom, tg3, eth0, or anything network-related besides wlan0.
Comment 5 Andy Gospodarek 2010-06-21 14:04:29 EDT
John, can you boot a kernel that works with this device, paste the following from the system:

# lspci
# lspci -n
# lsmod

I'm starting to wonder if you have a 5785 that you might be hitting bug 602155.
Comment 6 John Ruemker 2010-06-21 14:19:25 EDT
From 2.6.33.5-124.fc13.x86_64 (I was able to use preupgrade to get to f13):

$ lspci
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 03)
00:1c.5 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M-E LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
03:00.0 Network controller: Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Network Connection
07:00.0 Ethernet controller: Broadcom Corporation NetLink BCM57780 Gigabit Ethernet PCIe (rev 01)
$ lspci -n
00:00.0 0600: 8086:2a40 (rev 07)
00:02.0 0300: 8086:2a42 (rev 07)
00:02.1 0380: 8086:2a43 (rev 07)
00:1a.0 0c03: 8086:2937 (rev 03)
00:1a.1 0c03: 8086:2938 (rev 03)
00:1a.2 0c03: 8086:2939 (rev 03)
00:1a.7 0c03: 8086:293c (rev 03)
00:1b.0 0403: 8086:293e (rev 03)
00:1c.0 0604: 8086:2940 (rev 03)
00:1c.1 0604: 8086:2942 (rev 03)
00:1c.2 0604: 8086:2944 (rev 03)
00:1c.4 0604: 8086:2948 (rev 03)
00:1c.5 0604: 8086:294a (rev 03)
00:1d.0 0c03: 8086:2934 (rev 03)
00:1d.1 0c03: 8086:2935 (rev 03)
00:1d.2 0c03: 8086:2936 (rev 03)
00:1d.7 0c03: 8086:293a (rev 03)
00:1e.0 0604: 8086:2448 (rev 93)
00:1f.0 0601: 8086:2917 (rev 03)
00:1f.2 0106: 8086:2929 (rev 03)
00:1f.3 0c05: 8086:2930 (rev 03)
03:00.0 0280: 8086:4237
07:00.0 0200: 14e4:1692 (rev 01)
$ lsmod
Module                  Size  Used by
fuse                   54749  2 
tg3                   103314  0 
rfcomm                 65106  4 
sco                    16188  2 
bridge                 45753  0 
stp                     1887  1 bridge
llc                     4557  2 bridge,stp
bnep                   15121  2 
l2cap                  45185  16 rfcomm,bnep
sunrpc                192013  1 
ipv6                  267033  28 
cpufreq_ondemand        8420  2 
acpi_cpufreq            7477  1 
freq_table              3851  2 cpufreq_ondemand,acpi_cpufreq
kvm_intel              40231  0 
kvm                   252952  1 kvm_intel
uinput                  7230  0 
arc4                    1377  2 
snd_hda_codec_intelhdmi    16015  1 
snd_hda_codec_conexant    34904  1 
ecb                     1967  2 
iwlagn                147297  0 
snd_hda_intel          24200  2 
snd_hda_codec          73671  3 snd_hda_codec_intelhdmi,snd_hda_codec_conexant,snd_hda_intel
iwlcore               221094  1 iwlagn
snd_hwdep               6222  1 snd_hda_codec
snd_seq                50941  0 
uvcvideo               53857  0 
mac80211              196929  2 iwlagn,iwlcore
snd_seq_device          5895  1 snd_seq
btusb                  15012  2 
videodev               35123  1 uvcvideo
snd_pcm                76131  2 snd_hda_intel,snd_hda_codec
v4l1_compat            12570  2 uvcvideo,videodev
v4l2_compat_ioctl32     9793  1 videodev
iTCO_wdt               10864  0 
broadcom                6518  0 
i2c_i801               10086  0 
bluetooth              87181  9 rfcomm,sco,bnep,l2cap,btusb
iTCO_vendor_support     2451  1 iTCO_wdt
cfg80211              117099  3 iwlagn,iwlcore,mac80211
snd_timer              19234  2 snd_seq,snd_pcm
snd                    60573  13 snd_hda_codec_intelhdmi,snd_hda_codec_conexant,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_seq,snd_seq_device,snd_pcm,snd_timer
wmi                     6600  0 
rfkill                 16402  4 bluetooth,cfg80211
serio_raw               4539  0 
soundcore               6198  1 snd
snd_page_alloc          7221  2 snd_hda_intel,snd_pcm
joydev                  9439  0 
microcode              17930  0 
aes_x86_64              7654  2 
aes_generic            27012  1 aes_x86_64
xts                     2335  1 
gf128mul                7050  1 xts
dm_crypt               10930  1 
usb_storage            44408  0 
i915                  272088  3 
drm_kms_helper         23936  1 i915
drm                   169073  4 i915,drm_kms_helper
i2c_algo_bit            4781  1 i915
i2c_core               24507  6 videodev,i2c_i801,i915,drm_kms_helper,drm,i2c_algo_bit
video                  20741  1 i915
output                  2117  1 video
Comment 7 John Ruemker 2010-06-21 15:19:28 EDT
(In reply to comment #5)
> I'm starting to wonder if you have a 5785 that you might be hitting bug 602155.    

Yes, it does look to be the same model as that bug.  So assuming the fact that the current kernel works means the next installer will also, I am fine with this being closed or marked a duplicate.  Thanks for your help.

-John
Comment 8 Rainer Koenig 2010-06-22 03:41:57 EDT
Created attachment 425843 [details]
PXE boot log

Boot log from PXE, captuered with a nullmodem cable
Comment 9 Rainer Koenig 2010-06-22 03:42:40 EDT
Created attachment 425844 [details]
Hard disk boot log

Boot log for installed system, booting from hard disk, captured with nullmodem cable
Comment 10 Rainer Koenig 2010-06-22 03:43:42 EDT
Created attachment 425845 [details]
dmesg output after harddisk boot

unfortunately the boot process changes the console during boot, so no tg3 messages were captured via nullmodem cable. See this file for the tg3 messages
Comment 11 Rainer Koenig 2010-06-22 03:48:22 EDT
Andy, 

I created 3 attachments with boot logs that I captured via a nullmodem cable. When booting from harddisk Fedora changes the console during boot, so there are no tg3 driver messages in the captured file, but I can see them in dmesg. 

The system where I see the problem with the tg3 driver is a Fujitsu ESPRIMO E5645. Here is a link to the datasheet:
http://docs.ts.fujitsu.com/dl.aspx?id=5b075e13-b0a7-442e-8e80-1c3cfefc4c47

I performed all tests on exactly the same hardware. Booting from PXE brings me to a dialog box where I should select the LAN driver, even selecting tg3 doesn't solve this, I'm coming back to this dialog box.

Installing from DVD and booting from hard disk shows no problem. tg3 driver is loaded and working. 

Regards
Rainer
Comment 12 Andy Gospodarek 2010-06-23 12:07:33 EDT
Rainer, thanks for the detailed logging.  The 5785 and 57780 both require the broadcom.ko PHY module to load and there were problems getting this loaded in current kernels.  This was detailed in bug 602155 and should be fixed with the F14 install kernels.

I will try and get something added to the comments in bug 602155 to explain how to create new install images.
Comment 13 Rainer Koenig 2010-11-04 03:03:01 EDT
Tried out Fedora 14 now, problem is solved there.

Note You need to log in before you can comment on or make changes to this bug.