Bug 597125 - SDL crashes whenever axes 4 and 5 are pushed
SDL crashes whenever axes 4 and 5 are pushed
Status: CLOSED DUPLICATE of bug 624241
Product: Fedora
Classification: Fedora
Component: SDL (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 590484
  Show dependency treegraph
 
Reported: 2010-05-28 03:45 EDT by Danny Brodzik
Modified: 2010-08-17 05:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-17 05:10:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Danny Brodzik 2010-05-28 03:45:24 EDT
Description of problem: On Fedora 13, any game that uses SDL and a game pad or joystick crashes with a SIGSEGV whenever I push axes 4 or 5 (3 or 4 if we count them starting with 0).


Version-Release number of selected component (if applicable): 1.2.14-4.fc13


How reproducible: Every time I use the game pad.


Steps to Reproduce:
1. Start any game that supports gamepads or joysticks, like Kobo Deluxe.
2. Turn on joystick support.
3. Push axis 4 or 5 on the gamepad or joystick (like the directional hat, or directional buttons).
  
Actual results: Game crashes with a SIGSEGV.


Expected results: I expected the game to work normally.

Additional info: This worked in Fedora 12. I can't get a backtrace because ABRT isn't catching any of the SIGSEGVs from these games. If someone would like a backtrace, please let me know how to do it. Debuginfo is installed, however.
Comment 1 Björn Sund 2010-06-02 07:11:15 EDT
I can confirm this.

Seems to be a problem in SDL 1.2.14

Downgrading to SDL-1.2.13-10.fc12.i686 eliminates the problem.
Comment 2 Thomas Woerner 2010-06-02 08:22:44 EDT
Can you please try to start the game in gdb? It would be helpful to have a backtrace.
Comment 3 Björn Sund 2010-06-02 15:30:47 EDT
Starting program: /usr/bin/zsnes 
[Thread debugging using libthread_db enabled]
ZSNES v1.51, (c) 1997-2007, ZSNES Team
Be sure to check http://www.zsnes.com/ for the latest version.

ZSNES is written by the ZSNES Team (See AUTHORS.TXT)
ZSNES comes with ABSOLUTELY NO WARRANTY.  This is free software,
and you are welcome to redistribute it under certain conditions;
please read 'LICENSE.TXT' thoroughly before doing so.

Use ZSNES -? for command line definitions.

Starting Mouse detection.
Unable to poll /dev/input/event5. Make sure you have read permissions to it.
Unable to poll /dev/input/event11. Make sure you have read permissions to it.
Unable to poll /dev/input/event10. Make sure you have read permissions to it.
Unable to poll /dev/input/event9. Make sure you have read permissions to it.
Unable to poll /dev/input/event8. Make sure you have read permissions to it.
Unable to poll /dev/input/event7. Make sure you have read permissions to it.
Unable to poll /dev/input/event6. Make sure you have read permissions to it.
Unable to poll /dev/input/event4. Make sure you have read permissions to it.
Unable to poll /dev/input/event3. Make sure you have read permissions to it.
Unable to poll /dev/input/event2. Make sure you have read permissions to it.
Unable to poll /dev/input/event1. Make sure you have read permissions to it.
Unable to poll /dev/input/event0. Make sure you have read permissions to it.
ManyMouse: 0 mice detected.
[New Thread 0xb74afb70 (LWP 20640)]
[New Thread 0xb22b8b70 (LWP 20641)]
[Thread 0xb22b8b70 (LWP 20641) exited]
[New Thread 0xb22b8b70 (LWP 20642)]
[Thread 0xb22b8b70 (LWP 20642) exited]
[New Thread 0xb22b8b70 (LWP 20643)]
[New Thread 0xb16ffb70 (LWP 20644)]

Audio Opened.
Driver: PulseAudio Output
Channels: 2
Rate: 32000

Device 0 Padix Co. Ltd. Rockfire PSX/USB Bridge 
  1 axis, 12 buttons, 0 hats, 0 balls
[New Thread 0xaccfdb70 (LWP 20645)]
[Thread 0xaccfdb70 (LWP 20645) exited]
[New Thread 0xaccfdb70 (LWP 20646)]

Program received signal SIGSEGV, Segmentation fault.
0x00f9249d in ?? () from /usr/lib/libSDL-1.2.so.0
(gdb) backtrace 
#0  0x00f9249d in ?? () from /usr/lib/libSDL-1.2.so.0
#1  0x00f68c50 in SDL_JoystickUpdate () from /usr/lib/libSDL-1.2.so.0
#2  0x00f412de in SDL_PumpEvents () from /usr/lib/libSDL-1.2.so.0
#3  0x00f41748 in SDL_PollEvent () from /usr/lib/libSDL-1.2.so.0
#4  0x082e4148 in ?? ()
#5  0x082e4b5e in ?? ()
#6  0x082e1c21 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)
Comment 4 Danny Brodzik 2010-06-03 14:54:29 EDT
I have two ABRT backtraces here now.

https://bugzilla.redhat.com/show_bug.cgi?id=597964
https://bugzilla.redhat.com/show_bug.cgi?id=597970
Comment 5 Petr Pisar 2010-08-16 13:36:39 EDT
Danny, I'm going to release new SDL package regarding bug #624241 tomorrow. There is URL to the unofficially patched SDL package. Could you try it? Does it fix your problem?
Comment 6 Björn Sund 2010-08-16 14:09:37 EDT
Seems to do the thing for me.

Just a quick check but if it works it will probably work :-)
Comment 7 Danny Brodzik 2010-08-17 03:35:30 EDT
Works great for me! Thanks!
Comment 8 Petr Pisar 2010-08-17 05:10:25 EDT

*** This bug has been marked as a duplicate of bug 624241 ***

Note You need to log in before you can comment on or make changes to this bug.