Bug 624241 - Moving rumblepad hat causes segmentation fault in programs (sdlmame and gens-gs)
Summary: Moving rumblepad hat causes segmentation fault in programs (sdlmame and gens-gs)
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: SDL
Version: 13
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Petr Pisar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 597125 597964 597970 618883 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-15 05:48 UTC by Giles
Modified: 2010-10-06 15:58 UTC (History)
4 users (show)

(edit)
Clone Of:
: 640694 (view as bug list)
(edit)
Last Closed: 2010-08-26 03:24:14 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
SDL Simple Directmedia Layer 900 None None None Never

Description Giles 2010-08-15 05:48:55 UTC
Description of problem:
sdlmame and gens-gs crash with segmentation fault if analog hat on USB wired Logitech Rumblepad 2 is moved

Version-Release number of selected component (if applicable):
Fedora 13, kernel 2.6.33.6-147.2.4.fc13.i686.PAE
(Problem existed on previous kernels)

How reproducible:
Always reproducible

Steps to Reproduce:
This is one way - 
1.Start application
2.On Mame (emulator) press TAB and select setup key inputs for user interface, select any option, move analog hat up on Rumplepad
3. On Gens-gs (Genesis Emulator) go into a game, move analog hat up on Rumblepad
  
Actual results:
application freezes, then drop back to shell with error segmentation fault

Expected results:
accepts input; on mame it should show "DPad-up" or similar appropriate message in key input list


Additional info:
-My hardware: Phenom II x2 550 BE CPU; Asus M3N-H/HDMI Motherboard; nvidia 9800 graphics card
-It is complete supposition this is an SDL problem, on the basis both these applications are SDL Based
-Keypresses from the Rumblepad are accepted, only direction inputs cause crash; Crash is also reproducable when running ROM in either emulator with same result
-Rumblepad does not crash the joypad configuration utility - works as expected
-I have had this bug for about a month, not seen it reported anywhere else, not been cured with kernel update (or yum-update in general) I wondered if it might be related to updated rumblepad drivers in kernel? as new problem with Fedora 13, previously okay in Fedora 11
-Please contact me for further information if needed. Thankyou for your help.

Comment 1 Petr Pisar 2010-08-16 09:15:21 UTC
Yet another hardware related problem :( Please submit backtrace from debugger after crash. You can use `abrt' or `abrt-gui' tool to proceed it with handy user interface. Only such way developers get idea, what's wrong.

I found similar bug report in Ubuntu <https://bugs.launchpad.net/ubuntu/+source/libsdl1.2/+bug/504878>. Referenced patch <http://hg.libsdl.org/SDL/rev/42012a6afb5b> is not part of Fedora 13 SDL package.

I will prepare new SDL package build for you.

Comment 2 Petr Pisar 2010-08-16 11:04:55 UTC
I applied patch from <http://hg.libsdl.org/SDL/rev/42012a6afb5b>
 and built i686 package that can be downloaded from <http://koji.fedoraproject.org/koji/getfile?taskID=2403449&name=SDL-1.2.14-8.fc13.i686.rpm>.

Could you test it? Be ware the package is not digitally signed. You can install it list this:

$ wget --content-disposition 'http://koji.fedoraproject.org/koji/getfile?taskID=2403449&name=SDL-1.2.14-8.fc13.i686.rpm'
# yum --nogpgcheck localinstall SDL-1.2.14-8.fc13.i686.rpm

Does it fix the problem for you?

Comment 3 Giles 2010-08-16 13:47:50 UTC
(In reply to comment #1)
> Yet another hardware related problem :( Please submit backtrace from debugger
> after crash. You can use `abrt' or `abrt-gui' tool to proceed it with handy
> user interface. Only such way developers get idea, what's wrong.
> 
> I found similar bug report in Ubuntu
> <https://bugs.launchpad.net/ubuntu/+source/libsdl1.2/+bug/504878>. Referenced
> patch <http://hg.libsdl.org/SDL/rev/42012a6afb5b> is not part of Fedora 13 SDL
> package.
> 
> I will prepare new SDL package build for you.

Unfortunately abrt-gui does not show anything useful, there are two kernel errors reported from a few days ago, but nothing related to the crash I cause.

I tested the patch. Unfortunately I got an error, so ha to workaround with argument --skipbroken: not sure if this would have caused problem with the patch, but it didn't fix the error. Here's what happened on the console;

[mythtv@media ~]$ sudo yum --nogpgcheck localinstall SDL-1.2.14-8.fc13.i686.rpm
[sudo] password for mythtv: 
Loaded plugins: fastestmirror, presto, refresh-packagekit
Setting up Local Package Process
Examining SDL-1.2.14-8.fc13.i686.rpm: SDL-1.2.14-8.fc13.i686
Marking SDL-1.2.14-8.fc13.i686.rpm as an update to SDL-1.2.14-6.fc13.i686
Loading mirror speeds from cached hostfile
 * fedora: mirror.eurid.eu
 * rpmfusion-free: mirror01.th.ifl.net
 * rpmfusion-free-updates: mirror01.th.ifl.net
 * rpmfusion-nonfree: mirror01.th.ifl.net
 * rpmfusion-nonfree-updates: mirror01.th.ifl.net
 * updates: mirror.eurid.eu
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: SDL = 1.2.14-6.fc13 for package: SDL-devel-1.2.14-6.fc13.i686
---> Package SDL.i686 0:1.2.14-8.fc13 set to be updated
--> Finished Dependency Resolution
Error: Package: SDL-devel-1.2.14-6.fc13.i686 (@updates)
           Requires: SDL = 1.2.14-6.fc13
           Removing: SDL-1.2.14-6.fc13.i686 (@updates)
               SDL = 1.2.14-6.fc13
           Updated By: SDL-1.2.14-8.fc13.i686 (/SDL-1.2.14-8.fc13.i686)
               SDL = 1.2.14-8.fc13
           Available: SDL-1.2.14-4.fc13.i686 (fedora)
               SDL = 1.2.14-4.fc13
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[mythtv@media ~]$ sudo yum --nogpgcheck localinstall --skip-broken SDL-1.2.14-8.fc13.i686.rpm
[sudo] password for mythtv: 
Loaded plugins: fastestmirror, presto, refresh-packagekit
Setting up Local Package Process
Examining SDL-1.2.14-8.fc13.i686.rpm: SDL-1.2.14-8.fc13.i686
Marking SDL-1.2.14-8.fc13.i686.rpm as an update to SDL-1.2.14-6.fc13.i686
Loading mirror speeds from cached hostfile
 * fedora: mirror.leaseweb.com
 * rpmfusion-free: mirror01.th.ifl.net
 * rpmfusion-free-updates: mirror01.th.ifl.net
 * rpmfusion-nonfree: mirror01.th.ifl.net
 * rpmfusion-nonfree-updates: mirror01.th.ifl.net
 * updates: mirror.leaseweb.com
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: SDL = 1.2.14-6.fc13 for package: SDL-devel-1.2.14-6.fc13.i686
---> Package SDL.i686 0:1.2.14-8.fc13 set to be updated
--> Finished Dependency Resolution

Packages skipped because of dependency problems:
    SDL-1.2.14-8.fc13.i686 from /SDL-1.2.14-8.fc13.i686

[mythtv@media ~]$ mame
Segmentation fault (core dumped)
[mythtv@media ~]$ gens
Segmentation fault (core dumped)


I also note I misreported the error as it was "segmentation fault (core dumped)".

Comment 4 Petr Pisar 2010-08-16 14:02:51 UTC
Unfortunately, you did not install the new package because you had installed SDL-devel package already and as such yum could not resolve missing development package.

Download the SDL-devel package from <https://koji.fedoraproject.org/koji/taskinfo?taskID=2403449> (The output section) and do the `yum localinstall' with both packages as arguments:

# yum --nogpgcheck localinstall SDL-1.2.14-8.fc13.i686.rpm SDL-devel-1.2.14-8.fc13.i686.rpm

If it complained about missing debug or static SDL package, you wold need to download (from the same page) and install them too.

Comment 5 Giles 2010-08-16 16:15:15 UTC
(In reply to comment #4)
> Unfortunately, you did not install the new package because you had installed
> SDL-devel package already and as such yum could not resolve missing development
> package.
> 
> Download the SDL-devel package from
> <https://koji.fedoraproject.org/koji/taskinfo?taskID=2403449> (The output
> section) and do the `yum localinstall' with both packages as arguments:
> 
> # yum --nogpgcheck localinstall SDL-1.2.14-8.fc13.i686.rpm
> SDL-devel-1.2.14-8.fc13.i686.rpm
> 
> If it complained about missing debug or static SDL package, you wold need to
> download (from the same page) and install them too.

 Success! Thank-you for your help!

In case anyone should be following these instructions note the url to type into the browser is
http://koji.fedoraproject.org/koji/taskinfo?taskID=2403449
rather than https://...

Thankyou again very much Petr,

Giles

Comment 6 Petr Pisar 2010-08-17 09:10:25 UTC
*** Bug 597125 has been marked as a duplicate of this bug. ***

Comment 7 Petr Pisar 2010-08-17 09:11:09 UTC
*** Bug 597964 has been marked as a duplicate of this bug. ***

Comment 8 Petr Pisar 2010-08-17 09:11:46 UTC
*** Bug 597970 has been marked as a duplicate of this bug. ***

Comment 9 Fedora Update System 2010-08-17 09:34:02 UTC
SDL-1.2.14-8.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/SDL-1.2.14-8.fc14

Comment 10 Fedora Update System 2010-08-17 09:34:35 UTC
SDL-1.2.14-8.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/SDL-1.2.14-8.fc13

Comment 11 Petr Pisar 2010-08-17 09:39:32 UTC
*** Bug 618883 has been marked as a duplicate of this bug. ***

Comment 12 Fedora Update System 2010-08-17 19:35:14 UTC
SDL-1.2.14-8.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update SDL'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/SDL-1.2.14-8.fc14

Comment 13 Fedora Update System 2010-08-26 03:23:55 UTC
SDL-1.2.14-8.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2010-08-27 06:49:58 UTC
SDL-1.2.14-8.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Rafael Louback Ferraz 2010-08-27 21:31:20 UTC
Im using fedora core 13, and tested using a frozenblubble and xbox360 controller. Is working fine now.


Note You need to log in before you can comment on or make changes to this bug.