Bug 59718 - multiple bugs in package selection
multiple bugs in package selection
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
: 59700 60211 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-11 21:36 EST by greg hosler
Modified: 2007-04-18 12:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-19 13:32:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description greg hosler 2002-02-11 21:36:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-13smp-MO i686; Nav)

Description of problem:
At the install type (workstation/server/custion) Select individual packages.
The individual package selection has multiple problems:

1) first off the package name column is not sorted by default.
2) The screen will "jump" each time that a package is clicked/unclicked.
3) the description box does not "word wrap". It will wrap the line in the middle
of a word
4) Applications section - there are 2 "Publishing" sub groups
5) Clicking into a subgroup does not position at the start of the package
selection for that group. The position seems to be a random position into the
middle of the package group.
6) "Documentation" group - app packages appear 2wice.
7) "System Environment" group appears 2wice, though the 1st group is empty.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. see above
2.
3.
	

Additional info:
Comment 1 Michael Fulbright 2002-02-12 12:45:10 EST
This has some issues with the groups which timp needs to address, katzj should
look at the UI issues.
Comment 2 Jeremy Katz 2002-02-15 14:55:34 EST
Duplication isn't appearing for me anymore in test mode...  I'll check more once
I get my test boxes back up post-move.  Word wrapping is fixed.  There are a few
gtk2 issues here with sorting and reflow, so I'll cc jrb for them.
Comment 3 Jonathan Blandford 2002-02-15 15:00:47 EST
what are the issues?  Can you enumerate (or even better, provide a test case?)
Comment 4 Jeremy Katz 2002-02-15 15:05:55 EST
1.  The reflow jumping when selecting things in a treeview that I think msw
showed you; if not, I'll grab a simple test case hopefully over the weekend, but
if not, then the beginning of next week.  

2.  Sorting doesn't seem to be preserved when you clear and repopulate the view
Comment 5 Michael Fulbright 2002-02-22 11:32:13 EST
*** Bug 60211 has been marked as a duplicate of this bug. ***
Comment 6 Jay Turner 2002-03-19 16:17:19 EST
Deferring this to the gtk2-based installer.
Comment 7 Michael Fulbright 2002-05-13 17:36:26 EDT
#1 still happens.
#2 doesn't happen now.
#3 doesn't happen now.
#5 still happens.

Also sorting does not work still.

#4, #6, #7 do not apply anymore.
Comment 8 Michael Fulbright 2002-05-13 17:37:15 EDT
*** Bug 59700 has been marked as a duplicate of this bug. ***
Comment 9 Michael Fulbright 2002-06-19 13:32:32 EDT
I believe these issues have been resolved.
Comment 10 Michael Fulbright 2002-12-20 12:38:25 EST
Time tracking values updated

Note You need to log in before you can comment on or make changes to this bug.