Bug 597207 - [abrt] crash in xfce4-xkb-plugin-0.5.3.3-3.fc13: IA__gtk_tree_model_get_valist: Process /usr/libexec/xfce4/panel-plugins/xfce4-xkb-plugin was killed by signal 11 (SIGSEGV)
Summary: [abrt] crash in xfce4-xkb-plugin-0.5.3.3-3.fc13: IA__gtk_tree_model_get_valis...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xfce4-xkb-plugin   
(Show other bugs)
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: François Cami
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:75c9a18eab4bac42cb5688101e6...
Keywords:
: 597504 599429 614658 641507 650376 650939 658417 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-28 11:35 UTC by Jiri Moskovcak
Modified: 2015-02-01 22:52 UTC (History)
16 users (show)

Fixed In Version: xfce4-xkb-plugin-0.5.3.3-4.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-01 21:55:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (30.45 KB, text/plain)
2010-05-28 11:35 UTC, Jiri Moskovcak
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Xfce 6477 None None None Never

Description Jiri Moskovcak 2010-05-28 11:35:35 UTC
abrt 1.1.1 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/libexec/xfce4/panel-plugins/xfce4-xkb-plugin socket_id 25165875 name xkb-plugin id 12632952080 display_name 'Keyboard Layouts' size 26 screen_position 2
comment: it doesn't crash If I choose keyboard model and set the "change layout option"
component: xfce4-xkb-plugin
crash_function: IA__gtk_tree_model_get_valist
executable: /usr/libexec/xfce4/panel-plugins/xfce4-xkb-plugin
global_uuid: 75c9a18eab4bac42cb5688101e6dfcef60037944
kernel: 2.6.33.4-95.fc13.x86_64
package: xfce4-xkb-plugin-0.5.3.3-3.fc13
rating: 4
reason: Process /usr/libexec/xfce4/panel-plugins/xfce4-xkb-plugin was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1. add Keyboard Layouts plugin to the panel
2. leave all combos on defaults (model: empty, c layout option: -, compose key: -)
3. CLick Add layout -> Czechia -> qwerty

Comment 1 Jiri Moskovcak 2010-05-28 11:35:37 UTC
Created attachment 417577 [details]
File: backtrace

Comment 2 Christoph Wickert 2010-05-28 19:27:15 UTC
Forwarded upstream as http://bugzilla.xfce.org/show_bug.cgi?id=6477

Comment 3 Christoph Wickert 2010-06-03 13:37:09 UTC
*** Bug 597504 has been marked as a duplicate of this bug. ***

Comment 4 Christoph Wickert 2010-06-03 13:37:26 UTC
*** Bug 599429 has been marked as a duplicate of this bug. ***

Comment 5 Konstantin Svist 2010-06-09 02:07:15 UTC
Package: xfce4-xkb-plugin-0.5.3.3-3.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


Comment
-----
added keyboard applet, set shortcut to Alt+CapsLock

Comment 6 Victor Leschuk 2010-06-16 07:49:53 UTC
This happens at almost any action with xfce4-xkb-plugin (clicking on any button at configuration window) and also randomly when doing nothing with it. 

This issue makes xfce4-xkb-plugin completely unusable however there no other keyboard indicators for XFCE4 in fedora repo.

Comment 7 Christoph Wickert 2010-07-14 22:43:15 UTC
*** Bug 614658 has been marked as a duplicate of this bug. ***

Comment 8 Konstantin Svist 2010-07-22 17:24:52 UTC
Package: xfce4-xkb-plugin-0.5.3.3-3.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. add keyboard plugin
2. open preferences
3. close preferences

Comment 9 florin.smeu 2010-07-26 06:02:43 UTC
Package: xfce4-xkb-plugin-0.5.3.3-3.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.Right click on Xfce panel
2.Click on "Add new items..."
3.Click on "Keyboard Layouts"
4.Click on "Add" button; a configuration windows appears...
5.Click on "Close" button => the applet crashes!


Comment
-----
Xfce Keyboard Layouts applet crashes after closing it's configuration window.

Comment 10 Dmitrij Rebrov 2010-08-08 11:03:22 UTC
Package: xfce4-xkb-plugin-0.5.3.3-3.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Trying to add and configure xfce4-xkb-plugin at xfce4 panel
2. it totally crashes
3.

Comment 11 Christoph Wickert 2010-10-08 23:42:35 UTC
*** Bug 641507 has been marked as a duplicate of this bug. ***

Comment 12 Christoph Wickert 2010-11-06 01:46:53 UTC
*** Bug 650376 has been marked as a duplicate of this bug. ***

Comment 13 Christoph Wickert 2010-11-08 13:19:13 UTC
*** Bug 650939 has been marked as a duplicate of this bug. ***

Comment 14 Marian Klampar 2010-11-08 16:22:28 UTC
Package: xfce4-xkb-plugin-0.5.3.3-3.fc13
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.
2.
3.
hi problem with icons

Comment 15 Marian Klampar 2010-11-08 16:23:53 UTC
Package: xfce4-xkb-plugin-0.5.3.3-3.fc13
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.
2.
3.
have problem with kybord icon

Comment 16 Vadim Lipovetsky 2010-11-17 07:26:08 UTC
Package: xfce4-xkb-plugin-0.5.3.3-3.fc13
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Add keyboard layout to the panel.
2. Add hebrew layout
3. Close keyboard layout dialog box.
4. Crash.

Comment 17 François Cami 2010-11-19 23:46:17 UTC
Fix from upstream bug integrated in:
http://fcami.fedorapeople.org/srpms/xfce4-xkb-plugin-0.5.3.3-4.fc14.src.rpm

Comment 18 Fedora Update System 2010-11-25 21:02:57 UTC
xfce4-xkb-plugin-0.5.3.3-4.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/xfce4-xkb-plugin-0.5.3.3-4.fc14

Comment 19 Fedora Update System 2010-11-25 21:03:59 UTC
xfce4-xkb-plugin-0.5.3.3-4.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/xfce4-xkb-plugin-0.5.3.3-4.fc13

Comment 20 François Cami 2010-11-25 21:11:55 UTC
You should be able to  install the update candidate soon (in a few hours) with:
# yum update xfce4-xkb-plugin --enablerepo=updates-testing

Could you please provide us with feedback (tell us if your problem is fixed or not) through the admin.fedoraproject.org links above?

Comment 21 Fedora Update System 2010-11-26 21:08:58 UTC
xfce4-xkb-plugin-0.5.3.3-4.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xfce4-xkb-plugin'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/xfce4-xkb-plugin-0.5.3.3-4.fc14

Comment 22 Christoph Wickert 2010-11-30 10:32:13 UTC
*** Bug 658417 has been marked as a duplicate of this bug. ***

Comment 23 Christoph Wickert 2010-11-30 10:34:37 UTC
This crash affects at least 11 people, but so far none of you has provided any feedback on the update. The more feedback you provide in the update, the sooner it gets pushed out to the updates repository.

Comment 24 Pavel Holica 2010-11-30 14:41:45 UTC
I've tested xfce4-xkb-plugin-0.5.3.3-4.fc14.i686 using approach described in Bug 658417 and the crash didn't occured.

Comment 25 François Cami 2010-11-30 14:45:14 UTC
Pavel, then please provide us with feedback through Bodhi.

For F13:
https://admin.fedoraproject.org/updates/xfce4-xkb-plugin-0.5.3.3-4.fc13

For F14:
https://admin.fedoraproject.org/updates/xfce4-xkb-plugin-0.5.3.3-4.fc14

Comment 26 Nikola Ciprich 2010-12-01 10:34:39 UTC
Package: xfce4-xkb-plugin-0.5.3.3-3.fc13
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. add XFCE xkb applet
2. in applet settings, add another keyboard layout (I used Czech qwerty)
3. Apply settings

Comment 27 François Cami 2010-12-01 10:39:34 UTC
Nikola,

We've published a tentative fix for that issue. 

Could you please execute the procedure detailed in comment 20 and 21 and provide us with feedback (see comment 25)?

Comment 28 Nikola Ciprich 2010-12-01 11:19:51 UTC
François,
update from testing indeed fixes the problems, applet now seems to be usable! Thanks!

Comment 29 François Cami 2010-12-01 11:28:46 UTC
OK. Please post your experience in bodhi, otherwise we can't push to stable.

For F13:
https://admin.fedoraproject.org/updates/xfce4-xkb-plugin-0.5.3.3-4.fc13

For F14:
https://admin.fedoraproject.org/updates/xfce4-xkb-plugin-0.5.3.3-4.fc14

Comment 30 Fedora Update System 2010-12-01 21:55:16 UTC
xfce4-xkb-plugin-0.5.3.3-4.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 31 Fedora Update System 2010-12-05 00:39:57 UTC
xfce4-xkb-plugin-0.5.3.3-4.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.