Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 591786 - [abrt] crash in syncevolution-1.0beta3-1.fc13: dbus_error_is_set: Process /usr/libexec/syncevo-dbus-server was killed by signal 11 (SIGSEGV)
[abrt] crash in syncevolution-1.0beta3-1.fc13: dbus_error_is_set: Process /us...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: syncevolution (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
abrt_hash:05ba06bc969192359840271ef61...
:
: 591417 597745 597881 598030 599321 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-13 02:42 EDT by Blonďák
Modified: 2010-06-25 20:26 EDT (History)
12 users (show)

See Also:
Fixed In Version: syncevolution-1.0-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-25 14:11:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (10.79 KB, text/plain)
2010-05-13 02:42 EDT, Blonďák
no flags Details

  None (edit)
Description Blonďák 2010-05-13 02:42:41 EDT
abrt 1.1.0 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/libexec/syncevo-dbus-server
component: syncevolution
crash_function: dbus_error_is_set
executable: /usr/libexec/syncevo-dbus-server
global_uuid: 05ba06bc969192359840271ef61ec91c95346d1c
kernel: 2.6.33.3-85.fc13.x86_64
package: syncevolution-1.0beta3-1.fc13
rating: 4
reason: Process /usr/libexec/syncevo-dbus-server was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)
How to reproduce: Execute syncevolution and wait
Comment 1 Blonďák 2010-05-13 02:42:43 EDT
Created attachment 413648 [details]
File: backtrace
Comment 2 Blonďák 2010-05-20 03:44:39 EDT
Package: syncevolution-1.0beta3-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
run syncevo-dbus-server
Comment 3 Pete Gale 2010-05-24 15:10:14 EDT
Package: syncevolution-1.0beta3-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Plug in my iPhone.
2.
3.
Comment 4 Pete Gale 2010-05-26 00:08:19 EDT
Package: syncevolution-1.0beta3-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Plug in my iPhone.
2.
3.
Comment 5 Pete Gale 2010-05-31 02:04:05 EDT
Package: syncevolution-1.0beta3-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Booted
2. Plugged in my iPhone
3.
Comment 6 Peter Robinson 2010-05-31 06:18:51 EDT
*** Bug 591417 has been marked as a duplicate of this bug. ***
Comment 7 Peter Robinson 2010-05-31 06:19:00 EDT
*** Bug 597745 has been marked as a duplicate of this bug. ***
Comment 8 Peter Robinson 2010-05-31 06:19:08 EDT
*** Bug 597881 has been marked as a duplicate of this bug. ***
Comment 9 Peter Robinson 2010-05-31 06:19:10 EDT
*** Bug 598030 has been marked as a duplicate of this bug. ***
Comment 10 Bernie Innocenti 2010-06-05 18:47:15 EDT
Package: syncevolution-1.0beta3-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
Crashes immediately at startup
Comment 11 Bernie Innocenti 2010-06-05 18:48:02 EDT
Package: syncevolution-1.0beta3-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
Crashes at startup
Comment 12 Peter Robinson 2010-06-08 07:25:58 EDT
*** Bug 599321 has been marked as a duplicate of this bug. ***
Comment 13 Blonďák 2010-06-15 14:49:19 EDT
Package: syncevolution-1.0beta3-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
login and wait or execute /usr/libexec/syncevo-dbus-server
Comment 14 Robert Martin 2010-06-18 14:34:49 EDT
Package: syncevolution-1.0beta3-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


Comment
-----
I did nothing that I am aware of that generated this error.  Was in the process of installing the entire Yum Fedora respository on system.
Comment 15 Fedora Update System 2010-06-20 16:52:26 EDT
syncevolution-1.0-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/syncevolution-1.0-2.fc13
Comment 16 Felix Möller 2010-06-20 18:55:17 EDT
Running the new syncevolution I get:
fm@thinkpad:~ # gdb /usr/libexec/syncevo-dbus-server
GNU gdb (GDB) Fedora (7.1-26.fc13)
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/libexec/syncevo-dbus-server...Reading symbols from /usr/lib/debug/usr/libexec/syncevo-dbus-server.debug...done.
done.
(gdb) r
Starting program: /usr/libexec/syncevo-dbus-server 
[Thread debugging using libthread_db enabled]

Program received signal SIGSEGV, Segmentation fault.
dbus_error_is_set (error=0x1) at dbus-errors.c:330
330       return error->name != NULL;
Missing separate debuginfos, use: debuginfo-install GConf2-2.28.1-1.fc13.i686 ORBit2-2.14.18-1.fc13.i686 atk-1.30.0-1.fc13.i686 cairo-1.8.10-1.fc13.i686 cppunit-1.12.1-3.fc12.i686 cyrus-sasl-lib-2.1.23-11.fc13.i686 dbus-glib-0.84-3.fc13.i686 evolution-data-server-2.30.1-3.fc13.i686 expat-2.0.1-10.fc13.i686 fontconfig-2.8.0-1.fc13.i686 freetype-2.3.11-3.fc13.i686 gnutls-2.8.6-2.fc13.i686 gtk2-2.20.1-1.fc13.i686 keyutils-libs-1.2-6.fc12.i686 krb5-libs-1.7.1-10.fc13.i686 libX11-1.3.1-3.fc13.i686 libXau-1.0.5-1.fc12.i686 libXcomposite-0.4.1-2.fc13.i686 libXcursor-1.1.10-4.fc13.i686 libXdamage-1.1.2-2.fc13.i686 libXext-1.1-2.fc13.i686 libXfixes-4.0.4-2.fc13.i686 libXi-1.3-2.fc13.i686 libXinerama-1.1-2.fc13.i686 libXrandr-1.3.0-5.fc13.i686 libXrender-0.9.5-1.fc13.i686 libcom_err-1.41.10-6.fc13.i686 libgcrypt-1.4.5-4.fc13.i686 libgnome-keyring-2.30.1-1.fc13.i686 libgpg-error-1.7-1.fc13.i686 libical-0.43-5.fc12.i686 libnotify-0.4.5-4.fc13.i686 libproxy-0.3.1-4.fc13.i686 libselinux-2.0.90-5.fc13.i686 libsoup-2.30.1-1.fc13.i686 libtasn1-2.4-2.fc13.i686 libxcb-1.5-1.fc13.i686 libxml2-2.7.7-1.fc13.i686 nspr-4.8.4-2.fc13.i686 nss-3.12.6-7.fc13.i686 nss-softokn-freebl-3.12.6-3.fc13.i686 nss-util-3.12.6-1.fc13.i686 openssl-1.0.0a-1.fc13.i686 pango-1.28.0-1.fc13.i686 pcre-7.8-3.fc12.i686 pixman-0.18.0-1.fc13.i686 sqlite-3.6.22-1.fc13.i686
(gdb) bt
#0  dbus_error_is_set (error=0x1) at dbus-errors.c:330
#1  0x00969ff6 in internal_bus_get (type=DBUS_BUS_SESSION, private=0, error=0x1) at dbus-bus.c:435
#2  0x00a9169d in g_dbus_setup_bus (type=DBUS_BUS_SESSION, name=0x80c0c91 "org.syncevolution", error=0x1) at mainloop.c:458
#3  0x0809d739 in main (argc=1, argv=0xbffff3e4) at syncevo-dbus-server.cpp:5869


fm@thinkpad:~ # rpm -qa syncev*
syncevolution-debuginfo-1.0-2.fc13.i686
syncevolution-libs-1.0-2.fc13.i686
syncevolution-gtk-1.0-2.fc13.i686
syncevolution-perl-1.0-2.fc13.i686
syncevolution-1.0-2.fc13.i686
Comment 17 Jan Becker 2010-06-21 08:39:27 EDT
Package: syncevolution-1.0beta3-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. started evolution
2. cklicked on calendar
3. waited 2 minutes
Comment 18 Fedora Update System 2010-06-21 17:41:46 EDT
syncevolution-1.0-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update syncevolution'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/syncevolution-1.0-2.fc13
Comment 19 vaccaaa 2010-06-22 09:17:35 EDT
The problem persists in syncevolution-1.0-2.fc13 from testing repository... The bug is still open..
Comment 20 Paul Finnigan 2010-06-22 14:26:21 EDT
I am still having the same problems.

'syncevolution --template ?' fails, as does 'syncevolution --help'
Comment 21 Fedora Update System 2010-06-25 14:11:24 EDT
syncevolution-1.0-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 22 Olivier Crête 2010-06-25 20:22:53 EDT
Do you even read the comments on this bug? The update did NOT fix the problem...
Comment 23 Peter Robinson 2010-06-25 20:26:27 EDT
(In reply to comment #22)
> Do you even read the comments on this bug? The update did NOT fix the
> problem...    

Yes actually I do. But the way the fedora build system work it closes it off. Its now being tracked against the new bug report against the new version. Do you even read the fedora documentation.

Note You need to log in before you can comment on or make changes to this bug.