Bug 60004 - Issues installing on new disk.
Issues installing on new disk.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Alexandre Petit-Bianco
Beth Uptagrafft
:
: 60419 61328 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-18 16:02 EST by Alexandre Petit-Bianco
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-04 14:53:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Petit-Bianco 2002-02-18 16:02:46 EST
Description of Problem:

When installing on a new disk, the partition table isn't re-read properly,
making the installer abort at the time of creating filesystems.

An instance of the  python disk object seems to be kept live too long and
as a side effect, parted refuses re-read the partition table (parted
sees the device fd still open.)

Version-Release number of selected component (if applicable):

current.

How Reproducible:

Easily

Steps to Reproduce:
1. Start installing on a brand new disk or a disk whose partition table has
   been ereased (dd if=/dev/zero of=/dev/<device> bs=512 count=<enough>)
2. Go through the installation steps
3. The installer will abort trying to format the first partition of the new
   disk.

Actual Results:

Red Hat Linux isn't installed.

Expected Results:

Parition table should be re-read correctly, allowing the creation of 
filesystems on the partitions.

Additional Information:

This has been effectively traced with gdb to a device fd still marked used by
parted, because an instance of a Python object sharing it is still alive.

We don't know yet how this instance is still kept alive.
Comment 1 Alexandre Petit-Bianco 2002-03-04 14:53:50 EST
*** Bug 60419 has been marked as a duplicate of this bug. ***
Comment 2 Phil Copeland 2002-04-25 03:02:49 EDT
parted problem (fd left open)
Fixed for final

Closing

Phil
=--=
Comment 3 Beth Uptagrafft 2002-04-25 13:23:59 EDT
*** Bug 61328 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.