Bug 60023 - GUI install crashes when choosing individual package
Summary: GUI install crashes when choosing individual package
Status: CLOSED DUPLICATE of bug 61651
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.3
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-19 04:47 UTC by Wil Coulbourn
Modified: 2007-04-18 16:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-21 19:25:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Wil Coulbourn 2002-02-19 04:47:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.4)
Gecko/20011019 Netscape6/6.2

Description of problem:
During a GUI install or upgrade the system can be crashed when choosing the
individual packages.  
There are two "System Environment/Base" folders.  Clicking on the first base
folder causes the system to abort the install and shutdown.  
This can be done repeated however, it is not producable by clicking on that
folder first.  It only happens after choosing other folders and
checking/unchecking several packages.
The following is the error messages that show up onscreen:

anaconda(pid:75): Gtk-ERROR **: file gtkbtree.c: line 1147
(_gtk_rbtree_find_offset): assertion failed:(tree)
aborting...
install exited abnormally
sending termination signals...done
...
You may safely reboot your system

----
I believe this may be related to Bug#60020.  In that clicking on the Base
subfolder in the "System Environment" folder that has the full set does not
crash the system.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Go through the GUI install, Choose "Select Individual Packages" from the Group
selection screen.
2.Go into the various folders and check/uncheck packages.
3.There are two "System Environment" folders.  In one the only subfolder is
"Base", the other has a full set of subfolders. Click on the Base folder that is
by itself.
	

Actual Results:  The install aborts with the listed error

Additional info:

If you click on the problematic "Base" folder at the beginning of the selection
process the error does not occur. Nor does it occur if you clikc on the "Base"
folder, then make changes, then click on the "Base" folder again.  It will only
happen after selecting other folders first, then the specific "Base" folder.

Comment 1 Michael Fulbright 2002-02-19 19:37:26 UTC
Matt any ideas?

Comment 2 Jay Turner 2002-03-22 19:46:47 UTC

*** This bug has been marked as a duplicate of 61651 ***


Note You need to log in before you can comment on or make changes to this bug.