Bug 600298 - Please document the usage of '--fsoptions' for the 'part|partition' kickstart option in the install guide.
Please document the usage of '--fsoptions' for the 'part|partition' kickstart...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Installation_Guide (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Ruediger Landmann
ecs-bugs
: Documentation
Depends On:
Blocks: 601977 601980
  Show dependency treegraph
 
Reported: 2010-06-04 07:57 EDT by Mike A. Harris
Modified: 2012-04-12 21:04 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 601977 (view as bug list)
Environment:
Last Closed: 2012-04-12 21:04:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike A. Harris 2010-06-04 07:57:38 EDT
Description of problem:
Kickstart documentation in the "RHEL Installation Guide" does not document the
'part|partition' option's "--fsoptions" option.

Version-Release number of selected component (if applicable):
RHEL 5.5 and earlier.

How reproducible:
100%

Steps to Reproduce:
1. Read the installation guide's section on kickstart from start to finish.
2. Read through it again looking for a way to specify mount options.
3. Observe that there isn't any such option documented for the 'part' option.

Actual results:
Write your own ugly script in %post to munge fstab because you can't find a
built in method to specify mount options.  Hit corner cases that don't quite work right and have to special case them while your nose hairs fall out.  ;o)

Accidentally stumble upon the --fsoptions option documented in the 'raid' and 'logvol' options, and then notice it also on the Fedoraproject website anaconda documentation.

Test the option out in a dummy kickstart install and discover that it actually works with 'part' and not just with 'raid' and 'logvol'.  Rejoice and remove a screenful of unnecessary bash scripting from %post.  ;o)


Expected results:
For --fsoptions to be documented under the 'part' option, and any other missing options that there might be left to discover. ;o)


Additional info:
I'd paste my fstab_munge() function here for completeness but it'd make you barf.
Comment 1 Chris Lumens 2010-06-04 13:09:15 EDT
Here's what docs/kickstart-docs.txt on rhel5-branch has to say:

       --fsoptions=

           Specifies a free form string of options to be used when
           mounting the filesystem. This string will be copied into the
           /etc/fstab file of the installed system and should be enclosed
           in quotes.
Comment 2 Mike A. Harris 2010-06-05 06:51:29 EDT
I probably didn't file this bug report against the right component as it is technically not an anaconda bug.  The problem is specifically the RHEL 5 Installation Guide does not mention the option, so anyone using that as their basis for writing a kickstart file, will not see the --fsoptions documented for the 'part' command, and may resort to writing their own /etc/fstab mangling routines in %post.  When I discovered this and mentioned it in IRC, 3 or 4 other competent admins mentioned that they did the same type of mangling and were happy to find out about --fsoptions.

It is good that it is documented elsewhere, but all documentation should be consistent.  I suspect most admins, in particular newer admins will look either directly in the RHEL Installation Guide, or to Google, and "docs/kickstart.txt" doesn't come up high in the search list.  ;o)

I'll try to reassign this to the proper component if I can figure that out.
Comment 3 Mike A. Harris 2010-06-05 06:53:11 EDT
Doh, my bad...  I didn't notice it was already reassigned.  Good stuff.  Now that I'm aware of the option, this isn't for me, but rather for other admins out there who might not ever go looking beyond the installation guide for kickstart documentation.  It's a minor issue, but would still be nice to see it fixed in the next documentation update.
Comment 4 RHEL Product and Program Management 2010-08-09 14:16:17 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 6 Ruediger Landmann 2010-12-20 23:14:16 EST
Thanks for the feedback Mike; fixed in build 3.1-9
Comment 7 Mike A. Harris 2010-12-29 03:26:28 EST
Thanks for the update.

Note You need to log in before you can comment on or make changes to this bug.