Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 601980 - Please document the usage of '--fsoptions' for the 'part|partition' kickstart option in the install guide.
Please document the usage of '--fsoptions' for the 'part|partition' kickstart...
Status: CLOSED CURRENTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: install-guide (Show other bugs)
devel
All Linux
low Severity medium
: ---
: ---
Assigned To: Petr Bokoc
Ruediger Landmann
:
Depends On: 600298 601977
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-08 19:47 EDT by Michael Hideo
Modified: 2013-07-29 11:46 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 601977
Environment:
Last Closed: 2013-07-29 11:46:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Hideo 2010-06-08 19:47:54 EDT
+++ This bug was initially created as a clone of Bug #601977 +++

+++ This bug was initially created as a clone of Bug #600298 +++

Description of problem:
Kickstart documentation in the "RHEL Installation Guide" does not document the
'part|partition' option's "--fsoptions" option.

Version-Release number of selected component (if applicable):
RHEL 5.5 and earlier.

How reproducible:
100%

Steps to Reproduce:
1. Read the installation guide's section on kickstart from start to finish.
2. Read through it again looking for a way to specify mount options.
3. Observe that there isn't any such option documented for the 'part' option.

Actual results:
Write your own ugly script in %post to munge fstab because you can't find a
built in method to specify mount options.  Hit corner cases that don't quite work right and have to special case them while your nose hairs fall out.  ;o)

Accidentally stumble upon the --fsoptions option documented in the 'raid' and 'logvol' options, and then notice it also on the Fedoraproject website anaconda documentation.

Test the option out in a dummy kickstart install and discover that it actually works with 'part' and not just with 'raid' and 'logvol'.  Rejoice and remove a screenful of unnecessary bash scripting from %post.  ;o)


Expected results:
For --fsoptions to be documented under the 'part' option, and any other missing options that there might be left to discover. ;o)


Additional info:
I'd paste my fstab_munge() function here for completeness but it'd make you barf.

--- Additional comment from clumens@redhat.com on 2010-06-04 13:09:15 EDT ---

Here's what docs/kickstart-docs.txt on rhel5-branch has to say:

       --fsoptions=

           Specifies a free form string of options to be used when
           mounting the filesystem. This string will be copied into the
           /etc/fstab file of the installed system and should be enclosed
           in quotes.

--- Additional comment from mharris@mharris.ca on 2010-06-05 06:51:29 EDT ---

I probably didn't file this bug report against the right component as it is technically not an anaconda bug.  The problem is specifically the RHEL 5 Installation Guide does not mention the option, so anyone using that as their basis for writing a kickstart file, will not see the --fsoptions documented for the 'part' command, and may resort to writing their own /etc/fstab mangling routines in %post.  When I discovered this and mentioned it in IRC, 3 or 4 other competent admins mentioned that they did the same type of mangling and were happy to find out about --fsoptions.

It is good that it is documented elsewhere, but all documentation should be consistent.  I suspect most admins, in particular newer admins will look either directly in the RHEL Installation Guide, or to Google, and "docs/kickstart.txt" doesn't come up high in the search list.  ;o)

I'll try to reassign this to the proper component if I can figure that out.

--- Additional comment from mharris@mharris.ca on 2010-06-05 06:53:11 EDT ---

Doh, my bad...  I didn't notice it was already reassigned.  Good stuff.  Now that I'm aware of the option, this isn't for me, but rather for other admins out there who might not ever go looking beyond the installation guide for kickstart documentation.  It's a minor issue, but would still be nice to see it fixed in the next documentation update.
Comment 1 Jack Reed 2011-10-19 00:37:31 EDT
--fsoptions is now documented in the F16 version of the guide. 

Draft link is http://docs.fedoraproject.org/en-US/Fedora_Draft_Documentation/0.1/html/Installation_Guide/index.html
Comment 2 Karsten Wade 2011-12-13 22:46:25 EST
Removing myself for these bug components as I'm either no longer involved in that aspect of the project, or no longer care to watch this particular bug. Sorry if you are caught in a maelstrom of bug changes as a result!

Note You need to log in before you can comment on or make changes to this bug.