Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 601170 - Group all missing tasks together
Group all missing tasks together
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: command line (Show other bugs)
0.6
All Linux
low Severity medium (vote)
: 0.6.04
: ---
Assigned To: Dan Callaghan
:
Depends On:
Blocks: 601174
  Show dependency treegraph
 
Reported: 2010-06-07 07:55 EDT by Jan Ščotka
Modified: 2011-02-09 20:01 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-09 20:01:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Ščotka 2010-06-07 07:55:36 EDT
Description of problem:
I met several times problem with submitting job.
I do it for tier test purpose for BaseOS, and sometimes happen, that I must add new test,
for example tier test have over 200 of scheduled tests.
And problematic is, that beaker try to find if all rpms are in beaker repository, and sometimes it fails and show me something like:
$ bkr job-submit --convert beaker-xml
<Fault 1: "bkr.server.bexceptions.BX:u'Invalid Task: /CoreOS/tzdata/Regression/bz517009-Egypt-DST-2009'">

And in some cases there is more than 10 of similar problems (always is shown only one) so I must remove these tests from the xml file, in long time queue.
Comment 1 Marian Csontos 2011-01-31 01:36:09 EST
See also Bug 627286.
Comment 2 Dan Callaghan 2011-01-31 23:36:16 EST
Jan, to make sure I'm clear on this: you are submitting a job with several tasks which do not exist in Beaker, but the error message from the scheduler only mentions the first invalid task. You would like it to list all the invalid tasks, like:

Invalid task(s): /CoreOS/tzdata/Regression/one, /CoreOS/tzdata/Regression/two, /CoreOS/tzdata/Regression/three

Is that right?

I'm curious, why do these tasks not exist in Beaker?
Comment 3 Jan Ščotka 2011-02-01 02:26:29 EST
Hi Dan,
Yes, You understand my problem perfectly.
We do tier tests where are hunderds of tests and it isn't easy to be sure that all of tests are there, because I'm not an author of all of the tests and sometimes author forgot to add it into beaker, or something wrong happen (for example somebody write new test, add it into our tier, but forget to submit into beaker).
mostly up to 10 test per 150 what are okay, but it take very long time, to try schedule test, find whats wrong, remove it, schedule, find whats wrong, remove it, etc ...
Better to see all test together what are unable to be scheduled and then I'll be able remove all of them, and also report to our mailing list.
   Thanks
   Honza
Comment 6 Dan Callaghan 2011-02-09 20:01:28 EST
Beaker 0.6.4 has been released.

Note You need to log in before you can comment on or make changes to this bug.