Bug 601174 - Allow job submission with missing tasks
Summary: Allow job submission with missing tasks
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: command line (Show other bugs)
(Show other bugs)
Version: 0.6
Hardware: All Linux
low
medium vote
Target Milestone: 0.6.04
Assignee: Dan Callaghan
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On: 601170
Blocks: 593663
TreeView+ depends on / blocked
 
Reported: 2010-06-07 11:59 UTC by Jan Ščotka
Modified: 2011-02-10 01:01 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-10 01:01:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jan Ščotka 2010-06-07 11:59:27 UTC
Description of problem:
linked with bz601170

I met several times problem with submitting job.
I do it for tier test purpose for BaseOS, and sometimes happen, that I must add new test,
for example tier test have over 200 of scheduled tests.
And problematic is, that beaker try to find if all rpms are in beaker repository, and sometimes it fails and show me something like:
$ bkr job-submit --convert beaker-xml
<Fault 1: "bkr.server.bexceptions.BX:u'Invalid Task: /CoreOS/tzdata/Regression/bz517009-Egypt-DST-2009'">

So I expect some type of fault tolerance option for example --force to do that.
Because for me and for tier test is better to schedule it, with missing tasks, than it is not scheduled.
   Thanks

Comment 1 Marian Csontos 2011-01-31 07:46:14 UTC
Placeholder task could be used instead of simple omitting the task as that may put multihost off sync e.g. when a task is unavailable for architecture of one of the machines?

Different RPM can be used for these tasks while keep name and role intact. This would also make re-scheduling job after the tasks are uploaded/fixed easier.

Comment 2 Dan Callaghan 2011-02-01 00:44:56 UTC
(In reply to comment #1)

Marian, that a very good point about multihost tests getting out of sync. At the moment though we already have this problem, when a task is excluded because of arch/family: it is just silently removed. So I will do the same thing for this RFE. I will open a separate RFE with your idea of using a placeholder task.

Comment 3 Dan Callaghan 2011-02-01 23:08:34 UTC
(In reply to comment #1)

Bug 674229 is the RFE for inserting placeholder tasks.

Comment 6 Dan Callaghan 2011-02-10 01:01:15 UTC
Beaker 0.6.4 has been released.


Note You need to log in before you can comment on or make changes to this bug.