Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 606414 - request addendum to minimum requirements page
request addendum to minimum requirements page
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Deployment_Guide (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Jaromir Hradilek
ecs-bugs
: Documentation
Depends On:
Blocks: 614668 618860
  Show dependency treegraph
 
Reported: 2010-06-21 10:59 EDT by Neil Horman
Modified: 2016-06-17 17:11 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 614668 618860 (view as bug list)
Environment:
Last Closed: 2010-11-11 10:28:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
crash documentation update (6.74 KB, text/plain)
2010-08-25 09:36 EDT, Dave Anderson
no flags Details

  None (edit)
Description Neil Horman 2010-06-21 10:59:43 EDT
Description of problem:
The kdump technology that we ship currently calls for a large amount of ram to be reserved at boot time, which cannot be used by other applications.  As such I'd like to add the following footnote to the minumim requirements for RHEL:


If the kdump crash recovery technology is enabled an in use on a given system, minumum memory requirements should be raised by the amount of memory reserved for kdump usage.  This value is determined by the user, and specified on the kernel command line, via the crashkernel parameter.  The default value for this setting is 128MB.
Comment 2 RHEL Product and Program Management 2010-06-21 11:23:23 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Douglas Silas 2010-06-21 11:39:14 EDT
CCing Ryan for the release notes, and Jarek, who may end up handling the kdump documentation in the DG (bug 451059). Assigning to Jarek for now for that reason.

-- Silas
Comment 4 Douglas Silas 2010-07-14 17:39:43 EDT
Ryan,

Should I add Neil's description (and others I come across such as this one) to the Technical Notes field, as Tom did with bug 606993? This will make it into the 6_1 (not 6_0) Deployment guide.

Thanks,

Silas
Comment 5 Jaromir Hradilek 2010-07-30 05:12:09 EDT
Fixed in Red_Hat_Enterprise_Linux-Deployment_Guide-6-en-US-0.5-36.

http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6/html/Deployment_Guide/ch-kdump.html#s2-kdump-configuration-gui
Comment 7 Dave Anderson 2010-08-25 08:59:43 EDT
The "Displaying a Backtrace" page in the document is really strange:

http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6/html/Deployment_Guide/s2-kdump-crash-backtrace.html

It shows this:

crash> bt
PID: 5108   TASK: ee939980  CPU: 0   COMMAND: "bash"
 #0 [eeabfde8] ia32_sysenter_target at c0465b5c
 #1 [eeabfe3c] oops_end at c077209b
 #2 [eeabfe50] ia32_sysenter_target at c04206ac
    EAX: 00000000  EBX: c08833f3  ECX: 00000000  EDX: 00000046
    DS:  fffffed8      ESI: 00000002  ES:  fffffe8c      EDI: c076ee9d
    SS:  0001      ESP: c04207f4  EBP: ee939980  GS:  0002
    CS:  ffff8210      EIP: 00000000  ERR: eeabfed8  EFLAGS: eeabfea4

I thought this might be a crash bug because it's missing several
frames, the exception frame, etc.

So I create another x86 dumpfile from a 2.6.32-69.el6 kernel, with
kexec-tools-2.0.0-143.el6 to see if I could reproduce the above
with a "echo c > /proc/sysrq-trigger".  But when I do it, the
backtrace is correct:

crash> bt
PID: 5591   TASK: f196d560  CPU: 2   COMMAND: "bash"
 #0 [ef4dbdcc] crash_kexec at c0494922
 #1 [ef4dbe20] oops_end at c080e402
 #2 [ef4dbe34] no_context at c043089d
 #3 [ef4dbe58] bad_area at c0430b26
 #4 [ef4dbe6c] do_page_fault at c080fb9b
 #5 [ef4dbee4] error_code (via page_fault) at c080d809
    EAX: 00000063  EBX: 00000063  ECX: c09e1c8c  EDX: 00000000  EBP: 00000000 
    DS:  007b      ESI: c0a09ca0  ES:  007b      EDI: 00000286  GS:  00e0
    CS:  0060      EIP: c068124f  ERR: ffffffff  EFLAGS: 00010096 
 #6 [ef4dbf18] sysrq_handle_crash at c068124f
 #7 [ef4dbf24] __handle_sysrq at c0681469
 #8 [ef4dbf48] write_sysrq_trigger at c068150a
 #9 [ef4dbf54] proc_reg_write at c0569ec2
#10 [ef4dbf74] vfs_write at c051de4e
#11 [ef4dbf94] sys_write at c051e8cc
#12 [ef4dbfb0] system_call at c0409ad5
    EAX: ffffffda  EBX: 00000001  ECX: b7776000  EDX: 00000002 
    DS:  007b      ESI: 00000002  ES:  007b      EDI: b7776000
    SS:  007b      ESP: bfcb2088  EBP: bfcb20b4  GS:  0033
    CS:  0073      EIP: 00edc416  ERR: 00000004  EFLAGS: 00000246 
crash>

If the dumpfile which was used for the document example is still
around, I would like to see it.

In any case, the document's backtrace is really misleading.
Comment 8 Dave Anderson 2010-08-25 09:25:54 EDT
I can re-create each of the crash-utility output segments 
that are shown in the document, and attach them to this BZ.

Would that be helpful?
Comment 9 Dave Anderson 2010-08-25 09:36:45 EDT
Created attachment 440935 [details]
crash documentation update

Updated output for these examples:

Example 30.3. Running the crash utility
Example 30.4. Displaying the kernel message buffer
Example 30.5. Displaying the kernel stack trace
Example 30.6. Displaying status of processes in the system
Example 30.7. Displaying virtual memory information of the current context
Example 30.8. Displaying information about open files of the current context
Comment 12 releng-rhel@redhat.com 2010-11-11 10:28:51 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.