Bug 609530 - strigi: flac stream analyzer crashes
Summary: strigi: flac stream analyzer crashes
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: strigi   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Patch
: 605466 607463 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-30 14:03 UTC by Thomas Janssen
Modified: 2010-07-13 07:51 UTC (History)
8 users (show)

Fixed In Version: strigi-0.7.2-4.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-13 07:32:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 234398 None None None Never

Description Thomas Janssen 2010-06-30 14:03:29 UTC
Description of problem:
Strigi stream analyzer crashes dolphin sometimes even if you just hover the mouse over some sort of files.

Version-Release number of selected component (if applicable):
strigi-0.7.2-3

How reproducible:
Hover the mouse over a critical file (some tar.gz, some rpm)

Steps to Reproduce:
1. open Dolphin
2. go to rpmbuild/SOURCES
3. hover mouse over (here) Sentinella-0.6.1.tar.gz
  
Actual results:
Dolphin crashes

Expected results:
Dolphin does not crash

Additional info:
Fixed with a stream analyzer patch. Tested with strigi-0.7.2-4 in F13.

Upstream bugs:
https://bugs.kde.org/show_bug.cgi?id=240935
https://bugs.kde.org/show_bug.cgi?id=234398

Upstream diff:
http://websvn.kde.org/trunk/kdesupport/strigi/libstreamanalyzer/lib/endanalyzers/flacendanalyzer.cpp?r1=1115155&r2=1115154&pathrev=1115155

Comment 1 Rex Dieter 2010-06-30 14:06:39 UTC
I'll prepare an update, and start marking abrt nepomuk dupes against this one.

Comment 2 Thomas Janssen 2010-06-30 14:19:46 UTC
More info:

Dolphin still crashes when hover over or right click an rpm.

https://bugzilla.redhat.com/show_bug.cgi?id=609530

Upstream KDE bug:
https://bugs.kde.org/show_bug.cgi?id=231191

Upstream strigi bug
http://sourceforge.net/tracker/?func=detail&aid=3016947&group_id=171000&atid=856302

Comment 3 Rex Dieter 2010-06-30 14:59:54 UTC
*** Bug 607463 has been marked as a duplicate of this bug. ***

Comment 4 Rex Dieter 2010-06-30 15:04:37 UTC
*** Bug 605466 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2010-06-30 16:06:22 UTC
strigi-0.7.2-4.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/strigi-0.7.2-4.fc13

Comment 6 Fedora Update System 2010-06-30 16:06:55 UTC
strigi-0.7.2-4.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/strigi-0.7.2-4.fc12

Comment 7 Rex Dieter 2010-06-30 17:14:44 UTC
fyi, comment #2 issue is being tracked in bug #609541

Comment 8 Fedora Update System 2010-07-01 18:36:43 UTC
strigi-0.7.2-4.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update strigi'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/strigi-0.7.2-4.fc13

Comment 9 Fedora Update System 2010-07-01 18:46:27 UTC
strigi-0.7.2-4.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update strigi'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/strigi-0.7.2-4.fc12

Comment 10 Fedora Update System 2010-07-13 07:32:06 UTC
strigi-0.7.2-4.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2010-07-13 07:51:04 UTC
strigi-0.7.2-4.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.