Bug 609541 - strigi: inflateEnd, rpminputstream.cpp fail
strigi: inflateEnd, rpminputstream.cpp fail
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: strigi (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Deji Akingunola
Fedora Extras Quality Assurance
:
: 572402 572813 573334 573566 575423 576562 583480 583492 583886 584400 585080 586651 586652 586657 588197 588296 589091 599131 599793 604226 605403 608090 608667 609340 609358 610021 610922 611323 612487 613323 613460 613464 613738 613743 615746 616945 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-30 10:38 EDT by Rex Dieter
Modified: 2011-12-05 08:20 EST (History)
20 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-05 08:20:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 231191 None None None Never

  None (edit)
Description Rex Dieter 2010-06-30 10:38:43 EDT
Seeing a plethora of nepomuk-related crashes when it comes to parsing rpms.

They all have backtraces similar to:

Thread 1 (Thread 12413):
#0  inflateEnd (strm=0x7fed6c0ddc20) at inflate.c:1162
No locals.
#1  0x0000003e2801d46d in Strigi::GZipInputStream::Private::dealloc (this=
    0x7fed6c0ddc10)
    at /usr/src/debug/strigi-0.7.2/src/streams/gzipinputstream.cpp:97
No locals.
#2  0x0000003e2801d4b4 in Strigi::GZipInputStream::~GZipInputStream (this=
    0x7fed6c0ddbb0, __in_chrg=<value optimized out>)
    at /usr/src/debug/strigi-0.7.2/src/streams/gzipinputstream.cpp:90
No locals.
#3  0x0000003e2801d549 in Strigi::GZipInputStream::~GZipInputStream (this=
    0x7fed6c0ddbb0, __in_chrg=<value optimized out>)
    at /usr/src/debug/strigi-0.7.2/src/streams/gzipinputstream.cpp:91
No locals.
#4  0x0000003e280283e6 in Strigi::RpmInputStream::~RpmInputStream (this=
    0x7fed73d05640, __in_chrg=<value optimized out>)
    at /usr/src/debug/strigi-0.7.2/src/streams/rpminputstream.cpp:147
No locals.
#5  0x0000003e3064b2ed in RpmEndAnalyzer::analyze (this=0x7fed6c096ff0, 
    idx=<value optimized out>, in=0x7fed6c0c06c0)
    at /usr/src/debug/strigi-0.7.2/src/streamanalyzer/endanalyzers/rpmendanalyzer.cpp:87
        rpm = {<Strigi::SubStreamProvider> = {_vptr.SubStreamProvider = 
    0x3e28236ab0, m_status = Strigi::Error, m_error = 
    "Magic bytes for gz are wrong.", m_input = 0x7fed6c0c06c0, 
            m_entrystream = 0x0, m_entryinfo = warning: can't find linker symbol for virtual table for `Strigi::EntryInfo' value
warning:   found `std::basic_string<char, std::char_traits<char>, std::allocator<char> >::_Rep::_S_empty_rep_storage' instead
{filename = "", 
              properties = std::map with 0 elements
    Traceback (most recent call last):
  File "/usr/lib64/../share/gdb/python/libstdcxx/v6/printers.py", line 374, in children
    nodetype = gdb.lookup_type('std::_Rb_tree_node< std::pair< %s, %s > >' % (keytype, valuetype))
RuntimeError: No type named std::_Rb_tree_node< std::pair< const std::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::basic_string<char, std::char_traits<char>, std::allocator<char> > > >.
, size = -1, mtime = 0, type = Strigi::EntryInfo::Unknown}}, 
          uncompressionStream = 0x7fed6c0ddbb0, cpio = 0x0, 
          entryCompressedSize = 1811974176, compressionMethod = 32749, 
          headerinfo = 0x0}
Comment 1 Rex Dieter 2010-06-30 10:40:48 EDT
*** Bug 605403 has been marked as a duplicate of this bug. ***
Comment 2 Rex Dieter 2010-06-30 10:51:07 EDT
and some upstream bug references,
https://bugs.kde.org/show_bug.cgi?id=231191
http://sourceforge.net/tracker/?func=detail&aid=3016947&group_id=171000&atid=856302

Per my comment in the upstream report,

"To my layman eyes, in this case on fedora, it seems rpminputstream.cpp is
incorrectly trying to use GZipInputStream on our lzma/xz-compressed rpms."
Comment 3 Rex Dieter 2010-06-30 10:56:14 EDT
*** Bug 608839 has been marked as a duplicate of this bug. ***
Comment 4 Rex Dieter 2010-06-30 10:57:49 EDT
*** Bug 608667 has been marked as a duplicate of this bug. ***
Comment 5 Rex Dieter 2010-06-30 10:58:08 EDT
*** Bug 609340 has been marked as a duplicate of this bug. ***
Comment 6 Rex Dieter 2010-06-30 11:00:58 EDT
*** Bug 599793 has been marked as a duplicate of this bug. ***
Comment 7 Rex Dieter 2010-06-30 11:02:06 EDT
*** Bug 599131 has been marked as a duplicate of this bug. ***
Comment 8 Rex Dieter 2010-07-01 09:05:48 EDT
*** Bug 610021 has been marked as a duplicate of this bug. ***
Comment 9 Rex Dieter 2010-07-08 07:57:43 EDT
*** Bug 611323 has been marked as a duplicate of this bug. ***
Comment 10 Rex Dieter 2010-07-08 07:58:20 EDT
*** Bug 612487 has been marked as a duplicate of this bug. ***
Comment 11 Rex Dieter 2010-07-11 20:58:11 EDT
*** Bug 613460 has been marked as a duplicate of this bug. ***
Comment 12 Radek Novacek 2010-07-12 02:40:14 EDT
*** Bug 613464 has been marked as a duplicate of this bug. ***
Comment 13 Rex Dieter 2010-07-12 14:24:02 EDT
*** Bug 613743 has been marked as a duplicate of this bug. ***
Comment 14 Rex Dieter 2010-07-12 14:24:07 EDT
*** Bug 613738 has been marked as a duplicate of this bug. ***
Comment 15 Fedora Update System 2010-07-12 16:11:54 EDT
strigi-0.7.2-5.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/strigi-0.7.2-5.fc13
Comment 16 Fedora Update System 2010-07-12 16:25:16 EDT
strigi-0.7.2-5.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/strigi-0.7.2-5.fc12
Comment 17 Radek Novacek 2010-07-13 03:08:11 EDT
*** Bug 583492 has been marked as a duplicate of this bug. ***
Comment 18 Radek Novacek 2010-07-13 03:10:31 EDT
*** Bug 608090 has been marked as a duplicate of this bug. ***
Comment 19 Fedora Update System 2010-07-13 03:24:48 EDT
strigi-0.7.2-5.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update strigi'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/strigi-0.7.2-5.fc13
Comment 20 Fedora Update System 2010-07-13 03:31:38 EDT
strigi-0.7.2-5.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update strigi'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/strigi-0.7.2-5.fc12
Comment 21 Radek Novacek 2010-07-13 06:23:55 EDT
*** Bug 586651 has been marked as a duplicate of this bug. ***
Comment 22 Radek Novacek 2010-07-14 03:14:45 EDT
*** Bug 583886 has been marked as a duplicate of this bug. ***
Comment 23 Radek Novacek 2010-07-14 04:36:29 EDT
*** Bug 583480 has been marked as a duplicate of this bug. ***
Comment 24 Radek Novacek 2010-07-14 04:40:04 EDT
*** Bug 585080 has been marked as a duplicate of this bug. ***
Comment 25 Radek Novacek 2010-07-14 05:28:28 EDT
*** Bug 586657 has been marked as a duplicate of this bug. ***
Comment 26 Radek Novacek 2010-07-14 05:33:39 EDT
*** Bug 576562 has been marked as a duplicate of this bug. ***
Comment 27 Radek Novacek 2010-07-15 07:15:06 EDT
*** Bug 613323 has been marked as a duplicate of this bug. ***
Comment 28 Radek Novacek 2010-07-15 09:15:38 EDT
*** Bug 573566 has been marked as a duplicate of this bug. ***
Comment 29 Radek Novacek 2010-07-15 09:16:41 EDT
*** Bug 586652 has been marked as a duplicate of this bug. ***
Comment 30 Radek Novacek 2010-07-15 09:27:05 EDT
*** Bug 588296 has been marked as a duplicate of this bug. ***
Comment 31 Radek Novacek 2010-07-15 10:08:34 EDT
*** Bug 589091 has been marked as a duplicate of this bug. ***
Comment 32 Radek Novacek 2010-07-16 02:52:06 EDT
*** Bug 573334 has been marked as a duplicate of this bug. ***
Comment 33 Radek Novacek 2010-07-16 03:04:00 EDT
*** Bug 588197 has been marked as a duplicate of this bug. ***
Comment 34 Radek Novacek 2010-07-16 03:33:22 EDT
*** Bug 609358 has been marked as a duplicate of this bug. ***
Comment 35 Radek Novacek 2010-07-16 03:39:26 EDT
*** Bug 610922 has been marked as a duplicate of this bug. ***
Comment 36 Radek Novacek 2010-07-16 03:39:46 EDT
*** Bug 572813 has been marked as a duplicate of this bug. ***
Comment 37 Radek Novacek 2010-07-16 03:42:18 EDT
*** Bug 575423 has been marked as a duplicate of this bug. ***
Comment 38 Radek Novacek 2010-07-16 03:51:57 EDT
*** Bug 604226 has been marked as a duplicate of this bug. ***
Comment 39 Radek Novacek 2010-07-16 04:15:18 EDT
*** Bug 584400 has been marked as a duplicate of this bug. ***
Comment 40 Radek Novacek 2010-07-16 04:16:50 EDT
*** Bug 572402 has been marked as a duplicate of this bug. ***
Comment 41 Radek Novacek 2010-07-19 02:22:49 EDT
*** Bug 615746 has been marked as a duplicate of this bug. ***
Comment 42 Rex Dieter 2010-07-21 15:44:25 EDT
*** Bug 616945 has been marked as a duplicate of this bug. ***
Comment 43 Bug Zapper 2010-07-30 08:19:18 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.