Bug 611588 - Text/screen corruption with compiz enabled ....
Text/screen corruption with compiz enabled ....
Status: CLOSED DUPLICATE of bug 618679
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-05 16:02 EDT by Tom London
Modified: 2010-09-14 10:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-14 10:26:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (154.06 KB, text/plain)
2010-07-05 16:44 EDT, Tom London
no flags Details

  None (edit)
Description Tom London 2010-07-05 16:02:02 EDT
Description of problem:
[This is a regression, similar to https://bugzilla.redhat.com/show_bug.cgi?id=557451].

Updating to 
xorg-x11-server-common-1.8.99.904-1.20100702.fc14.x86_64
xorg-x11-server-Xorg-1.8.99.904-1.20100702.fc14.x86_64
xorg-x11-drv-intel-2.12.0-4.fc14.x86_64

causes compiz-enabled sessions to have corrupted screens: characters do not always render correctly (sometimes the do not render until another character or two is entered, sometimes they render as a solid black rectangle), CR/LF do not always show, etc. etc.

[Sorry if I have pointed to the wrong package.....]

Version-Release number of selected component (if applicable):
xorg-x11-server-common-1.8.99.904-1.20100702.fc14.x86_64
xorg-x11-server-Xorg-1.8.99.904-1.20100702.fc14.x86_64
xorg-x11-drv-intel-2.12.0-4.fc14.x86_64
libdrm-devel-2.4.21-3.fc14.x86_64
mesa-dri-drivers-7.9-0.2.fc14.x86_64
mesa-libGL-devel-7.9-0.2.fc14.x86_64
mesa-libGLU-devel-7.9-0.2.fc14.x86_64
mesa-libGLU-7.9-0.2.fc14.x86_64
libdrm-debuginfo-2.4.21-3.fc14.x86_64
mesa-debuginfo-7.9-0.2.fc14.x86_64
compiz-0.8.6-1.fc14.x86_64
mesa-libGL-7.9-0.2.fc14.x86_64
mesa-dri-drivers-experimental-7.9-0.2.fc14.x86_64
libdrm-2.4.21-3.fc14.x86_64

How reproducible:
Every time....

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2010-07-05 16:02:47 EDT
Sorry, forgot to mention hardware:  Thinkpad X200:

[root@tlondon ~]# lspci
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:03.0 Communication controller: Intel Corporation Mobile 4 Series Chipset MEI Controller (rev 07)
00:19.0 Ethernet controller: Intel Corporation 82567LM Gigabit Network Connection (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M-E LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
03:00.0 Network controller: Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Network Connection
[root@tlondon ~]#
Comment 2 Tom London 2010-07-05 16:44:55 EDT
Created attachment 429607 [details]
Xorg.0.log

Xorg.0.log

No Xorg.conf
Comment 3 Tom London 2010-07-09 09:14:17 EDT
This problem continues with:

[tbl@tlondon ~]$ rpm -qa xorg-x11-server\* xorg-x11-drv-intel mesa\*
mesa-libGLU-7.9-0.5.fc14.x86_64
mesa-libGL-devel-7.9-0.5.fc14.x86_64
mesa-libGLU-devel-7.9-0.5.fc14.x86_64
xorg-x11-server-utils-7.4-16.fc14.x86_64
xorg-x11-drv-intel-2.12.0-4.fc14.x86_64
mesa-debuginfo-7.9-0.2.fc14.x86_64
mesa-libGL-7.9-0.5.fc14.x86_64
xorg-x11-server-common-1.8.99.904-3.20100702.fc14.x86_64
mesa-dri-drivers-experimental-7.9-0.5.fc14.x86_64
xorg-x11-server-Xorg-1.8.99.904-3.20100702.fc14.x86_64
mesa-dri-drivers-7.9-0.5.fc14.x86_64
[tbl@tlondon ~]$ 

Running kernel-2.6.35-0.31.rc4.git4.fc14.x86_64

No problems is I revert 'desktop-effects' to metacity, but it occurs every time I enable compiz.
Comment 4 Bug Zapper 2010-07-30 08:27:22 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Tom London 2010-09-14 10:26:02 EDT

*** This bug has been marked as a duplicate of bug 618679 ***

Note You need to log in before you can comment on or make changes to this bug.