This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 612789 - cgroup file systems should be ignored when unmounting in /etc/rc.d/init.d/halt
cgroup file systems should be ignored when unmounting in /etc/rc.d/init.d/halt
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
: Reopened
: 627399 627645 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-08 22:33 EDT by Lennart Poettering
Modified: 2014-03-16 23:24 EDT (History)
7 users (show)

See Also:
Fixed In Version: initscripts-9.17-2.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-26 23:06:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lennart Poettering 2010-07-08 22:33:45 EDT
When booting a system with systemd /cgroup contains the cgroup hierarchies, and they cannot be unmounted on shutdown (or at least /cgroup/systemd cannot, and hence neither /cgroup). Currently, the halt script tries really hard to unmount the FS in a loop, which ultimately fails, but takes quite some time until it gives up.

/etc/rc.d/init.d/halt shoulds simply ignore all directories starting with /cgroup the same way as /proc and /sys are spared.
Comment 2 Lennart Poettering 2010-08-10 09:02:20 EDT
BTW: as it turns out this mount point of the cgroup fs has been mnoved in the kernel, to a place inside of /sys.
Comment 3 Bill Nottingham 2010-08-10 10:05:25 EDT
/sys/cgroup/...? Or somewhere else?
Comment 4 Michal Schmidt 2010-08-25 17:42:19 EDT
Reopening. With systemd-8 it now tries to umount /sys/fs/cgroup/systemd and /sys/fs/cgroup on shutdown.
Comment 5 Michal Schmidt 2010-08-26 11:32:19 EDT
*** Bug 627645 has been marked as a duplicate of this bug. ***
Comment 6 Bill Nottingham 2010-08-26 12:08:27 EDT
*** Bug 627399 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2010-08-26 13:49:37 EDT
systemd-8-2.fc14,initscripts-9.17-2.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/systemd-8-2.fc14,initscripts-9.17-2.fc14
Comment 8 Fedora Update System 2010-08-26 14:38:24 EDT
systemd-8-2.fc14, initscripts-9.17-2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update systemd initscripts'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/systemd-8-2.fc14,initscripts-9.17-2.fc14
Comment 9 Fedora Update System 2010-08-26 23:05:49 EDT
initscripts-9.17-2.fc14, systemd-8-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.