Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 61637 - i18n trouble with real names in address
i18n trouble with real names in address
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: evolution (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
: 61634 61635 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-22 09:15 EST by Leonid Kanter
Modified: 2007-04-18 12:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-02 09:41:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (58.82 KB, image/png)
2002-03-22 09:29 EST, Leonid Kanter
no flags Details

  None (edit)
Description Leonid Kanter 2002-03-22 09:15:06 EST
Description of Problem:

It's impossible to quickly add to address book somebody's name if it contain
characters not from current locale's charmap.

Version-Release number of selected component (if applicable):

1.0.2

How Reproducible:

always

Steps to Reproduce:
1. start evolution in ru_RU.koi8r locale
2. click right button on Trond's message and try to add his address to contacts list


Actual Results:

One character (slashed "o") will be shown as "_"

Expected Results:

It must be shown exactly as in message body
Comment 1 Leonid Kanter 2002-03-22 09:29:08 EST
Created attachment 49664 [details]
screenshot
Comment 2 Trond Eivind Glomsrxd 2002-03-22 10:29:02 EST
*** Bug 61635 has been marked as a duplicate of this bug. ***
Comment 3 Trond Eivind Glomsrxd 2002-03-22 10:30:23 EST
*** Bug 61634 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Katz 2002-03-22 17:37:44 EST
*** Bug 61681 has been marked as a duplicate of this bug. ***
Comment 5 Jeremy Katz 2002-03-25 18:55:03 EST
Probably due to the property bag not using a widget which handles UTF8 properly
which the rest of evo is careful to do.
Comment 6 Jeremy Katz 2003-06-29 16:33:13 EDT
This should be better in 1.4.x
Comment 7 Dave Malcolm 2004-11-01 16:16:29 EST
I'm sorry that this bug has gone for so long without activity.

Have you tried this in more recent versions of Evolution?  I believe that the
behaviour should have got substantially better in Evolution 1.4, and hopefully
has not regressed.

The current version of Evolution in Rawhide is 2.0.2 (which should be in FC3)
Comment 8 Leonid Kanter 2004-11-02 03:59:48 EST
Sure, in 2.0.2 everything is ok
Comment 9 Dave Malcolm 2004-11-02 09:41:06 EST
Thanks.  At this stage, doing maintenance work on such old versions of
Evolution is not a priority for me, so I'm going to resolve this as
fixed in the CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.