Bug 61903 - anaconda exception on bad component in ks file
anaconda exception on bad component in ks file
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
: 64595 74467 76460 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-25 15:44 EST by Erik van Konijnenburg
Modified: 2008-01-17 12:49 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-25 10:51:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erik van Konijnenburg 2002-03-25 15:44:35 EST
Description of Problem:

In the %packages section of your kickstart file, put '@ Development'
rather than '@ Kernel Development'.  During installation, this results 
in an unhandled exception popup.

Version-Release number of selected component (if applicable):


How Reproducible:

Consistently.

Steps to Reproduce:
1. 
2. 
3. 

Actual Results:

Popup with invitation to visit Bugzilla.

Expected Results:

Helpful message about how 'Development' is not a known group.

Additional Information:

The relevant lines from the anaconda trace:

  File "/usr/lib/anaconda/dispatch.py", line 209, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 107, in readPackages
    id.instClass.setGroupSelection(id.comps)
  File "/usr/lib/anaconda/kickstart.py", line 905, in setGroupSelection
    comps[n].select()
  File "/usr/lib/anaconda/comps.py", line 352, in __getitem__
    return self.compsDict[key]
KeyError: Development
Comment 1 Jeremy Katz 2002-03-25 19:23:25 EST
We are currently in a string and screen freeze but will revisit this for a
future release
Comment 2 Jeremy Katz 2002-05-08 19:25:08 EDT
*** Bug 64595 has been marked as a duplicate of this bug. ***
Comment 3 Jeremy Katz 2003-01-03 01:03:29 EST
*** Bug 76460 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Katz 2003-01-03 01:17:47 EST
*** Bug 74467 has been marked as a duplicate of this bug. ***
Comment 5 Jeremy Katz 2003-01-08 19:39:03 EST
Added a dialog informing you of the problem that lets you continue or abort. 
Also added --ignoremissing as an argument for %packages so that you can just
ignore them and not get prompted
Comment 6 Brent Fox 2003-05-25 10:51:30 EDT
I'm going through Bugzilla closing some bugs that have been marked as Modified
for some period of time.  I believe that most of these issues have been fixed,
so I'm resolving these bugs as Rawhide.  If the bug you are seeing still exists,
please reopen this report and mark it as Reopened.

Note You need to log in before you can comment on or make changes to this bug.