Bug 619098 - KVM guests do not consume FLEX entitlements
Summary: KVM guests do not consume FLEX entitlements
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: Clients   
(Show other bugs)
Version: 1.1
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Miroslav Suchý
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: space11 619100 624780
TreeView+ depends on / blocked
 
Reported: 2010-07-28 14:52 UTC by Miroslav Suchý
Modified: 2010-08-19 08:24 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 619100 (view as bug list)
Environment:
Last Closed: 2010-08-19 08:24:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Miroslav Suchý 2010-07-28 14:52:40 UTC
Description of problem:
KVM guests do not report as FLEX guest due to missing data in smbios.system.manufacturer

Version-Release number of selected component (if applicable):
RHEL6 Snapshot8

Steps to Reproduce:
1. install rhel6 host
2. startup kvm guest with rhel6
3. rhn_register
  
Actual results:
in hardware info is empty smbios.system.manufacturer:
PYTHONPATH='/usr/share/rhn/' python -c 'from up2date_client import hardware; print hardware.get_smbios()'

Expected results:
smbios.system.manufacturer should get data from 
/dmidecode/SystemInfo/Manufacturer and not from /dmidecode/BaseBoardInfo/Manufacturer

Comment 1 Miroslav Suchý 2010-07-28 14:58:08 UTC
commited as 3b2c2ecac7c02e8fce4866dc8e60d0ccff94356c

Comment 2 Milan Zázrivec 2010-08-19 08:24:50 UTC
Spacewalk 1.1 has been released.


Note You need to log in before you can comment on or make changes to this bug.