Bug 619100 - KVM guests do not consume FLEX entitlements
Summary: KVM guests do not consume FLEX entitlements
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rhn-client-tools
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Miroslav Suchý
QA Contact: Garik Khachikyan
URL:
Whiteboard:
Keywords:
Depends On: 619098
Blocks: 624780
TreeView+ depends on / blocked
 
Reported: 2010-07-28 15:01 UTC by Miroslav Suchý
Modified: 2015-01-04 21:57 UTC (History)
6 users (show)

(edit)
Clone Of: 619098
: 624780 (view as bug list)
(edit)
Last Closed: 2010-11-10 21:30:22 UTC


Attachments (Terms of Use)

Description Miroslav Suchý 2010-07-28 15:01:20 UTC
+++ This bug was initially created as a clone of Bug #619098 +++

Description of problem:
KVM guests do not report as FLEX guest due to missing data in smbios.system.manufacturer

Version-Release number of selected component (if applicable):
RHEL6 Snapshot8

Steps to Reproduce:
1. install rhel6 host
2. startup kvm guest with rhel6
3. rhn_register
  
Actual results:
in hardware info is empty smbios.system.manufacturer:
PYTHONPATH='/usr/share/rhn/' python -c 'from up2date_client import hardware; print hardware.get_smbios()'

Expected results:
smbios.system.manufacturer should get data from 
/dmidecode/SystemInfo/Manufacturer and not from /dmidecode/BaseBoardInfo/Manufacturer

--- Additional comment from msuchy@redhat.com on 2010-07-28 10:58:08 EDT ---

commited as 3b2c2ecac7c02e8fce4866dc8e60d0ccff94356c

Comment 1 Jay Turner 2010-07-28 15:16:38 UTC
QE ack.  This needs to be fixed . . . want to make sure we have RHEL6 "right" from the start.

Comment 3 Miroslav Suchý 2010-07-29 07:29:07 UTC
Change is in satellite.git in commit a9523f1bd6e78eeca157a26404c037b4e7ae4162

Comment 5 Garik Khachikyan 2010-08-13 12:32:56 UTC
# VERIFIED 

verified against package rhn-client-tools-1.0.0-34.el6

The python call of: hardware.get_smbios();
---
{'smbios.system.serial': 'Not Specified', 'smbios.system.manufacturer': 'Red Hat', 'smbios.system.skunumber': 'Not Specified', 'smbios.system.product': 'KVM', 'smbios.system.version': 'RHEL 6.0.0 PC', 'smbios.system.uuid': '6ce57e4f-a133-c522-dca4-f142f427c6bb', 'smbios.system.family': 'Red Hat Enterprise Linux', 'smbios.bios.vendor': 'Seabios'}
---
So the smbios.system.manufacturer = 'Red Hat'

Comment 7 releng-rhel@redhat.com 2010-11-10 21:30:22 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.