Bug 61917 - hwbrowser crashes when selected in system settings
Summary: hwbrowser crashes when selected in system settings
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: hwbrowser (Show other bugs)
(Show other bugs)
Version: 9
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Keywords:
: 67957 (view as bug list)
Depends On:
Blocks: 61590 67217
TreeView+ depends on / blocked
 
Reported: 2002-03-25 22:42 UTC by Gerry Tool
Modified: 2013-04-02 04:16 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-25 14:30:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gerry Tool 2002-03-25 22:42:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020314

Description of problem:
Logged in as root in Gnome, clicking on Hardware Browser in a Nautilus window of
System Settings, hwbrowser starts to open a window and then dies.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.log into gnome as root
2.click on system settings in Start Here
3.click on hardware browser
	

Actual Results:  hardware browser window frame opens with no data and then
disappears

Expected Results:  hardware browser window should open and display hardware
information

Additional info:

Comment 1 Jonathan Blandford 2002-03-27 17:13:04 UTC
Can you run it as in a terminal and post the traceback here?

Comment 2 Jay Turner 2002-03-28 19:04:04 UTC
I'm not able to replicate this behavior here in the lab with hwbrowser-0.3.6-2.

Comment 3 Alexander Larsson 2002-04-10 14:23:43 UTC
Does hwbrowser print anything?
It could be the stupid bug we had where nautilus forked processes with read-only
stdout. Could you try installing eel-1.0.2-10 and try again.



Comment 4 Preston Brown 2002-08-20 19:02:20 UTC
*** Bug 67957 has been marked as a duplicate of this bug. ***

Comment 5 Preston Brown 2002-08-20 19:03:10 UTC
*** Bug 66581 has been marked as a duplicate of this bug. ***

Comment 6 Preston Brown 2002-08-20 19:23:39 UTC
soon to be fixed in rawhide.

Comment 7 Gerry Tool 2002-08-21 20:22:05 UTC
Which package fixed this?  I have the latest rawhide hwbrowser package
installed, and it still crashes.

Comment 8 Peter van Egdom 2002-08-21 21:53:47 UTC
Please reopen this bug.

Tested this on a fresh installed Red Hat Linux 7.3.94 ('null') and this is
what happens when starting "hwbrowser" from the command line :

(DeviceList.py:3280): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:3280): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed
Traceback (most recent call last):
  File "/usr/share/hwbrowser/DeviceList.py", line 163, in ?
    setup_ui ()
  File "/usr/share/hwbrowser/DeviceList.py", line 156, in setup_ui
    DeviceDisk.initialize (xml, hardware)
  File "/usr/share/hwbrowser/DeviceDisk.py", line 485, in initialize
    populate (tree_view, disks, graph)
  File "/usr/share/hwbrowser/DeviceDisk.py", line 379, in populate
    raise RuntimeError, ("can't handle more than "
RuntimeError: can't handle more than one extended partition per disk
[root@localhost peterve]# 


Source RPM: hwbrowser-0.4.1-2.src.rpm



Comment 9 Bill Nottingham 2002-08-28 01:59:10 UTC
Should be fixed in 0.5-1

Comment 10 Tim Waugh 2002-09-02 09:44:16 UTC
The patch attached to bug #66581 fixes this the correct way.  Currently, each 
successive logical partition appears to be a child of the previous one!

Comment 11 Eric Lau 2002-12-09 23:25:43 UTC
Sorrie this is my first time here and im a linux newbie...
i hav the same prob for hwbrowser and i downloaded the latest version
(hwbrowser-0.6) already but there are no prevails

i wonder if i can hav permission to look at the patch attached in bug #66581
nyway help is greatly appreciated

Comment 12 Brent Fox 2003-01-08 23:15:50 UTC
Eric, I've made bug #66581 public so that you can see the patch.

Comment 13 Brent Fox 2003-01-08 23:18:04 UTC
Actually, I tried to make it public, but Bugzilla wouldn't let me.  I'm
investigating...

Comment 14 Brent Fox 2003-01-10 04:24:23 UTC
Ok, Eric, I've managed to convince Bugzilla to let me make bug #66581 public, so
you should be able to view it now.

Comment 15 Brent Fox 2003-01-10 04:28:37 UTC
Dang Bugzilla.  Now I can't even see the bug.  Argh!

Comment 16 Need Real Name 2003-01-19 06:32:01 UTC
running rh 8.0 with latest latest kernel.  same behavior as described above. 
Using hwbrowser-.6.  Gui appears briefly, then the following trace back with the
first line repeated many times.

(DeviceList.py:2126): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:2126): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed
Traceback (most recent call last):
  File "/usr/share/hwbrowser/DeviceList.py", line 203, in ?
    reread_device_type_list ()
  File "/usr/share/hwbrowser/DeviceList.py", line 150, in reread_device_type_list
    list.set (iter, 0, hardware.get_category_string (key), 1, key)
  File "/usr/share/hwbrowser/DeviceList.py", line 91, in get_category_string
    return self.type_mapping[key]
KeyError: 20


Comment 17 Brent Fox 2003-01-21 06:20:43 UTC
khill: you are seeing a totally different bug (see bug #74956).

Comment 18 Brent Fox 2003-01-21 06:24:09 UTC
twaugh: since I can't see bug #66581 due to some Bugzilla error, can you test
with hwbrowser-0.8-2 and see if that fixes the problem?  If not, I'll try to get
dkl to unbreak Bugzilla so I can see that patch in bug #66581.

Comment 19 Tim Waugh 2003-01-21 10:03:06 UTC
Still unfixed.  This is pretty easily reproducible.  Just make a bunch of
logical partitions and see what hwbrowser looks like:

hda4
|>hda5
 |>hda6
  |>hda7

etc

Comment 20 Brent Fox 2003-02-07 20:27:26 UTC
Patch from bug #66581 applied.  Seems to work fine in hwbrowser-0.8-7.  Thanks
for the patch

QA, please verify.

Comment 21 Brent Fox 2003-05-25 14:30:30 UTC
There is a stack of 64 bugs that have been in Modified state for a long period
of time.  I am closing these as Rawhide now.  If you find that the issue is not
fixed, please reopen this report.


Note You need to log in before you can comment on or make changes to this bug.