Bug 621100 - Failed to install in anaconda
Failed to install in anaconda
Status: CLOSED DUPLICATE of bug 621685
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
: 621817 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-04 05:20 EDT by MingtaoNiu
Modified: 2010-08-06 13:06 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-06 13:06:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Exception Log (147.04 KB, text/plain)
2010-08-05 02:11 EDT, He Rui
no flags Details

  None (edit)
Description MingtaoNiu 2010-08-04 05:20:21 EDT
Description of problem:
In stage 2 of anaconda, encountered an exception with errors about python 2.7 

Version-Release number of selected component (if applicable):
anaconda 14.14
F14-alpha-tc2

How reproducible:
100%

Steps to Reproduce:
1.Boot the system with DVD.iso
  
Actual results:
<report xmlns="http://www.redhat.com/gss/strata"><binding name="localhash">dd5d9121b3d09d62c51159d6dde2a7400f97d3cefe16fbc6f506624182844a89</binding><binding name="product" /><binding name="description">The following was filed automatically by anaconda:
anaconda 14.14 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/pyanaconda/upgrade.py", line 86, in findRootParts
    oldInstalls += " on ".join(info)
  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 212, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 131, in gotoNext
    self.moveStep()
  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1262, in setScreen
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1175, in nextClicked
    self.setScreen ()
TypeError: sequence item 0: expected string, NoneType found
</binding><binding fileName="/tmp/anaconda-tb-CkSL0m" name="pythonUnhandledException" type="text">anaconda 14.14 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/pyanaconda/upgrade.py", line 86, in findRootParts
    oldInstalls += " on ".join(info)
  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 212, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 131, in gotoNext
    self.moveStep()
  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1262, in setScreen
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1175, in nextClicked
    self.setScreen ()
TypeError: sequence item 0: expected string, NoneType found

Local variables in innermost frame:
info: (None, None, 'VolGroup-lv_root')
oldInstalls:
anaconda: &lt;pyanaconda.Anaconda object at 0xb70f650c&gt;
notUpgradable: [(None, None, 'VolGroup-lv_root')]


Expected results:
   1.  Graphical boot menu(isolinux or syslinux) is displayed for users to select install options. If no option is selected, the installer should load after a reasonable timeout
   2. Anaconda boots successfully from the DVD
   3. Anaconda transitions to stage2 without error 

Additional info:
Comment 1 Dave Malcolm 2010-08-04 16:04:42 EDT
Thanks for filing this bug report.

I'm not familiar with the Anaconda code, but this appears to be happening in error handling: it is preparing this error message:
 "Your current installation cannot be upgraded. This "
 "is likely due to it being too old. Only the previous two "
 "release may be upgraded. To upgrade older releases "
 "you must first upgrade through all intermediate releases."

trying to list the older installs that aren't possible.

This looks like an anaconda bug; reassigning.

The exception:
  TypeError: sequence item 0: expected string, NoneType found
is from the join invocation in
    oldInstalls += " on ".join(info)
  File "/usr/lib/python2.7/site-packages/pyanaconda/upgrade.py", line 86, in
findRootParts

All elements of the input iterable must be strings or unicode, but the 0th element of info is None.

notUpgradeable seems to be initialized in storage/__init__.py, findExistingRootDevices, using getReleaseString (by opening /etc/redhat-release), and if that file can't be opened, relName and relVer will both be None; I believe this will trigger the exception you're seeing.

So I believe you'll see this if you have a pre-existing install that has a /etc/fstab but doesn't have a /etc/redhat-release.
Comment 2 Dave Malcolm 2010-08-04 16:09:25 EDT
(I'm fairly sure that "".join didn't change behavior here between python 2.6 and 2.7, fwiw)
Comment 3 Chris Lumens 2010-08-04 16:14:33 EDT
Please attach the complete exception report, preferably in a non-xml format, so we have more context on this error.  Also what OS do you have installed currently, and is there a /etc/fedora-release file?  If so, what are its contents?
Comment 4 He Rui 2010-08-05 02:11:36 EDT
Created attachment 436760 [details]
Exception Log

Reproduced it in both i386 and x86_64 system after it examined the storage devices. Exception Log attached. And there's no /etc/fedora-release file in the system.
Comment 5 Chris Lumens 2010-08-05 09:24:13 EDT
How did you end up in a situation where there's no /etc/fedora-release?
Comment 6 He Rui 2010-08-06 04:03:05 EDT
*** Bug 621817 has been marked as a duplicate of this bug. ***
Comment 7 He Rui 2010-08-06 04:06:35 EDT
(In reply to comment #5)
> How did you end up in a situation where there's no /etc/fedora-release?    

? What does that mean? I turned to console tty2 and found no /etc/fedora-release existed.
Comment 8 Chris Lumens 2010-08-06 09:30:50 EDT
I meant on some previously (possibly corrupted) installed system.  I should have made that clear.  But we know what the problem is and Brian is already looking into it.  I'll reassign this to him so he can mark as a duplicate.
Comment 9 Brian Lane 2010-08-06 13:06:28 EDT

*** This bug has been marked as a duplicate of bug 621685 ***

Note You need to log in before you can comment on or make changes to this bug.