Bug 622164 - [abrt] crash in qgis-1.5.0-3.fc13: isEmpty: Process /usr/bin/qgis was killed by signal 11 (SIGSEGV)
Summary: [abrt] crash in qgis-1.5.0-3.fc13: isEmpty: Process /usr/bin/qgis was killed ...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: qt   
(Show other bugs)
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:603e0a609c14757117250082be3...
Keywords: Reopened
: 622650 625025 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-07 21:01 UTC by Matthieu Pupat
Modified: 2010-12-12 20:05 UTC (History)
12 users (show)

Fixed In Version: qt-4.7.1-5.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-12 20:05:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (48.85 KB, text/plain)
2010-08-07 21:01 UTC, Matthieu Pupat
no flags Details

Description Matthieu Pupat 2010-08-07 21:01:43 UTC
abrt 1.1.1 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: qgis
component: qgis
crash_function: isEmpty
executable: /usr/bin/qgis
global_uuid: 603e0a609c14757117250082be3d20232e3b7459
kernel: 2.6.33.6-147.2.4.fc13.x86_64
package: qgis-1.5.0-3.fc13
rating: 4
reason: Process /usr/bin/qgis was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

How to reproduce
-----
Start qgis

Comment 1 Matthieu Pupat 2010-08-07 21:01:46 UTC
Created attachment 437375 [details]
File: backtrace

Comment 2 Volker Fröhlich 2010-08-07 21:57:24 UTC
Do you use Qt 4.6.3-8? If not, please update to that version.

*** This bug has been marked as a duplicate of bug 498111 ***

Comment 3 Matthieu Pupat 2010-08-08 03:07:17 UTC
qt.x86_64 1:4.6.3-8.fc13

Comment 4 Kevin Kofler 2010-08-08 08:09:43 UTC
Looks like we need to add an additional NULL check to qguieventdispatcher_glib.cpp:97. (So far we added them to lines 79 and 87 of the same file.)

Comment 5 Volker Fröhlich 2010-08-10 07:58:57 UTC
*** Bug 622650 has been marked as a duplicate of this bug. ***

Comment 6 Kevin Kofler 2010-08-22 23:15:51 UTC
*** Bug 625025 has been marked as a duplicate of this bug. ***

Comment 7 Matthieu Pupat 2010-09-24 23:01:30 UTC
Package: qgis-1.5.0-3.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
Open qgis

Comment 8 Volker Fröhlich 2010-09-25 12:18:59 UTC
Matthieu, please provide a backtrace, if possible! You're using Gnome, right?

Comment 9 Kevin Kofler 2010-09-25 13:48:20 UTC
We already have a backtrace, it should be sufficient.

Comment 10 Ngo Than 2010-09-27 15:38:47 UTC
i cannot reproduce the issue with the latest qt-4.7.0-3.fc13,  could you please try the new qt from http://koji.fedoraproject.org/koji/buildinfo?buildID=196716

thanks

Comment 11 Fedora Update System 2010-12-10 01:15:10 UTC
qt-4.7.1-5.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/qt-4.7.1-5.fc14

Comment 12 Fedora Update System 2010-12-10 20:33:32 UTC
qt-4.7.1-5.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qt'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/qt-4.7.1-5.fc14

Comment 13 Fedora Update System 2010-12-12 20:05:22 UTC
qt-4.7.1-5.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.