Bug 622979 - Review Request: libassuan1 - GnuPG IPC v1 library
Review Request: libassuan1 - GnuPG IPC v1 library
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jaroslav Reznik
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 573796
  Show dependency treegraph
 
Reported: 2010-08-10 19:28 EDT by Rex Dieter
Modified: 2010-08-24 21:17 EDT (History)
3 users (show)

See Also:
Fixed In Version: kdepim-4.4.5-2.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-24 21:17:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jreznik: fedora‑review+
tibbs: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2010-08-10 19:28:29 EDT
Spec URL: http://rdieter.fedorapeople.org/rpms/libassuan1/libassuan1.spec
SRPM URL: http://rdieter.fedorapeople.org/rpms/libassuan1/libassuan1-1.0.5-5.fc13.src.rpm
Description:
This is the GnuPG IPC v1 library


This is a compat library for applications not yet ported to use libassuan-2.0.0, see also bug #573796
Comment 1 Rex Dieter 2010-08-10 19:29:46 EDT
Applications still needing libassuan v1 include:
gpa
opensc
kdepim

(I'll take care of patching these to use libassuan1)
Comment 2 Rex Dieter 2010-08-10 19:31:06 EDT
Scratch build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2392240

rpmlint:
$ rpmlint *.rpm x86_64/*.rpm
libassuan1-devel.x86_64: W: obsolete-not-provided libassuan-static
libassuan1-devel.x86_64: W: no-manual-page-for-binary libassuan1-config
2 packages and 0 specfiles checked; 0 errors, 2 warnings.
Comment 3 Jaroslav Reznik 2010-08-11 10:58:07 EDT
Name: ok, compatibility library
Spec: ok
Summary: ok
License: ok, LGPLv2+ and GPLv3+
Sources: ok
c2db0974fcce4401f48f3fa41c4edc5a  libassuan-1.0.5.tar.bz2
167c1838f56f3b85083422668b369f17  libassuan-1.0.5.tar.bz2.sig

Group: ok
BuildRoot: ok
Description: ok
Macros usage: ok

%doc: ok

Static only library, it's ok to include in -devel, correct -static provides.
No .la files included.

Build: local x86_64, Koji

Rpmlint: ok
libassuan1-devel.x86_64: W: obsolete-not-provided libassuan-static

> ok as it obsoletes < 1.0.3 and provides libassuan1

libassuan1-devel.x86_64: W: no-manual-page-for-binary libassuan1-config
1 packages and 0 specfiles checked; 0 errors, 2 warnings.

APPROVED
Comment 4 Rex Dieter 2010-08-11 11:24:27 EDT
New Package SCM Request
=======================
Package Name: libassuan1
Short Description: GnuPG IPC v1 library
Owners: rdieter
Branches: F-14
Comment 5 Jason Tibbitts 2010-08-11 12:14:12 EDT
Git done (by process-git-requests).
Comment 6 Fedora Update System 2010-08-11 15:16:41 EDT
opensc-0.11.13-3.fc14,gpa-0.9.0-1.fc14,libassuan1-1.0.5-5.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/opensc-0.11.13-3.fc14,gpa-0.9.0-1.fc14,libassuan1-1.0.5-5.fc14
Comment 7 Fedora Update System 2010-08-12 15:49:20 EDT
kdepim-4.4.5-2.fc14, opensc-0.11.13-3.fc14, gpa-0.9.0-1.fc14, libassuan1-1.0.5-5.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdepim opensc gpa libassuan1'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/kdepim-4.4.5-2.fc14,opensc-0.11.13-3.fc14,gpa-0.9.0-1.fc14,libassuan1-1.0.5-5.fc14
Comment 8 Fedora Update System 2010-08-24 21:17:05 EDT
kdepim-4.4.5-2.fc14, opensc-0.11.13-3.fc14, gpa-0.9.0-1.fc14, libassuan1-1.0.5-5.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.