Bug 623636 - [abrt] crash in Mayavi-3.3.0-1.fc13: Process /usr/bin/python was killed by signal 11 (SIGSEGV)
[abrt] crash in Mayavi-3.3.0-1.fc13: Process /usr/bin/python was killed by si...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Mayavi (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Rakesh Pandit
Fedora Extras Quality Assurance
abrt_hash:104c795c0af2060ffa5a0437048...
:
: 615539 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-12 07:29 EDT by Phil V
Modified: 2010-08-19 22:26 EDT (History)
2 users (show)

See Also:
Fixed In Version: Mayavi-3.3.2-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-19 22:26:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (104.15 KB, text/plain)
2010-08-12 07:29 EDT, Phil V
no flags Details

  None (edit)
Description Phil V 2010-08-12 07:29:31 EDT
abrt 1.1.1 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/bin/python /usr/bin/mayavi2
component: Mayavi
executable: /usr/bin/python
global_uuid: 104c795c0af2060ffa5a0437048a8226eb98a7fc
kernel: 2.6.33.6-147.2.4.fc13.x86_64
package: Mayavi-3.3.0-1.fc13
rating: 4
reason: Process /usr/bin/python was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

comment
-----
Note i have recently installed python-TraitsBackendWX.noarch
Previously, segmentation fault would happen after error finding "wx.init"

How to reproduce
-----
1. run mayavi2 in gnome-terminal
2.
3.
Comment 1 Phil V 2010-08-12 07:29:33 EDT
Created attachment 438405 [details]
File: backtrace
Comment 2 Chen Lei 2010-08-14 06:12:35 EDT
Don't use WX backend until next weekend, the current Mayavi version is incompatible with latest python-TraitsBackendWX.
Comment 3 Chen Lei 2010-08-14 06:21:51 EDT
*** Bug 615539 has been marked as a duplicate of this bug. ***
Comment 4 Chen Lei 2010-08-14 06:22:11 EDT
*** Bug 615063 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2010-08-15 04:37:01 EDT
Mayavi-3.3.2-1.fc13,python-Traits-3.4.0-1.fc13,python-TraitsGUI-3.4.0-2.fc13,python-TraitsBackendQt-3.4.0-1.fc13,python-TraitsBackendWX-3.4.0-3.fc13,python-EnvisagePlugins-3.1.2-1.fc13,python-EnvisageCore-3.1.2-1.fc13,python-EnthoughtBase-3.0.5-1.fc13,python-AppTools-3.3.2-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/Mayavi-3.3.2-1.fc13,python-Traits-3.4.0-1.fc13,python-TraitsGUI-3.4.0-2.fc13,python-TraitsBackendQt-3.4.0-1.fc13,python-TraitsBackendWX-3.4.0-3.fc13,python-EnvisagePlugins-3.1.2-1.fc13,python-EnvisageCore-3.1.2-1.fc13,python-EnthoughtBase-3.0.5-1.fc13,python-AppTools-3.3.2-1.fc13
Comment 6 Fedora Update System 2010-08-17 01:42:04 EDT
Mayavi-3.3.2-1.fc13, python-Traits-3.4.0-1.fc13, python-TraitsGUI-3.4.0-2.fc13, python-TraitsBackendQt-3.4.0-1.fc13, python-TraitsBackendWX-3.4.0-3.fc13, python-EnvisagePlugins-3.1.2-1.fc13, python-EnvisageCore-3.1.2-1.fc13, python-EnthoughtBase-3.0.5-1.fc13, python-AppTools-3.3.2-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update Mayavi python-Traits python-TraitsGUI python-TraitsBackendQt python-TraitsBackendWX python-EnvisagePlugins python-EnvisageCore python-EnthoughtBase python-AppTools'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/Mayavi-3.3.2-1.fc13,python-Traits-3.4.0-1.fc13,python-TraitsGUI-3.4.0-2.fc13,python-TraitsBackendQt-3.4.0-1.fc13,python-TraitsBackendWX-3.4.0-3.fc13,python-EnvisagePlugins-3.1.2-1.fc13,python-EnvisageCore-3.1.2-1.fc13,python-EnthoughtBase-3.0.5-1.fc13,python-AppTools-3.3.2-1.fc13
Comment 7 Fedora Update System 2010-08-19 22:26:34 EDT
Mayavi-3.3.2-1.fc13, python-Traits-3.4.0-1.fc13, python-TraitsGUI-3.4.0-2.fc13, python-TraitsBackendQt-3.4.0-1.fc13, python-TraitsBackendWX-3.4.0-3.fc13, python-EnvisagePlugins-3.1.2-1.fc13, python-EnvisageCore-3.1.2-1.fc13, python-EnthoughtBase-3.0.5-1.fc13, python-AppTools-3.3.2-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.