Bug 615063 - [abrt] crash in mayavi: killed by signal 11 (SIGSEGV)
Summary: [abrt] crash in mayavi: killed by signal 11 (SIGSEGV)
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Mayavi   
(Show other bugs)
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Rakesh Pandit
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:539a61b04ae023e1fc0cd9196aa...
Keywords: Reopened
: 591693 601416 605630 609407 615068 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-15 20:55 UTC by Phil V
Modified: 2013-01-10 10:43 UTC (History)
13 users (show)

Fixed In Version: Mayavi-3.3.2-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-20 02:26:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (100.82 KB, text/plain)
2010-07-15 20:55 UTC, Phil V
no flags Details

Description Phil V 2010-07-15 20:55:26 UTC
abrt 1.1.1 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/bin/python /usr/bin/ipython
component: ipython
executable: /usr/bin/python
global_uuid: 539a61b04ae023e1fc0cd9196aa0d77e729dcb8e
kernel: 2.6.33.6-147.fc13.x86_64
package: ipython-0.10-5.fc13
rating: 4
reason: Process /usr/bin/python was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

comment
-----
$ ipython
Python 2.6.4 (r264:75706, Jun  4 2010, 18:20:31) 
Type "copyright", "credits" or "license" for more information.

IPython 0.10 -- An enhanced Interactive Python.
?         -> Introduction and overview of IPython's features.
%quickref -> Quick reference.
help      -> Python's own help system.
object?   -> Details about 'object'. ?object also works, ?? prints more.

In [1]: from enthought.mayavi import mlab
Segmentation fault (core dumped)

My installed versions are:

Cython-0.12.1-4.fc13.x86_64
ipython-0.10-5.fc13.noarch
Mayavi-3.3.0-1.fc13.x86_64
pexpect-2.3-4.fc12.noarch
python-foolscap-0.5.1-1.fc13.noarch
python-matplotlib-0.99.1.2-4.fc13.x86_64
python-networkx-1.0.1-1.fc13.noarch
python-nose.noarch 0:0.11.3-1.fc13
python-pygments-1.3.1-2.fc13.noarch
python-setuptools-0.6.13-3.fc13.noarch
python-sphinx-0.6.6-1.fc13.noarch
python-twisted-8.2.0-3.fc12.noarch
scipy-0.7.1-3.fc13.x86_64
sympy-0.6.6-3.fc13.noarch

How to reproduce
-----
1. ipython
2. from enthought.mayavi import mlab

Segmentation fault (core dumped)

Comment 1 Phil V 2010-07-15 20:55:28 UTC
Created attachment 432226 [details]
File: backtrace

Comment 2 Phil V 2010-07-15 20:59:41 UTC
Please note!

export ETS_TOOLKIT=null

was set before running ipython.

Comment 3 Thomas Spura 2010-07-15 21:37:03 UTC
*** Bug 615068 has been marked as a duplicate of this bug. ***

Comment 4 Phil V 2010-07-15 21:48:53 UTC
$ unset ETS_TOOLKIT
$ python -c "from enthought.mayavi import mlab"
Warning: Unable to import the wx backend for pyface due to traceback: Traceback (most recent call last):
	  File "/usr/lib/python2.6/site-packages/enthought/pyface/toolkit.py", line 40, in _init_toolkit
	    __import__(be + 'init')
	ImportError: No module named wx.init

Segmentation fault (core dumped)

$ export ETS_TOOLKIT=null
$ python -c "from enthought.mayavi import mlab"
Segmentation fault (core dumped)

Comment 5 Thomas Spura 2010-07-16 08:13:36 UTC
*** Bug 601416 has been marked as a duplicate of this bug. ***

Comment 6 Thomas Spura 2010-07-16 08:14:53 UTC
*** Bug 605630 has been marked as a duplicate of this bug. ***

Comment 7 Thomas Spura 2010-07-16 08:16:25 UTC
*** Bug 609407 has been marked as a duplicate of this bug. ***

Comment 8 Thomas Spura 2010-07-16 08:24:12 UTC
*** Bug 591693 has been marked as a duplicate of this bug. ***

Comment 9 Thomas Spura 2010-07-16 18:37:05 UTC
I further tracked this down to:
import enthought.tvtk.pyface.light_manager

But I cannot get a full backtrace from abrt...

Maybe the Mayavi owner can help here.
(Assigning to Mayavi)

Comment 10 Didi Hoffmann 2010-07-21 23:42:42 UTC
Package: Mayavi-3.3.0-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
Just start Mayavi and select any value from the dropdown list

Comment
-----
Just start Mayavi and select any value from the dropdown list

Comment 11 Didi Hoffmann 2010-07-21 23:51:34 UTC
A little script that will create the segfault. It looks like the ImportError and the actual Segfault are two different things

$ export ETS_TOOLKIT=null
$ python -c "import enthought.mayavi.core.ui.api"
Segmentation fault (core dumped)

Comment 12 Phil V 2010-07-22 01:56:10 UTC
I think Comment #10 means "start Mayavi from the desktop menu"
which means run the command 
tvtk_doc

which, when run in bash, presents a graphical interface but also reports:

Warning: Unable to import the wx backend for pyface due to traceback: Traceback (most recent call last):
	  File "/usr/lib/python2.6/site-packages/enthought/pyface/toolkit.py", line 40, in _init_toolkit
	    __import__(be + 'init')
	ImportError: No module named wx.init

Segmentation fault (core dumped)    <--- this after selecting in the list.



mayavi2 run in bash just throws the error:

Warning: Unable to import the wx backend for pyface due to traceback: Traceback (most recent call last):
	  File "/usr/lib/python2.6/site-packages/enthought/pyface/toolkit.py", line 40, in _init_toolkit
	    __import__(be + 'init')
	ImportError: No module named wx.init


Segmentation fault (core dumped)

Comment 13 Phil V 2010-07-29 08:23:48 UTC
Package: Mayavi-3.3.0-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. /usr/bin/python /usr/bin/tvtk_doc
2. Select an option in the pulldown menu
3. observe segmentation fault

Comment 14 Chen Lei 2010-08-14 10:22:11 UTC

*** This bug has been marked as a duplicate of bug 623636 ***

Comment 15 Fedora Update System 2010-08-15 08:36:55 UTC
Mayavi-3.3.2-1.fc13,python-Traits-3.4.0-1.fc13,python-TraitsGUI-3.4.0-2.fc13,python-TraitsBackendQt-3.4.0-1.fc13,python-TraitsBackendWX-3.4.0-3.fc13,python-EnvisagePlugins-3.1.2-1.fc13,python-EnvisageCore-3.1.2-1.fc13,python-EnthoughtBase-3.0.5-1.fc13,python-AppTools-3.3.2-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/Mayavi-3.3.2-1.fc13,python-Traits-3.4.0-1.fc13,python-TraitsGUI-3.4.0-2.fc13,python-TraitsBackendQt-3.4.0-1.fc13,python-TraitsBackendWX-3.4.0-3.fc13,python-EnvisagePlugins-3.1.2-1.fc13,python-EnvisageCore-3.1.2-1.fc13,python-EnthoughtBase-3.0.5-1.fc13,python-AppTools-3.3.2-1.fc13

Comment 16 Fedora Update System 2010-08-17 05:41:58 UTC
Mayavi-3.3.2-1.fc13, python-Traits-3.4.0-1.fc13, python-TraitsGUI-3.4.0-2.fc13, python-TraitsBackendQt-3.4.0-1.fc13, python-TraitsBackendWX-3.4.0-3.fc13, python-EnvisagePlugins-3.1.2-1.fc13, python-EnvisageCore-3.1.2-1.fc13, python-EnthoughtBase-3.0.5-1.fc13, python-AppTools-3.3.2-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update Mayavi python-Traits python-TraitsGUI python-TraitsBackendQt python-TraitsBackendWX python-EnvisagePlugins python-EnvisageCore python-EnthoughtBase python-AppTools'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/Mayavi-3.3.2-1.fc13,python-Traits-3.4.0-1.fc13,python-TraitsGUI-3.4.0-2.fc13,python-TraitsBackendQt-3.4.0-1.fc13,python-TraitsBackendWX-3.4.0-3.fc13,python-EnvisagePlugins-3.1.2-1.fc13,python-EnvisageCore-3.1.2-1.fc13,python-EnthoughtBase-3.0.5-1.fc13,python-AppTools-3.3.2-1.fc13

Comment 17 Fedora Update System 2010-08-20 02:26:29 UTC
Mayavi-3.3.2-1.fc13, python-Traits-3.4.0-1.fc13, python-TraitsGUI-3.4.0-2.fc13, python-TraitsBackendQt-3.4.0-1.fc13, python-TraitsBackendWX-3.4.0-3.fc13, python-EnvisagePlugins-3.1.2-1.fc13, python-EnvisageCore-3.1.2-1.fc13, python-EnthoughtBase-3.0.5-1.fc13, python-AppTools-3.3.2-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.