Bug 624752 - Enhancement Request: add VLAN tagging to anaconda
Enhancement Request: add VLAN tagging to anaconda
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
: FutureFeature
: 757911 815081 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-17 12:27 EDT by Randy Goddard
Modified: 2013-06-14 09:46 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-14 09:46:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Randy Goddard 2010-08-17 12:27:02 EDT
Please reference https://bugzilla.redhat.com/show_bug.cgi?id=431915 comment #5 for details.

Description of problem:
In order to network install Fedora or RHEL onto a blade whose NICs are configured with a native non-routeable network, but a routeable VLAN, the VLAN tagging must be added to the initial kickstart file.  However, while the 8021q.ko module has been added to the initrd, anaconda and pykickstart still don't utilize the 'vlanid' parameter.  Could we please add this?

Additional info:
The initial kickstart (and subsequent final ks) would include something like:
label newdiz
  kernel vmlinuz
  append ks=http://rhelinstall.obfuscated.org/server/software/os/linux/rhel5.5/64bitks_newdiz.cfg initrd=initrd.img latecfload noipv6 ip=192.168.48.17 netmask=255.255.255.0 gateway=192.168.48.1 dns=192.168.160.160 vlanid=848
Comment 1 Manuel Faux 2010-08-19 12:37:54 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Radek Vykydal 2011-11-29 05:01:29 EST
*** Bug 757911 has been marked as a duplicate of this bug. ***
Comment 3 Dan Winship 2012-04-23 10:36:58 EDT
*** Bug 815081 has been marked as a duplicate of this bug. ***
Comment 4 Radek Vykydal 2013-06-14 09:46:47 EDT
Support for vlan has been added to F19.

Note You need to log in before you can comment on or make changes to this bug.