Bug 62487 - Starting programs like "gpm" and "links" in a /dev/tty console gives a 'gpm' error
Starting programs like "gpm" and "links" in a /dev/tty console gives a 'gpm' ...
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: gpm (Show other bugs)
skipjack-beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
David Lawrence
:
: 63437 100675 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-01 12:03 EST by Peter van Egdom
Modified: 2007-04-18 12:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-01 12:03:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter van Egdom 2002-04-01 12:03:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020314

Description of problem:
Starting programs like "links" or "mc" in a virtual console gives an error
reported by "gpm" :

*** debug ***: [/usr/src/build/78046-i386/BUILD/gpm-1.20.0/src/liblow.c(202)]:
VC: 0
info: [/usr/src/build/78046-i386/BUILD/gpm-1.20.0/src/liblow.c(446)]:
Warning: closing connection


Running "links" or "mc" as root gives a slightly shorter error message :

*** debug ***: [/usr/src/build/78046-i386/BUILD/gpm-1.20.0/src/liblow.c(202)]:
VC: 0


Disabling "gpm" (/etc/rc.d/init.d/gpm stop) and then running "mc" or "links"
gives another kind of error :

*** debug ***: [/usr/src/build/78046-i386/BUILD/gpm-1.20.0/src/liblow.c(202)]:
VC: 0
info: [/usr/src/build/78046-i386/BUILD/gpm-1.20.0/src/liblow.c(319)]:
/dev/gpmctl: No such file or directory
=== ERROR ===: [/usr/src/build/78046-i386/BUILD/gpm-1.20.0/src/liblow.c(326)]:
/dev/gpmctl: No such file or directory
=== ERROR ===: [/usr/src/build/78046-i386/BUILD/gpm-1.20.0/src/liblow.c(370)]:
Oh, oh, it's an error! possibly I die!


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. go to a virtual console (ctrl-alt-f4).
2. log in 
3. start links with "links 2>foobar"
4. "cat foobar" and observe error

Actual Results:  file called foobar is created with the error from 'gpm'

Expected Results:  Links or Midnight Commander should have started normally
without giving the 'gpm' error

Additional info:

gpm-1.20.0-1
elinks-0.3.0-1
mc-4.5.55-1
Comment 1 Bill Nottingham 2002-04-01 16:22:55 EST
This particular error was fixed in 1.20.0-2.
Comment 2 Mike A. Harris 2004-07-05 18:23:46 EDT
*** Bug 63437 has been marked as a duplicate of this bug. ***
Comment 3 Mike A. Harris 2004-07-05 18:25:20 EDT
*** Bug 100675 has been marked as a duplicate of this bug. ***
Comment 4 Barry K. Nathan 2004-07-05 19:57:12 EDT
There's another annoying gpm error message that still shows up in
aumix. I guess I'll file another bug for it (although I'm not going to
do that yet because I first need to see if someone else has already
filed another bug).

Note You need to log in before you can comment on or make changes to this bug.