Bug 100675 - aumix spews "Oh, oh, it's an error! possibly I die!" nonsense
aumix spews "Oh, oh, it's an error! possibly I die!" nonsense
Status: CLOSED DUPLICATE of bug 62487
Product: Red Hat Linux Beta
Classification: Retired
Component: aumix (Show other bugs)
beta2
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Mike A. Harris
Brock Organ
:
: 109467 (view as bug list)
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-07-24 04:34 EDT by Barry K. Nathan
Modified: 2007-04-18 12:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:57:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
aumix hack to cover up gpm error messages (645 bytes, patch)
2004-03-06 22:47 EST, Barry K. Nathan
no flags Details | Diff

  None (edit)
Description Barry K. Nathan 2003-07-24 04:34:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
When aumix is run from within a GNU screen session (or possibly under other
circumstances, although GNU screen is the only 100% reproducible scenario I've
found), aumix overwrites its own onscreen mixer controls with some totally goofy
error messages.

Version-Release number of selected component (if applicable):
aumix-2.8-6

How reproducible:
Always

Steps to Reproduce:
1. Go to some kind of text console or terminal emulator or whatever.
(gnome-terminal and an actual text virtual console both work.)
2. Run "screen" (or "screen -x" to attach to an existing screen session, or
whatever).
3. Run "aumix".
4. Look at the goofy debug output. It still works though!

Actual Results:  
aumix*** err [libOliblow.c(265)]:<Vol            ++++++++++++O+++++++++++++
       +++++++++++++++O++++++++++strncmp/isdigit/option.consolename failed+
Quit   ++++++++++++O+++++++++++++ Spkr                                    ***
err [lib/liblow.c(374O]:+++++++++++ Line           ++++++++++++O+++++++++++++
Save  RL+++++++++++O++Oh, oh, itRs an error! possibly I die!
Keys  P++++++++++++O+++++++++++++ CD             +++++++++++xO+++++++++++++
Mute   ++++++++++++O+++++++++++++ IGain          ++++++++++++O+++++++++++++
Only  P++++++++++++O+++++++++++++ Line1          ++++++++++++O+++++++++++++
Undo  P                           PhoneIn
      P++++++++++++O+++++++++++++ Video          ++++++++++++O+++++++++++++
       0         Level        100                L        Balance         R
                                                                                
[irrelevant blank lines from copy-and-paste snipped]

Expected Results:  Those pathetic laughter-inducing messages shouldn't be there.

Additional info:

I think these messages started at some point in Rawhide, after the Shrike
release. Maybe this is what bug 98605 was really trying to report. (I'm not 100%
sure that these messages did not exist in the RHL 9 release, though.)
Comment 1 Chris Ricker 2003-09-11 18:51:59 EDT
It does this when run in the VCs as well

There, it displays an additional error about /dev/gpmctl missing, in addition to
the liblow.c errors
Comment 2 Barry K. Nathan 2003-10-12 16:46:32 EDT
Still happening in test 2 (the aumix package is still the same)

FWIW, the problem does not seem to happen on a Mandrake cooker (equivalent to
Mandrake 9.2 right now) system. Mandrake's aumix package (2.8-6mdk) still has
the problem when run on a Fedora Core 0.94 system, though...
Comment 3 Pete Zaitcev 2003-11-09 01:12:06 EST
*** Bug 109467 has been marked as a duplicate of this bug. ***
Comment 4 Barry K. Nathan 2004-03-06 19:37:07 EST
At some point the apostrophe in the error message was corrected (see
bug 109467 for a screenshot), so I've corrected the summary accordingly.

I started actually looking through source code, and I think this bug
may actually be in gpm not in aumix.
Comment 5 Barry K. Nathan 2004-03-06 22:47:39 EST
Created attachment 98352 [details]
aumix hack to cover up gpm error messages

This patch may be a really ugly hack, from a conceptual viewpoint. OTOH it may
also be worth considering.

Right now I'm not sure whether I like this patch; I'm attaching it to this bug
so others can look at the patch and see what they think...

(BTW if the "Patch by..." line in the patch file seems like I'm tooting my own
horn or something, feel free to remove it.)
Comment 6 Mike A. Harris 2004-07-05 18:25:17 EDT

*** This bug has been marked as a duplicate of 62487 ***
Comment 7 Red Hat Bugzilla 2006-02-21 13:57:43 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.