Bug 624971 - Kernel argument with "UUID=" is not honored
Summary: Kernel argument with "UUID=" is not honored
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Keywords:
: 627377 629245 (view as bug list)
Depends On:
Blocks: F14Beta, F14BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2010-08-18 09:27 UTC by He Rui
Modified: 2010-09-03 23:38 UTC (History)
13 users (show)

Fixed In Version: anaconda-14.16-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-03 23:38:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log after manually changing install.img path (3.53 KB, text/plain)
2010-09-02 09:08 UTC, He Rui
no flags Details

Description He Rui 2010-08-18 09:27:19 UTC
Description of problem:
Updated to the newest version of preupgrade on F13 system, preupgrade downloaded files and packages normally, but after reboot, it failed to find install.img and ks file. 

In grub.conf:

title Upgrade to Fedora 14 (Laughlin)
	kernel /upgrade/vmlinuz preupgrade repo=hd::/var/cache/yum/preupgrade stage2=hd:UUID=41ed99ac-a112-4429-8c96-d584dff131a8:/upgrade/install.img ks=hd:UUID=41ed99ac-a112-4429-8c96-d584dff131a8:/upgrade/ks.cfg
	initrd /upgrade/initrd.img

In ks.cfg:

# ks.cfg generated by preupgrade
lang en_US.UTF-8
keyboard us
bootloader --upgrade --location=none
upgrade --root-device=UUID=ef4e416a-d1ce-493b-81d1-62fcc987c5d5
reboot


%post
grubby --remove-kernel=/boot/upgrade/vmlinuz
rm -rf /boot/upgrade /var/cache/yum/preupgrade*
%end



Version-Release number of selected component (if applicable):
preupgrade-1.1.4-1.fc13

How reproducible:
100%
  
Actual results:
Failed to upgrade after reboot

Expected results:
I've encountered the similar bugs in preupgrade-1.1.4-1.fc12, but they are fixed in preupgrade-1.1.7-1.fc12, so preupgrade-1.1.7-1.fc13 should also be pushed to F13 system?

Comment 1 He Rui 2010-08-18 09:41:47 UTC
Mark as beta blocker due to:

The installer must be able to successfully complete an upgrade installation from a clean, fully updated default installation of the previous stable Fedora release, either via preupgrade or by booting to the installer manually

Comment 2 John Ellson 2010-08-25 16:37:36 UTC
Perhaps #627000 could be linked with this blocker bug, and extend the expectation to upgrades of Fedora-13 systems with encrypted file systems.

Comment 3 Andy Lawrence 2010-08-28 01:57:44 UTC
*** Bug 627377 has been marked as a duplicate of this bug. ***

Comment 4 Andy Lawrence 2010-08-28 21:26:52 UTC
With preupgrade-1.1.4-1.fc13.noarch even entering /images instead of /upgrade would not work.  So I installed preupgrade-1.1.7-1.fc12.noarch from Koji and preformed a preupgrade again (without removing the cached files from preupgrade 1.1.4-1).  Still the installer could find the installation images, but hand entering /images worked!

At bit more info in Bug 627377 marked as a duplicate above.

The rest of the install went fine.

Comment 5 Kamil Páral 2010-09-02 08:53:09 UTC
*** Bug 629245 has been marked as a duplicate of this bug. ***

Comment 6 He Rui 2010-09-02 09:05:25 UTC
It turns out that anaconda fails to find install.img and ks.cfg. Reproduced it
on F-13 by both preupgrade and preupgrade-cli.

I further tested this issue, when it failed to find install.img, I manually
input /upgrade/install.img instead of /images/install.img, then anaconda
started.
I referred to anaconda.log on tty2, oddly, it seems that
'stage2=hd:UUID=41ed99ac-a112-4429-8c96-d584dff131a8:/upgrade/install.img' as
well as 'ks=hd:UUID=41ed99ac-a112-4429-8c96-d584dff131a8:/upgrade/ks.cfg' is
not honored since both of these are not mentioned under "kernel command line:"
and anaconda is blaming for "no ‘stage2=’ given" (See attached /tmp/logs).

So is it a anaconda bug?

Comment 7 He Rui 2010-09-02 09:08:08 UTC
Created attachment 442578 [details]
anaconda.log after manually changing install.img path

Comment 8 He Rui 2010-09-02 09:45:38 UTC
Interestingly, if I don't use UUID by changing "UUID=41ed99ac-a112-4429-8c96-d584dff131a8" to "/dev/sda1", it works normally.

Comment 9 He Rui 2010-09-02 10:21:06 UTC
This time I use pxeboot images to test kernel arguments like stage2/repo/ks=hd:UUID=:... and it turns out that as long as "UUID=" is used, anaconda seems to ignore the command line and there's no such input displayed under "kernel command line:" in anaconda.log. But if "UUID=" is replaced by "/dev/sda1", it works well. 

So reassign it against anaconda component.

Comment 10 James Laska 2010-09-02 15:12:04 UTC
According to bcl, the fix to address this issue is - http://git.fedorahosted.org/git/?p=anaconda.git;a=commit;h=943447b8058375c3d8e04d2a354e3868359532a4

Comment 11 Adam Williamson 2010-09-03 16:41:11 UTC
Discussed at today's blocker review meeting, we accepted this bug as a Beta blocker.


Note You need to log in before you can comment on or make changes to this bug.