Bug 625312 - [abrt] Thunar-1.0.2-1.fc13: __strcmp_ssse3: Process /usr/bin/Thunar was killed by signal 11 (SIGSEGV)
[abrt] Thunar-1.0.2-1.fc13: __strcmp_ssse3: Process /usr/bin/Thunar was kille...
Status: CLOSED DUPLICATE of bug 606184
Product: Fedora
Classification: Fedora
Component: thunar-vcs-plugin (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
abrt_hash:119038362bbd465a27cb6ad15ba...
:
: 662313 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-18 23:20 EDT by Zirneklitis
Modified: 2010-12-18 19:37 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-18 19:37:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (76.38 KB, text/plain)
2010-08-18 23:20 EDT, Zirneklitis
no flags Details

  None (edit)
Description Zirneklitis 2010-08-18 23:20:28 EDT
abrt version: 1.1.13
architecture: x86_64
Attached file: backtrace
cmdline: /usr/bin/Thunar --daemon
component: Thunar
crash_function: __strcmp_ssse3
executable: /usr/bin/Thunar
kernel: 2.6.33.6-147.2.4.fc13.x86_64
package: Thunar-1.0.2-1.fc13
rating: 4
reason: Process /usr/bin/Thunar was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)
time: 1282187402
uid: 500

comment
-----
Something wrong with Xfce environment?
There are several programs which are unstable under Xfce but work fine under Gnome
(thunar, seamonkey, fontforge).

How to reproduce
-----
1. The crashes happen unpredictably .
Comment 1 Zirneklitis 2010-08-18 23:20:31 EDT
Created an attachment (id=439571)
File: backtrace
Comment 2 Kevin Fenzi 2010-08-19 00:06:02 EDT
Try: 

rpm -e thunar-vcs-plugin

and see if the crashes stop happening? 

I can't speak to seamonkey, but I also maintain fontforge and haven't seen very many bugs on it. 
Please do file them when and if you are able to duplicate.
Comment 3 Raphael Groner 2010-09-07 16:05:29 EDT
Package: Thunar-1.0.2-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Right click on a file to open context menu
2. No menu, instead crash
3.
Comment 4 Niels de Vos 2010-09-10 09:45:08 EDT
Package: Thunar-1.0.2-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. have a new Thunar window opened (by attaching an USB-stick)
2. do not select anything in the new window
3. right-mouse-click (open menu) in the part where the files are listed (not on a file)
4. crash

Does not seem to happen every time, but frequently enough to get annoyed by it

Comment
-----
Workaround, but I keep forgetting to do it:

first do a left-mouse-click to make the Thunar file-list-component active
Comment 5 Kevin Fenzi 2010-09-10 12:27:20 EDT
Can you guys try the suggestion in comment #2 please?
Comment 6 Raphael Groner 2010-09-10 12:55:10 EDT
(In reply to comment #2)
Kevin, the challenge is that the problem is very difficult to reproduce. It works in most cases without having changed anything. Currently, I can not even reproduce the crash (any more?). Maybe it was fixed by some earlier update, but no guarantee.

thunar-vcs-plugin-0.1.2-2.fc13.x86_64
Thunar-1.0.2-1.fc13.x86_64
Comment 7 Niels de Vos 2010-09-10 13:13:48 EDT
Hi Kevin,

the comments I added went in through ABRT, therefore I did not see your suggestion on uninstalling thunar-vcs-plugin.

Removed the plugin and did some testing. The problem did not occur yet... Will let you know when it happens again (its infrequent anyway).

Possibly you already narrowed the issue down :)

Cheers,
Niels
Comment 8 Raphael Groner 2010-09-22 20:15:51 EDT
Package: Thunar-1.0.2-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. right click on a folder
2.
3.


Comment
-----
maybe due to buggy thunar-vcs-plugin
Comment 9 Raphael Groner 2010-09-23 13:47:52 EDT
Package: Thunar-1.0.2-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. business as usual...
2.
3.
Comment 10 Raphael Groner 2010-09-26 08:01:45 EDT
Package: Thunar-1.0.2-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Right click
2.
3.


Comment
-----
Probably the problem with vcs plugin...
Comment 11 Raphael Groner 2010-12-10 13:46:06 EST
Is this bug reported upstream? Maybe that one ...
http://bugzilla.xfce.org/show_bug.cgi?id=6404
Comment 12 Kevin Fenzi 2010-12-11 15:51:36 EST
I think it's slightly different than that one. ;( 

Bug 468149 does look like a dup of this one... 

I'll try and get it reported upstream.
Comment 13 Kevin Fenzi 2010-12-11 15:52:13 EST
*** Bug 662313 has been marked as a duplicate of this bug. ***
Comment 14 Christoph Wickert 2010-12-11 17:05:58 EST
Reassigning to thunar-vcs-plugin.
Comment 15 bugs0 2010-12-12 13:23:49 EST
Package: Thunar-1.0.2-3.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Select a previously opened File manager
2. Right-click in the empty area
3. Select 'open terminal here' from the context menu

Comment
-----
Attempted to open a terminal from the context menu.
Comment 16 Raphael Groner 2010-12-12 13:39:23 EST
I can not reproduce comment #15. What has the terminal to do with vcs-plugin??
Comment 17 Christoph Wickert 2010-12-12 14:02:11 EST
Nothing, but it's already crashing as soon the right click menu is activated.
Comment 18 Raphael Groner 2010-12-12 14:51:23 EST
To bugs0@sacredsoundsystems.com :
Do you have thunar-vcs-plugin installed?
rpm -q thunar-vcs-plugin
Comment 19 bugs0 2010-12-12 14:54:37 EST
$ rpm -q thunar-vcs-plugin
thunar-vcs-plugin-0.1.2-2.fc13.i686
Comment 20 Christoph Wickert 2010-12-18 19:37:23 EST
Try uninstalling the plugin and tell us if Thunar still crashes.

Further investigation of this crash will take place in bug 606184, because we have a slightly better backtrce there.

*** This bug has been marked as a duplicate of bug 606184 ***

Note You need to log in before you can comment on or make changes to this bug.