Bug 62596 - Please add usbdnet kernel module for Zaurus SL-5500
Please add usbdnet kernel module for Zaurus SL-5500
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
http://www.zauruszone.com/files/usbdn...
: FutureFeature
: 62592 62831 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-02 17:20 EST by Dax Kelson
Modified: 2007-04-18 12:41 EDT (History)
2 users (show)

See Also:
Fixed In Version: FC1 2.4.22-1.2140
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-20 00:15:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch itself, from Spot's e-mail (73.08 KB, patch)
2002-05-30 17:07 EDT, Pete Zaitcev
no flags Details | Diff

  None (edit)
Description Dax Kelson 2002-04-02 17:20:01 EST
From Bugzilla Helper:

Description of problem:
http://www.zauruszone.com/files/usbdnet-patch.gz

This is a completely self contained kernel module for 2.4.17+ that adds support
for "usbdnet".  This is required to connect with the newly released Sharp Zaurus
SL-5500 (linux based) handheld.

The kernel module is used sucessfully by hundreds of of Zaurus owners, and as it
impacts only three files, I believe it is safe (even for late inclusion):

drivers/usb/Config.in
drivers/usb/Makefile
drivers/usb/usbdnet.c  <-- The driver itself
I believe you will get lots of requests for this, as the Zaurus SL-5500 looks to
be *very* popular.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
N/A

The web forums and mailing lists are full of people who have problems manually
patching their kernel.  By adding this module, it is reasonable to assume that
you'll be saving Red Hat tech support from getting lots of call from people, who
don't have the proper skills and end up mucking their kernel/kernel
configuration up.

Actual Results:  N/A

Expected Results:  N/A

Additional info:


The instructions people currently use:

http://www.zauruszone.com/cgi-bin/ikonboard.cgi?s=3caa0d576116ffff;act=ST;f=14;t=10
Comment 1 Dax Kelson 2002-04-02 17:22:06 EST
I own a Zaurus SL-5500 (it arrived yesterday).  This would be very helpful to me
personally. It is great product!
Comment 2 Pete Zaitcev 2002-04-05 17:49:30 EST
*** Bug 62831 has been marked as a duplicate of this bug. ***
Comment 3 Pete Zaitcev 2002-04-05 17:55:42 EST
*** Bug 62592 has been marked as a duplicate of this bug. ***
Comment 4 Pete Zaitcev 2002-04-05 18:01:35 EST
Errata material, maybe.
Comment 5 Pete Zaitcev 2002-05-30 17:07:41 EDT
Created attachment 59004 [details]
Patch itself, from Spot's e-mail
Comment 6 Richard Torkar 2002-10-06 08:55:03 EDT
Love to see this in the next kernel released for Red Hat 8.0!
:)

/Richard
Comment 7 Pete Zaitcev 2002-10-18 18:06:12 EDT
Pavel Machek posted a patch to add the Zaurus support to usbnet,
so far for 2.5 only.
 http://marc.theaimsgroup.com/?l=linux-usb-devel&m=103497713029447&w=2
Comment 8 Need Real Name 2003-02-07 20:00:52 EST
Uhh ... me too, me too.  Is there a better way to make Redhat aware
of user demand for a feature?  Voting for features or somesuch?
Comment 9 Emmanuel Galanos 2003-02-23 23:54:26 EST
Another location of patches is:

http://www.ruault.com/Zaurus/patches/

They probably apply in a cleaner fashion.
Comment 10 Pete Zaitcev 2003-04-02 15:58:23 EST
Dax, I saw your review at gurulabs. Upstream to the rescue. Closing.
Comment 11 Need Real Name 2003-04-02 18:07:20 EST
Mr. Zaitcev, can you give just a little bit more detail, please?  Are you
suggesting that this is fixed in RH9?

I assume you are referring to the article at
http://www.gurulabs.com/RedHatLinux9-review.html ... I don't see where that
article mentions this problem specifically.
Comment 12 Pete Zaitcev 2003-04-02 18:16:31 EST
Dax commented it out of the review an hour ago, perhaps something broke.
No e-mail or other communication from him so far.

Anyhow, usbdnet is not going in. Pavel changed usbnet, but apparently
that one is not in either. David-B is fixing CDCEther
to support Zaurus framing, I saw a new 2.5 changeset today.
I am not exactly sure what the status is. Should work.
Comment 13 Dax Kelson 2003-04-02 18:21:07 EST
Well, I did have mention in the review briefly, then I noticed on closer
inspection that it doesn't work. :(

dmesg output:

hub.c: new USB device 00:1d.0-1, assigned address 17
CDCEther.c: Found Header descriptor, CDC version 110.
CDCEther.c: Imperfect filtering support - need sw hashing
CDCEther.c: Can't use SetEthernetMulticastFilters request
CDCEther.c: detected BULK OUT packets of size 64
divert: allocating divert_blk for eth2
CDCEther.c: eth2: Sharp SL Series
CDCEther.c: eth2: 40:00:02:00:00:01

When I try to trasmit any traffic, I get:

eth1: Undersized frame received (0 bytes)
eth1: Undersized frame received (0 bytes)
eth1: Undersized frame received (0 bytes)

So, no. It isn't working yet.
Comment 14 Pete Zaitcev 2004-01-19 23:46:00 EST
Does Fedora work?
Comment 15 Dax Kelson 2004-01-19 23:51:37 EST
It does work with a little bit of hotplug configuration changes, this
can be closed.

Note You need to log in before you can comment on or make changes to this bug.