Bug 62653 - Gimp segfault when i press wacom stylus on the tablet
Gimp segfault when i press wacom stylus on the tablet
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: gimp (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
David Lawrence
:
Depends On:
Blocks: 61901 67218 79579 CambridgeTarget
  Show dependency treegraph
 
Reported: 2002-04-03 14:48 EST by Anvil
Modified: 2007-04-18 12:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-06 04:42:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anvil 2002-04-03 14:48:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020314

Description of problem:
I got an usb a6 wacom intuos tablet and i think i have configured it correctly
but gimp segfault when i press the tablet..

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Configure X (see http://confiote.ath.cx/~anvil/XF86Config-4)
2. gimp &
3. ctrl-n, enter. 
4. In the gimp, File Menu -> dialogs -> Input device : enable the stylus.
5. In the gimp, File Menu -> dialogs -> Device status : choose pencil for the
wacom stylus.
6. assume the stylus is enabled in the gimp
7. Press the tablet with the stylus in the new image.

Actual Results:  Gimp --> Segfault

Expected Results:  Should Draw something


Additional info:

See my Xconfiguration at : http://confiote.ath.cx/~anvil/XF86Config-4
If it can help, see gimp strace at :
http://confiote.ath.cx/~anvil/gimpstrace.log.bz2 (about 300ko in bz2, 20Mo if
uncompressed).
Bug was also present in enigma.
Is my X configuration wrong ?
Comment 1 Matt Wilson 2002-04-03 16:38:13 EST
please run the gimp under gdb by doing:

gdb gimp
run

When the crash happens, type 'bt' and press return.  Send me the output.
Comment 2 Matt Wilson 2002-04-03 19:51:33 EST
I've just tested this on a wacom Intuos2 9x12 and it works fine for me here.
Comment 3 Anvil 2002-04-04 00:13:07 EST
Starting program: /usr/bin/gimp-1.2 
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...
Program received signal SIGSEGV, Segmentation fault.
0x40339e27 in sYSMALLOc () from /lib/i686/libc.so.6
(gdb) bt
#0  0x40339e27 in sYSMALLOc () from /lib/i686/libc.so.6
#1  0x4033b1b3 in _int_malloc () from /lib/i686/libc.so.6
#2  0x4033a39b in malloc () from /lib/i686/libc.so.6
#3  0x4019d8bc in g_malloc () from /usr/lib/libglib-1.2.so.0
#4  0x08159744 in temp_buf_new ()
#5  0x0815998a in temp_buf_resize ()
#6  0x08122038 in paint_core_get_paint_area ()
#7  0x081373da in tools_free_pencil ()
#8  0x081372b6 in pencil_paint_func ()
#9  0x081208fb in paint_core_button_press ()
#10 0x080afeed in gdisplay_canvas_events ()
#11 0x400b8aec in gtk_marshal_BOOL__POINTER () from /usr/lib/libgtk-1.2.so.0
#12 0x400ec436 in gtk_handlers_run () from /usr/lib/libgtk-1.2.so.0
#13 0x400eb76d in gtk_signal_real_emit () from /usr/lib/libgtk-1.2.so.0
#14 0x400e9525 in gtk_signal_emit () from /usr/lib/libgtk-1.2.so.0
#15 0x40123868 in gtk_widget_event () from /usr/lib/libgtk-1.2.so.0
#16 0x400b8a45 in gtk_propagate_event () from /usr/lib/libgtk-1.2.so.0
#17 0x400b7a6f in gtk_main_do_event () from /usr/lib/libgtk-1.2.so.0
#18 0x40169d7f in gdk_event_dispatch () from /usr/lib/libgdk-1.2.so.0
#19 0x4019c773 in g_main_dispatch () from /usr/lib/libglib-1.2.so.0
#20 0x4019cd39 in g_main_iterate () from /usr/lib/libglib-1.2.so.0
#21 0x4019ceec in g_main_run () from /usr/lib/libglib-1.2.so.0
#22 0x400b7333 in gtk_main () from /usr/lib/libgtk-1.2.so.0
#23 0x081111bf in main ()
#24 0x402d5df9 in __libc_start_main () from /lib/i686/libc.so.6

Is Your intuos USB ? i got a usb mouse too, can there be a conflict or something
like that ? Can you send me you XF86Config-4 ?
What kernel module should be loaded (i got hid, usbcore, wacom, evdev, usb-uhci,
usbmouse, mousedev and input) ?
Comment 4 Matt Wilson 2002-04-04 11:26:07 EST
I've tested with a usb wacom + ps/2 mouse, and a usb wacom + usb trackball.

I will try to reproduce it with the pencil tool (don't think I've tried that one).
Comment 5 Matt Wilson 2002-08-20 09:45:26 EDT
still unable to reproduce this bug on the tablets we have here.
Comment 6 Need Real Name 2002-10-22 09:04:15 EDT
I've seen this before- if you set the modes of the cursors/etc. to WINDOW, it
crashes, but if you set them to SCREEN, it works fine.

Using: 
WACOM GRAPHIRE 2
Redhat 8.0 Release + Standard Gimp

relevant X11 config:

Section "InputDevice"
        Identifier  "Stylus0"
        Driver      "wacom"
        Option      "type"   "stylus"
        Option      "Mode" "absolute"
        Option      "USB" "on"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/input/event0"
        Option      "ZAxisMapping" "5 4"
        Option      "Emulate3Buttons" "no"
EndSection

Section "InputDevice"
        Identifier  "Cursor0"
        Driver      "wacom"
        Option      "type"          "cursor"
        Option      "Mode" "absolute"
        Option      "USB" "on"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/input/event0"
        Option      "ZAxisMapping" "5 4"
        Option      "Emulate3Buttons" "no"
EndSection

Section "InputDevice"
        Identifier  "Eraser0"
        Driver      "wacom"
        Option      "type"          "eraser"
        Option      "Mode" "absolute"
        Option      "USB" "on"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/input/event0"
        Option      "ZAxisMapping" "5 4"
        Option      "Emulate3Buttons" "no"
EndSection
Comment 7 Nils Philippsen 2004-08-06 04:42:09 EDT
Please confirm whether or not this bug is still there in current GIMP
versions, until then I'll close this.

Note You need to log in before you can comment on or make changes to this bug.