Bug 627890 - [abrt] ucview-0.31-1.fc13: theora_encode_header: Process /usr/bin/ucview was killed by signal 11 (SIGSEGV)
Summary: [abrt] ucview-0.31-1.fc13: theora_encode_header: Process /usr/bin/ucview was ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libucil
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kamil Dudka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:75b6de4e1a115913d438ce36c24...
: 587800 637537 (view as bug list)
Depends On:
Blocks: 635645
TreeView+ depends on / blocked
 
Reported: 2010-08-27 10:09 UTC by chuck elliot
Modified: 2010-10-05 13:17 UTC (History)
2 users (show)

Fixed In Version: libucil-0.9.8-5.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 635645 (view as bug list)
Environment:
Last Closed: 2010-09-24 20:37:13 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (13.96 KB, text/plain)
2010-08-27 10:09 UTC, chuck elliot
no flags Details

Description chuck elliot 2010-08-27 10:09:01 UTC
abrt version: 1.1.13
architecture: x86_64
Attached file: backtrace
cmdline: ucview
component: ucview
crash_function: theora_encode_header
executable: /usr/bin/ucview
kernel: 2.6.33.8-149.fc13.x86_64
package: ucview-0.31-1.fc13
rating: 4
reason: Process /usr/bin/ucview was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)
time: 1282903397
uid: 500

comment
-----
This is a repeat of bug 587800 but as I am now running Fedora 13 (old bug on 12) I thought it 
better to register a 'new' bug.

How to reproduce
-----
1. select Celestron NexImage camera
2. start recording.
3.

Comment 1 chuck elliot 2010-08-27 10:09:04 UTC
Created an attachment (id=441456)
File: backtrace

Comment 2 Kamil Dudka 2010-08-27 10:36:38 UTC
*** Bug 587800 has been marked as a duplicate of this bug. ***

Comment 3 Kamil Dudka 2010-08-27 11:03:56 UTC
 chuck elliot      2010-08-27 12:43:03 CEST

libucil-0.9.8-2.fc13.x86_64
libunicap-0.9.8-1.fc13.x86_64
libunicapgtk-0.9.8-1.fc13.x86_64
ucview-0.31-1.fc13.x86_64

Comment 4 Kamil Dudka 2010-09-15 12:03:39 UTC
Return value of theora_encode_init() should be checked:

diff --git a/src/ucil_theora.c b/src/ucil_theora.c
--- a/src/ucil_theora.c
+++ b/src/ucil_theora.c
@@ -1556,7 +1556,11 @@ ucil_theora_video_file_object_t *ucil_theora_create_video_filev( const char *pat
    
 #endif
 
-   theora_encode_init( &vobj->th, &vobj->ti );   
+   if( theora_encode_init( &vobj->th, &vobj->ti ) != 0)
+   {
+      free( vobj );
+      return NULL;
+   }
 
    vobj->full_queue = g_queue_new();
    vobj->empty_queue = g_queue_new();

Comment 5 Fedora Update System 2010-09-15 12:36:17 UTC
libucil-0.9.8-5.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/libucil-0.9.8-5.fc14

Comment 6 Fedora Update System 2010-09-15 12:36:29 UTC
libucil-0.9.8-4.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/libucil-0.9.8-4.fc13

Comment 7 Fedora Update System 2010-09-15 22:35:40 UTC
libucil-0.9.8-4.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libucil'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/libucil-0.9.8-4.fc13

Comment 8 Fedora Update System 2010-09-19 20:19:11 UTC
libucil-0.9.8-3.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/libucil-0.9.8-3.fc12

Comment 9 Fedora Update System 2010-09-24 20:37:03 UTC
libucil-0.9.8-4.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Kamil Dudka 2010-09-26 13:40:53 UTC
*** Bug 637537 has been marked as a duplicate of this bug. ***

Comment 11 Fedora Update System 2010-09-30 10:28:55 UTC
libucil-0.9.8-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2010-10-05 13:17:36 UTC
libucil-0.9.8-5.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.