Bug 628182 - [abrt] gthumb-2.11.5-1.fc13: raise: Process /usr/bin/gthumb was killed by signal 6 (SIGABRT)
Summary: [abrt] gthumb-2.11.5-1.fc13: raise: Process /usr/bin/gthumb was killed by sig...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: exiv2
Version: 14
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:12a4c645e65d05b226d52c97226...
: 628671 644754 647236 657900 663497 672078 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-28 12:28 UTC by Radek Vokál
Modified: 2011-02-24 20:58 UTC (History)
10 users (show)

Fixed In Version: exiv2-0.20-3.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-02-24 20:58:14 UTC


Attachments (Terms of Use)
File: backtrace (113.36 KB, text/plain)
2010-08-28 12:28 UTC, Radek Vokál
no flags Details


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 640268 None None None Never

Internal Links: 678698

Description Radek Vokál 2010-08-28 12:28:19 UTC
abrt version: 1.1.13
architecture: i686
Attached file: backtrace
cmdline: gthumb /home/radek/Desktop/Tipo/Small/IMG_0911.JPG
component: gthumb
crash_function: raise
executable: /usr/bin/gthumb
kernel: 2.6.33.6-147.2.4.fc13.i686
package: gthumb-2.11.5-1.fc13
rating: 4
reason: Process /usr/bin/gthumb was killed by signal 6 (SIGABRT)
release: Fedora release 13 (Goddard)
time: 1282998330
uid: 500

How to reproduce
-----
1. Open image (height bigget than width)
2. Try to resize it (width bigger than height)
3. Observe crash

Comment 1 Radek Vokál 2010-08-28 12:28:22 UTC
Created an attachment (id=441677)
File: backtrace

Comment 2 Christian Krause 2010-08-28 13:25:19 UTC
- Can you reproduce the problem?

- Does it still happen with the update in updates-testing:
https://admin.fedoraproject.org/updates/gthumb-2.11.90-3.fc13 (If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gthumb').

- Can you provide a picture which causes the problem?

Comment 3 Radek Vokál 2010-08-30 17:32:32 UTC
*** Bug 628671 has been marked as a duplicate of this bug. ***

Comment 4 Radek Vokál 2010-08-30 17:32:43 UTC
Still same, will send the picture as well

gthumb: tiffcomposite.cpp:1141: virtual uint32_t Exiv2::Internal::TiffDirectory::doWrite(Exiv2::Internal::IoWrapper&, Exiv2::ByteOrder, int32_t, uint32_t, uint32_t, uint32_t&): Předpoklad „sv == d“ nesplněn.

Comment 5 Radek Vokál 2010-08-30 17:36:53 UTC
The steps to reproduce are different. 

1. Mark set of images - some of them are 4:3, some 3:4 .. 
2. Hit tools, resize images - select 640x480 a rewrite target
3. When it get to first image in 3:4 it crashes

Comment 6 Christian Krause 2010-09-05 19:45:49 UTC
(In reply to comment #4)
> Still same, will send the picture as well

Please can you attach the pictures or provide a link to download them? Thanks!

Comment 7 Karel Klíč 2010-11-08 18:09:07 UTC
*** Bug 644754 has been marked as a duplicate of this bug. ***

Comment 8 Michael J. Chudobiak 2011-01-27 14:04:26 UTC
Please supply a sample image and procedure that triggers this crash.

- Mike

Comment 9 Michael J. Chudobiak 2011-01-27 14:04:35 UTC
*** Bug 657900 has been marked as a duplicate of this bug. ***

Comment 10 Michael J. Chudobiak 2011-01-27 14:04:41 UTC
*** Bug 663497 has been marked as a duplicate of this bug. ***

Comment 11 Michael J. Chudobiak 2011-01-27 14:04:47 UTC
*** Bug 672078 has been marked as a duplicate of this bug. ***

Comment 12 Michael J. Chudobiak 2011-01-27 14:19:05 UTC
*** Bug 647236 has been marked as a duplicate of this bug. ***

Comment 13 patrick.guio 2011-01-29 17:05:01 UTC
Package: gthumb-2.12.1-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. trying to rest the exif date tag to the date picture taken
2.
3.

Comment 14 Michael J. Chudobiak 2011-02-01 15:38:35 UTC
Re-assigning to exiv2.

exiv2 bug report:
http://dev.exiv2.org/issues/752

Please patch the F14 exiv2 rpm with this upstream patch:
http://dev.exiv2.org/attachments/230/bug752-exiv2-0.20.patch

For F15, a 0.21.1 release is supposed to be made upstream in the middle of February. Or the 0.21.x patch can be pulled in:

http://dev.exiv2.org/projects/exiv2/repository/revisions/2435/diff?format=diff&rev_to=2434

This crasher bug is known to affect both gThumb and Shotwell.

- Mike

Comment 15 Ferry Huberts 2011-02-06 22:31:50 UTC
Package: gthumb-2.12.1-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.when downloading pictures from sd card, often happens to crash, sometimes in the middle of the download, sometimes before the last picture, sometime after the last picture before starting the overview window
2.
3.

Comment 16 Fedora Update System 2011-02-15 13:58:32 UTC
exiv2-0.20-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/exiv2-0.20-3.fc14

Comment 17 Fedora Update System 2011-02-15 21:27:42 UTC
exiv2-0.20-3.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update exiv2'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/exiv2-0.20-3.fc14

Comment 18 collura 2011-02-18 22:06:28 UTC
had a problem with the update dependency and got filed as 

  https://bugzilla.redhat.com/show_bug.cgi?id=678698

and noted in 

  https://admin.fedoraproject.org/updates/exiv2-0.20-3.fc14

Comment 19 Fedora Update System 2011-02-24 20:58:08 UTC
exiv2-0.20-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.