Bug 62911 - Galeon crashes when Settings->Preferences is chosen
Galeon crashes when Settings->Preferences is chosen
Status: CLOSED DUPLICATE of bug 62944
Product: Red Hat Public Beta
Classification: Retired
Component: galeon (Show other bugs)
skipjack-beta2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
:
: 62874 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-07 12:37 EDT by Scott Dowdle
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-15 14:28:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Dowdle 2002-04-07 12:37:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; Linux 2.4.18-0.13 i686)

Description of problem:
Running Galeon in both GNOME and KDE, attempting to go into
Settings->Preferences makes the program crash... window closes... no process
running.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Open galeon
2.  Select Settings->Preferences
3.  Program closes
	

Expected Results:  Settings dialog window should open for access to program
settings.

Additional info:

Running it from the command line I get:

[dowdle@upstairs dowdle]$ galeon

Gdk-WARNING **: locale not supported by Xlib, locale set to C
IDN support disabled
escape UTF-8 enabled

Gdk-WARNING **: locale not supported by Xlib, locale set to C

GnomeUI-ERROR **: file gnome-icon-item.c: line 375 (get_default_font): assertion
failed: (default_font != NULL)
aborting...
Aborted
[dowdle@upstairs dowdle]$
Comment 1 Jeremy Katz 2002-04-07 15:55:18 EDT
Probably related to bug 68244.  Does it work better if you change LANG in
/etc/sysconfig/i18n to en_US and completely restart your X session (including
restarting gdm)
Comment 2 Jeremy Katz 2002-04-07 15:58:31 EDT
*** Bug 62874 has been marked as a duplicate of this bug. ***
Comment 3 Warren Togami 2002-04-08 04:30:14 EDT
I was unable to reproduce this crash on my system.  When I run galeon in     
konsole I only get these messages on my system:     
     
IDN support disabled     
escape UTF-8 enabled     
     
I don't know if this makes any difference, but I have Japanese support     
installed.  Here are the contents of my /etc/sysconfig/i18n:     
    
LANG="en_US"    
SUPPORTED="en_US:en:ja_JP.eucJP:ja_JP:ja"    
SYSFONT="lat0-sun16"    
SYSFONTACM="iso01"    
   
dowdle@b-squared.net, what is your LANG currently set to?
Comment 4 Scott Dowdle 2002-04-10 21:21:55 EDT
I edited /etc/sysconfig/i18n and changed the line that read:

LANG="en_US.iso885915"

to read

LANG="en_US"

...and restarted X (and KDM)... and yes that took care of the problem.  For the
record, this was from a completely clean install with a formatted / and /home
directory so it wasn't a matter of a crufty, stale config file somewhere. 
That's how Skipjack beta 2 configured it.  I installed "Workstation" and
selected all of the top level groups (GNOME, KDE, DEVEL, and GAMES, right?).

Not trying to gripe, just trying to be informative... and I'm glad you came up
with a solution so quickly.

Settings->Preferences works great now!
Comment 5 Need Real Name 2002-04-12 22:03:02 EDT
um...i did what recommended fix above, but i still have the problem
I get the exact same error
Comment 6 Dana Canfield 2002-04-14 16:37:27 EDT
Making the change in /etc/sysconfig/i18n did not work for me, either.  Someone
mentioned something about japanese support... I've removed several of the rpms
that said they provided japanese support (these used to cause dependency
problems, but since they didn't anymore I assumed it was safe to get rid of them
now).  Could that be a factor.

I have run the up2date program and have all of the latest packages as of this
4/14 (and BTW... the new splash screens and such in the updated RPMs look great.).
Comment 7 Need Real Name 2002-04-15 14:28:35 EDT
i did the skipjack installation
workstation > gnome + devel
the only things i've changed is, i've updated gaim to 0.56 and i installed the 
kernel-source and i've installed the nvidia drivers NVIDIA_kernel and NVIDIA_GLX

then i did a fresh installation and i didn't install any files or update 
anything. i went straight to the choose locale and changed it to en_US. but it 
still crashes. i just updated all of the packages via up2date without adding 
anything and the same result.
Comment 8 Preston Brown 2002-07-23 14:47:07 EDT

*** This bug has been marked as a duplicate of 62944 ***

Note You need to log in before you can comment on or make changes to this bug.