Bug 630095 - rhnreg_ks fails with Assertion error from file 'dmidecode.c'
rhnreg_ks fails with Assertion error from file 'dmidecode.c'
Status: CLOSED DUPLICATE of bug 583867
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Registration (Show other bugs)
540
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Mráka
Red Hat Satellite QA List
:
Depends On:
Blocks: sat540-triage
  Show dependency treegraph
 
Reported: 2010-09-03 13:17 EDT by Pavel Novotny
Modified: 2011-04-15 12:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-07 08:57:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Clifford Perry 2010-09-06 10:30:14 EDT
This is a CLIENT bug, please report it as such. 

I am 100% if you tried the same test to a RHN Hosted or Sat 5.3 code base, the same error would occur. 

Using a no hardware or skip hardware option should by-pass this bug to allow registration to complete.

Cliff
Comment 2 Michael Mráka 2010-09-06 10:47:21 EDT
htps://www.redhat.com/archives/spacewalk-list/2010-September/msg00034.html

To all developers reading this I have discovered the route of the problem but could probably do with some sort of workaround for others;

Basically as you know, when the system attaches itself to the server it collects a load of  hardware information, this calls upon dmidecode which scans /dev/mem.

The error although seemingly random seemed to happen on boxes that had a loud of dodgy information in /dev/mem. I could get the servers connecting to spacewalk by deleting the /dev/mem device (or renaming it for the rhnreg_ks command and then rename it back).

I think there should be a workaround for this since this information was nowhere on the internet. Should I raise a bug report since this was happening to me 1 in 4 servers.

Cheers,
Chris
Comment 4 Michael Mráka 2010-09-07 04:45:00 EDT
Please report version of dmidecode and python-dmidecode.
Comment 5 Pavel Novotny 2010-09-07 08:57:30 EDT
Package versions:
python-dmidecode-3.10.8-4.el5
dmidecode-2.10-3.el5

BUT..

I found out this bug has been already fixed in bug 596133 in python-dmidecode-3.10.13-1.el5_5.1 and related errata RHBA-2010:9824-04 has been verified.
Now it is waiting for release. 

I am closing this bug as duplicate of bug 583867.

*** This bug has been marked as a duplicate of bug 583867 ***

Note You need to log in before you can comment on or make changes to this bug.